SQL Server Management Studio Backwards Compatibility



By:

SSMS Backwards Compatibility

SQL Server Management Studio is backward compatible and it is always recommended to use the latest version even if you are connecting to older versions of SQL Server such as SQL Server 2008. 

At the time of writing this tutorial, SSMS 18.4 was the latest release in November, 2019 and we will be using this version in this tutorial. Version 18.4 will work with SQL Server 2008 through SQL Server 2019.

Also, it is fine to have slightly older versions such as 17.X since these later versions support a lot of the newer features and also support Azure SQL database, but if possible it is always best to use the latest version.

To find the version in SSMS, select menu items Help > About and the following will open.

SSMS 18.4

Last Update: 2/5/2020






Comments For This Article





download








get free sql tips
agree to terms


Learn more about SQL Server tools