
<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta http-equiv="Content-Language" content="en-us" />
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

<link rel="SHORTCUT ICON" href="/favicon.ico" />
<meta content="width=device-width, initial-scale=1.0" name="viewport" />
<title>Capturing SQL Server Deadlocks using Extended Events</title>
<meta name="description" content="In this tip we look at how to capture deadlocks that occur in SQL Server and the associated information to help troubleshoot.  We look at how to do this using the GUI and T-SQL code." />
<link rel="canonical" href="https://www.mssqltips.com/sqlservertip/5658/capturing-sql-server-deadlocks-using-extended-events/" />
<link rel="stylesheet" href="/css/foundation-app-combined-min.css">
<script>/*! loadCSS. [c]2017 Filament Group, Inc. MIT License */!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mssqltips.com/sqlservertip/5658/capturing-sql-server-deadlocks-using-extended-events/"
  },
  "headline": "Capturing SQL Server Deadlocks using Extended Events",
  "image": [
  
    "https://www.mssqltips.com/images_newsletter/5658_NewsletterImage.png"
  
   ],  
  "datePublished": "2018-10-01T00:00:00+05:00",
  "dateModified": "2022-08-03T00:00:00+05:00",
  "author": {
    "@type": "Person",
    "name": "Eduardo Pivaral"
  },
   "publisher": {
    "@type": "Organization",
    "name": "MSSQLTips",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.mssqltips.com/images/mslogo_113x60.png"
    }
  },
  "description": "In this tip we look at how to capture deadlocks that occur in SQL Server and the associated information to help troubleshoot.  We look at how to do this using the GUI and T-SQL code."
}
</script>
<meta property="og:url" content="https://www.mssqltips.com/sqlservertip/5658/capturing-sql-server-deadlocks-using-extended-events/" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Capturing SQL Server Deadlocks using Extended Events" />
<meta property="og:description" content="In this tip we look at how to capture deadlocks that occur in SQL Server and the associated information to help troubleshoot.  We look at how to do this using the GUI and T-SQL code." />
<meta property="og:image" content="https://www.mssqltips.com/images_newsletter/5658_NewsletterImage.png" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mssqltips">
<meta name="twitter:creator" content="@mssqltips">
<meta name="twitter:title" content="Capturing SQL Server Deadlocks using Extended Events">
<meta name="twitter:description" content="In this tip we look at how to capture deadlocks that occur in SQL Server and the associated information to help troubleshoot.  We look at how to do this using the GUI and T-SQL code.">
<meta name="twitter:image" content="https://www.mssqltips.com/images_newsletter/5658_NewsletterImage.png">
<script>

var head = document.getElementsByTagName('head')[0];
var js = document.createElement("script");

js.type = "text/javascript";

if (screen.width > 749)
{
    js.src = "https://securepubads.g.doubleclick.net/tag/js/gpt.js";
}
head.appendChild(js);

if (screen.width > 749)
{

!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

apstag.init({
  pubID: '434bb5e4-3704-4b75-b36c-785a444462bd',
  adServer: 'googletag',
  simplerGPT: true,
  schain: {
    complete: 1,
    ver: '1.0',
    nodes: [
      {
        asi: 'theadengine.com',
        sid: '01307',
        hp: 1,
      },
    ],
  },
});

window.googletag = window.googletag || {cmd: []};

googletag.cmd.push(function() {

   var mapping = googletag.sizeMapping().
   addSize([100, 100], []).
   addSize([320, 400], []).
   addSize([320, 700], []).
   addSize([750, 200],  [[728, 90],[300,250],[160,300],[300,600],[170,90]]).
   addSize([1050, 200], [[728, 90],[300,250],[160,300],[300,600],[170,90]]).build();

   var mapping728 = googletag.sizeMapping()
     .addSize([750, 200], [728, 90])
     .addSize([0, 0], [])
     .build();
   var mapping300 = googletag.sizeMapping()
     .addSize([640, 400], [300, 250])
     .addSize([0, 0], [])
     .build();
   var mapping600 = googletag.sizeMapping()
     .addSize([640, 600], [[160,600],[300,600]])
     .addSize([0, 0], [])
     .build();
   var mapping170 = googletag.sizeMapping()
     .addSize([640, 400], [170,90])
     .addSize([0, 0], [])
     .build();   
   
   
 
   googletag.defineSlot('/53998264/160x600-Primary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-0').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/160x600-Secondary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-1').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Primary', [300, 250], 'div-gpt-ad-1388505177750-2').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Secondary', [300, 250], 'div-gpt-ad-1388505177750-3').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/728x90-Primary', [728, 90], 'ad-slot-leader').defineSizeMapping(mapping728).addService(googletag.pubads()); 
   
   googletag.pubads().setTargeting('SyncFusion','DBA');

   // googletag.pubads().enableLazyLoad();
   googletag.pubads().disableInitialLoad();
   googletag.pubads().collapseEmptyDivs();
   googletag.enableServices();
});


googletag.cmd.push(function(){ 
  apstag.fetchBids({ 
  timeout: 2000 }, 
    function(bids) {
      apstag.setDisplayBids(); 
      googletag.pubads().refresh();
  }); 
}); 

}

</script>
</head>
<body onload="PR.prettyPrint()" style="background-color:white;">
<a name="top"></a>

<div name="container" id="container">
<div class="sticky-no">
<nav class="top-bar" data-topbar role="navigation">
<ul class="title-area">
<li class="name">
<a href="https://www.mssqltips.com/"><img alt="mssqltips logo" src="/images/mslogo_bw_89x45-2.png" width="89" height="45"></a>
</li>

<li class="toggle-topbar menu-icon"><a href="#"><span>Menu</span></a></li>
</ul>
<section class="top-bar-section">

<ul class="right">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'join'});" href="/get-free-sql-server-tips/?ref=JoinHeaderMenu"><span style="color:red;">Join</span></a></li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="#">Beginner</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/1948/sql-server/">What is SQL Server?</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6422/sql-server-concepts/">SQL Server Concepts</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6429/sql-server-download-quick-links/">SQL Server Download Links</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/3700/my-first-sql-server-business-intelligence-project-tutorial/">My First BI Project </a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/2677/sql-server-career-planning/">SQL Server Career Plan</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="#">Tutorials</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedures</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9131/sql-server-index-tutorial-overview/">Indexing</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sql-server-tutorials/">All Tutorials</a></li>
</ul>
</li>
<li class="has-dropdown"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="#">DBA</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/60/database-administration/">Database Administration</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/54/monitoring/">Monitoring</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9194/sql-server-extended-events-tutorial/">Extended Events</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/81/powershell/">PowerShell</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/27/sql-server-agent/">SQL Server Agent</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9268/sql-server-management-studio-overview-ssms/">Management Studio</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/161/backup/">Backup</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/202/restore/">Restore</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/143/availability-groups/">Availability Groups</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="#">T-SQL</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedure Tutorial</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1667/sql-server-join-example/">SQL Server Join Example</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">CROSS APPLY + OUTER APPLY</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1599/cursor-in-sql-server/">Cursor in SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/4054/creating-a-date-dimension-or-calendar-table-in-sql-server/">Calendar Table</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/5993/sql-server-date-and-time-functions-with-examples/">Date and Time Functions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="#">Analytics</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-tip-category/211/power-bi/">Power BI</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-business-intelligence-resources/">Azure Data Factory</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/4200/sql-server-analysis-services-2016-ssas-tutorial/">Analysis Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9073/sql-server-2017-and-python-basics/">Python</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9040/getting-started-with-r-in-sql-server/">R</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="#">Cloud</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/205/amazon-aws/">AWS</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/87/azure/">Azure</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="#">Tools</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6297/melissa-data-quality-solutions-for-ssis/?ps=melissa">Data Quality Tools</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6310/solarwinds-database-performance-analyzer-for-sql-server/?ps=solarwinds-dpa">Database Performance Analyzer</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6367/quest-foglight-for-databases/?ps=quest-foglight">Foglight for SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6845/sql-diagnostic-manager-for-sql-server/?ps=sql-dm">SQL Diagnostic Manager for SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/7159/solarwinds-sentryone-sql-server-performance-tuning/?ps=solarwinds-s1">SolarWinds SQL Sentry</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/7224/dbi-performance-suite-for-db2-and-sql-server/?ps=dbi-software">DBI Web Performance Suite</a></li>
</ul>
</li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'search'});" href="/search/"><span style="color:red;">Search</span></a></li>
</ul>
</section>
</nav>
</div>
<div class="row">
<div class="entry-content large-9 columns" role="content"> <h1>Capturing SQL Server Deadlocks using Extended Events</h1>
<article>
<p>By: <a href="/sqlserverauthor/315/eduardo-pivaral/" rel="author" title="author profile for Eduardo Pivaral">Eduardo Pivaral</a> &nbsp;&nbsp;|&nbsp;&nbsp; Updated: 2022-08-03 &nbsp;&nbsp;|&nbsp;&nbsp; <a href="#comments" title="read and post comments">Comments (4)</a> &nbsp;&nbsp;|&nbsp;&nbsp; Related: <a href="/sql-server-dba-resources/">More</a> > <a href="/sql-server-tip-category/54/monitoring/">Monitoring</a></p>
<br />
<h5>Problem</h5>
<p>In large environments, where you have large OLTP databases,
<a href="/sqlservertutorial/252/tracing-a-sql-server-deadlock/" target="_blank">
deadlocks</a> are a common issue. It is imperative to identify and resolve
the SQL Server Deadlocks to guarantee
business continuity with no user interruptions. Even when you can
identify deadlocks using
<a href="/sqlservertip/1036/finding-and-troubleshooting-sql-server-deadlocks/" target="_blank">
trace flags or Profiler</a>, Extended Events provide us the ability to monitor and
capture deadlock events and related information in a lightweight and customizable
way. Also, Extended Events are meant to replace SQL Server Profiler as it
is deprecated.</p>
<p>If you use trace flags, you can easily forget you have them configured on the
server and if a migration/server rebuild occurs you can forget to configure them,
especially for servers handed over to your team.</p>
<div align="center" class="hide-for-print hide-for-small"> <div id="ad-slot-leader" style="width:728px; height:90px; min-width:728px; min-height:90px;"> <script type='text/javascript'> if (screen.width > 749) { googletag.cmd.push(function() {googletag.display('ad-slot-leader'); }); }	</script> </div></div><h5>Solution</h5>
<p>Extended Events were introduced in SQL Server 2008, so you will not have any
issue implementing them in your environment. In this tip, we will learn how to capture
deadlock information using Extended Events and review the captured
data.</p>
<h2>Creating SQL Server Extended Events to Capture Deadlocks using Management
Studio</h2>
<p>First, open
<a href="/sql-server-tip-category/52/sql-server-management-studio/">SQL Server Management Studio</a> (SSMS) and navigate to <strong>Management &gt;
Extended Events &gt; Sessions.</strong></p>
<div class="imageborder">
<img loading="lazy" width="344" height="503" alt="location of extended events" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.001.png" />
</div>
<p>Right-click on Sessions and select <strong>New Session.</strong></p>
<div class="imageborder">
<img loading="lazy" width="320" height="188" alt="new session" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.002.png" />
</div>
<p>In the new window, enter a name for your event, we will use <em>Deadlock_Capture</em>
for this example.&nbsp; Select the event to start at server startup and after session
creation, you can change these options if you want.</p>
<div class="imageborder">
<img loading="lazy" width="900" height="626" alt="session name" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.003.png" />
</div>
<p>Then go to the Events tab and in the event library textbox type <strong>&ldquo;deadlock&rdquo;</strong>
to filter deadlock events:</p>
<div class="imageborder">
<img loading="lazy" width="900" height="625" alt="session events" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.004.png" />
</div>
<p>For this tip, we will select 2 events: <strong>Lock_Deadlock </strong>(Occurs
when an attempt to acquire a lock is canceled for the victim of a deadlock) and
<strong>Lock_deadlock_chain </strong>(Occurs when an attempt to acquire a lock generates
a deadlock. This event is raised for each participant in the deadlock<span style="font-family: 'Microsoft Sans Serif'; font-size: 8.5pt">).</span></p>
<div class="imageborder">
<img loading="lazy" width="751" height="372" alt="session selection" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.005.png" />
</div>
<p>With both events selected, click on the configure button, and a new window will
appear, in this window, we will capture the <strong>sql_text</strong> field to be
able to see the query that caused the deadlock:</p>
<div class="imageborder">
<img loading="lazy" width="876" height="581" alt="events configuration" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.006.png" />
</div>
<p>In the Data Storage tab, select where you want to store the Extended Event data,
I prefer to use a file:</p>
<div class="imageborder">
<img loading="lazy" width="900" height="601" alt="event file location" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.007.png" />
</div>
<p>I leave the defaults and it should look something like this:</p>
<div class="imageborder">
<img loading="lazy" width="791" height="476" alt="event file configuration" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.008.png" />
</div>
<p>After that, click on <strong>OK</strong> to save the Event configuration, we
can see that the event is created and is already running:</p>
<div class="imageborder">
<img loading="lazy" width="262" height="140" alt="event created" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.009.png" />
</div>
<h2>Create SQL Server Extended Events to Capture Deadlocks using T-SQL</h2>
<p>You can achieve the same results as we demonstrated in SQL Server Management
Studio by executing the following T-SQL code. In the comments of the code, I briefly explain the purpose of each section.
</p>
<div class="codediv">
<pre class="prettyprint lang-sql">
--Event Session
CREATE EVENT SESSION [deadlock_capture] ON SERVER 

--Events to track Lock_deadlock and Lock_deadlock_chain
ADD EVENT sqlserver.lock_deadlock(
    ACTION(sqlserver.sql_text)),
ADD EVENT sqlserver.lock_deadlock_chain(
    ACTION(sqlserver.sql_text))

-- TARGET to use, for this case, a file
ADD TARGET package0.event_file(SET filename=N&apos;deadlock_capture&apos;)

--The event session advanced parameters, you can see that the event starts automatically
WITH (MAX_MEMORY=4096 KB,EVENT_RETENTION_MODE=ALLOW_SINGLE_EVENT_LOSS,MAX_DISPATCH_LATENCY=30 
SECONDS,MAX_EVENT_SIZE=0 KB,MEMORY_PARTITION_MODE=NONE,TRACK_CAUSALITY=OFF,STARTUP_STATE=ON)

GO
</pre>
</div>
<p>Now our event to capture deadlocks is created, it is just a matter of testing
it.</p>
<h2>Testing SQL Server Extended Events with a Deadlock</h2>
<p>Creating a deadlock for testing purposes is very simple, all you need is 2
tables and 2 sessions. In this example, we are updating the same record on each table for each
session with open transactions.</p>
<p>In session 1 run this query (use any test table you want):</p>
<div class="codediv">
<pre class="prettyprint lang-sql">
BEGIN TRAN

UPDATE tableA
set [value] = &apos;C1&apos;
WHERE id = 1

WAITFOR DELAY &apos;00:00:05&apos;

UPDATE tableB
set [value] = &apos;C2&apos;
WHERE id = 1
</pre>
</div>
<p>Then after a few seconds run the below code in session 2 (we just changed the
update order):</p>
<div class="codediv">
<pre class="prettyprint lang-sql">
BEGIN TRAN

UPDATE tableB
set [value] = &apos;C2&apos;
WHERE id = 1

WAITFOR DELAY &apos;00:00:05&apos;

UPDATE tableA
set [value] = &apos;C1&apos;
WHERE id = 1
</pre>
</div>
<p>One of the sessions will throw a message like this:</p>
<div class="codediv">Msg 1205, Level 13, State 51, Line 9<br />
Transaction (Process ID 56) was deadlocked on lock resources with another process and has been
chosen as the deadlock victim. Rerun the transaction.</div>
<p>After that, you can just commit or rollback the transaction that did not
fail.</p>
<p>Of course, in a real-world scenario, you will not be monitoring each user session
in real-time, that is why we created the Extended Event to capture this information
for later analysis.</p>
<p>Now let's check how this deadlock was captured.</p>
<h2>Reviewing Data Captured by SQL Server Extended Events</h2>
<p>Using SSMS, navigate to <strong>Management &gt; Extended Events &gt; Sessions</strong>,
and expand the event you want to check the data (<strong>deadlock_capture</strong>
for our example), then double click on the target you want to check:</p>
<div class="imageborder">
<img loading="lazy" width="310" height="240" alt="checking the data captured" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.010.png" />
</div>
<p>You can see the captured data so far, I filtered the data by date so you just
see the test we did earlier:</p>
<div class="imageborder">
<img loading="lazy" width="426" height="176" alt="viewing the events" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.011.png" />
</div>
<h2>What the captured data tells us?</h2>
<ul>
<li>The <strong>lock_deadlock_chain</strong> events tell us both sessions
involved in the deadlock, as you can see by clicking on any of them to see the
details, for our example were sessions 53 and 56:</li>
</ul>
<div class="imageborder">
<img loading="lazy" width="517" height="600" alt="session 1" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.012.png" />
</div>
<div class="imageborder">
<img loading="lazy" width="418" height="592" alt="session 2" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.013.png" />
</div>
<ul>
<li>The <strong>lock_deadlock</strong> event provides us the information about
the deadlock victim, with the T-SQL code involved as well, we can correlate
it to the <strong>session_id</strong> using the <strong>transaction_id</strong>
field:</li>
</ul>
<div class="imageborder">
<img loading="lazy" width="522" height="589" alt="deadlock information" src="/tipimages2/5658_identify-sql-server-deadlocks-using-extended-events.014.png" />
</div>
<p>With this info, you can create and analyze deadlocks in your database server.
</p>
<h2>What if you need more information?</h2>
<p>There are cases where troubleshooting deadlocks can be problematic, maybe
because of the complexity of the queries or because there are more than two sessions involved
in
the deadlocks. In that case, you can use the <strong>xml deadlock report</strong>, which allows
you to visually analyze the deadlock and have a better understanding of the issue.</p>
<p><strong>Please note:</strong> using this event can be more resource intensive since
more data must be captured and stored, so use only in situations where is strictly
necessary, and try to filter it whenever possible.</p>
<p>To configure, repeat the same steps we did before using SSMS but this time select the <strong>xml_deadlock_report</strong> option (feel free to experiment
with the other options):</p>
<div class="imageborder">
<img loading="lazy" alt="New extended event" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.001.png" height="662" width="900" />
</div>
<p>Once selected, you can click on Configure to add additional fields or filter
the event, in our case we will not select any other field or filter. Also, we
will not select <strong>sql_text</strong> this time since is already
included in the deadlock report event.</p>
<div class="imageborder">
<img loading="lazy" alt="Select XML Report event" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.002.png" height="335" width="810" />
</div>
<p>Once done, click OK and we are ready for testing.</p>
<p>In case you want the T-SQL definition for this event, here it is:</p>
<div class="codediv">
<pre class="prettyprint lang-sql">
CREATE EVENT SESSION [deadlock_capture] ON SERVER 
 
ADD EVENT sqlserver.xml_deadlock_report
 
ADD TARGET package0.event_file (SET filename = N'deadlock_capture')
    WITH (
            MAX_MEMORY = 4096 KB
            , EVENT_RETENTION_MODE = ALLOW_SINGLE_EVENT_LOSS
            , MAX_DISPATCH_LATENCY = 30 SECONDS
            , MAX_EVENT_SIZE = 0 KB
            , MEMORY_PARTITION_MODE = NONE
            , TRACK_CAUSALITY = OFF
            , STARTUP_STATE = OFF
            )
GO
</pre>
</div>
<p>We can test again using the same test query as before.</p>
<div class="imageborder">
<img loading="lazy" alt="Deadlock Example" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.003.png" height="375" width="900" />
</div>
<p>Now, if we check the extended event data, we will be able to see the deadlock
report entry:</p>
<div class="imageborder">
<img loading="lazy" alt="Deadlock entry in events" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.004.png" height="443" width="561" />
</div>
<p>If you select one of these deadlock report entries and click on the Deadlock tab, you will be able to analyze it visually:
</p>
<div class="imageborder">
<img loading="lazy" alt="Deadlock diagram" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.005.png" height="440" width="900" />
</div>
<p>You can hover the mouse over the various objects to get additional details as
shown below:</p>
<div class="imageborder">
<img loading="lazy" alt="Hover the deadlock diagram" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.006.png" height="193" width="902" />
</div>
<p>You can also open the XML in case you need to look for specific details
of the session (host name, application name, client app, isolation level, etc.)
</p>
<div class="imageborder">
<img loading="lazy" alt="XML field for deadlock" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.007.png" height="509" width="810" />
</div>
<p>Those details are found in the <strong>&lt;process&gt;</strong> tag (I added
a few ENTERs to make it easier to read each entry, but you can scroll right to look for the
information):</p>
<div class="imageborder">
<img loading="lazy" alt="Process tag information" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.008.png" height="163" width="902" />
</div>
<h2>My Extended Event is Not Capturing Any Data!</h2>
<p>In the case you are not seeing data after your test, aside from any restrictive
filter you could have created, make sure the event is started (it should have a
green triangle next to it).</p>
<div class="imageborder">
<img loading="lazy" alt="Extended event is started" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.009.png" height="220" width="383" />
</div>
<p>If it is not started (you see a red square), you can start it by
right-clicking on it and choosing Start Session:</p>
<div class="imageborder">
<img loading="lazy" alt="Starting Extended event" src="/tipimages2/5658_identifying-deadlocks-using-extended-events.010.png" height="506" width="458" />
</div>
<p>If you need to do it programmatically, you read my other tip on
<a href="/sqlservertip/5748/start-and-stop-extended-events-sessions-automatically-using-sql-server-agent-jobs/" target="_blank">how to start and stop XE events via T-SQL code and using SQL
Agent jobs</a>.</p>
<h5>Next Steps</h5>
<ul>
<li>SQL Server introduced Extended Events in SQL Server 2008, they were meant
to replace SQL Server Profiler traces and they provide a lightweight, customizable
event collection platform.</li>
<li>You can use the example I provided as a base and customize it by adding
other fields you might need (for example: capturing the user, hostname,
etc.)</li>
<li>Check
out the
<a href="https://docs.microsoft.com/en-us/sql/relational-databases/extended-events/extended-events?view=sql-server-2017" target="_blank">Microsoft official documentation about
Extended Events</a>.</li>
</ul>
<br /><br />
<div style="width:95%;">
<script src="https://fast.wistia.com/embed/medias/fbvlltguct.jsonp" async></script><script src="https://fast.wistia.com/assets/external/E-v1.js" async></script><div class="wistia_responsive_padding" style="padding:56.25% 0 0 0;position:relative;"><div class="wistia_responsive_wrapper" style="height:100%;left:0;position:absolute;top:0;width:100%;"><div class="wistia_embed wistia_async_fbvlltguct videoFoam=true" style="height:100%;position:relative;width:100%"><div class="wistia_swatch" style="height:100%;left:0;opacity:0;overflow:hidden;position:absolute;top:0;transition:opacity 200ms;width:100%;"><img src="https://fast.wistia.com/embed/medias/fbvlltguct/swatch" style="filter:blur(5px);height:100%;object-fit:contain;width:100%;" alt="" aria-hidden="true" onload="this.parentNode.style.opacity=1;" /></div></div></div></div>
<br>
<p style="text-align:center;"><a onclick="gtag('event', 'download', {'event_category': 'SolarWinds', 'event_label': 'ProdCommercial'});" href="https://www.solarwinds.com/database-insights-sql-server/registration?CMP=SYN-VID-MSSQL-SW_WW_X_RR_FLT_CQ_EN_DISSQL_SW-DISQL-X_X_X_VID_X-X" target="_blank">Get Started Now - Click here to get your free 14 day trial of SolarWinds Database Insights</a>
<br>
</div>
<div class="row">
<div class="large-6 medium-6 small-12 columns">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Related Articles</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '1177'});" href="/sqlservertip/1177/determining-space-used-for-all-tables-in-a-sql-server-database/">Determining space used for all tables in a SQL Server database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '1178'});" href="/sqlservertip/1178/monitoring-sql-server-database-transaction-log-space/">Monitoring SQL Server database transaction log space</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '1473'});" href="/sqlservertip/1473/killing-a-spid-and-checking-rollback-progress-in-sql-server/">Killing a SPID and Checking Rollback progress in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '1476'});" href="/sqlservertip/1476/how-to-read-log-file-in-sql-server-using-tsql/">How to Read Log File in SQL Server using TSQL</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '1477'});" href="/sqlservertip/1477/methods-to-determine-the-status-of-a-sql-server-database/">Methods to determine the status of a SQL Server database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '1523'});" href="/sqlservertip/1523/how-to-setup-sql-server-alerts-and-email-operator-notifications/">How to setup SQL Server alerts and email operator notifications</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '1811'});" href="/sqlservertip/1811/find-current-running-sql-statement-in-sql-server/">Find Current Running SQL Statement in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '1917'});" href="/sqlservertip/1917/performance-analysis-using-sql-server-2008-activity-monitor-tool/">Performance Analysis Using SQL Server 2008 Activity Monitor Tool</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '2732'});" href="/sqlservertip/2732/different-techniques-to-identify-blocking-in-sql-server/">Different techniques to identify blocking in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '4017'});" href="/sqlservertip/4017/low-disk-space-alert-for-sql-server/">Low Disk Space Alert for SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '5319'});" href="/sqlservertip/5319/automated-notification-email-for-sql-server-object-modifications/">Automated Notification Email for SQL Server Object Modifications</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '5724'});" href="/sqlservertip/5724/monitor-cpu-and-memory-usage-for-all-sql-server-instances-using-powershell/">Monitor CPU and Memory usage for all SQL Server instances using PowerShell</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '6090'});" href="/sqlservertip/6090/sql-server-configuration-settings-query/">SQL Server Configuration Settings Query</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '6195'});" href="/sqlservertip/6195/sql-server-function-to-measure-cpu-usage-per-database/">SQL Server Function to Measure CPU Usage Per Database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '6354'});" href="/sqlservertip/6354/monitoring-sql-server-with-powershell-core-object-setup/">Monitoring SQL Server with PowerShell Core Object Setup</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '6645'});" href="/sqlservertip/6645/sp-whoisactive-sql-server-monitoring/">sp_whoisactive SQL Server Monitoring</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '6731'});" href="/sqlservertip/6731/how-to-check-disk-space-in-sql-server/">How To Check Disk Space in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '6833'});" href="/sqlservertip/6833/sql-server-memory-usage-query/">SQL Server Memory Usage Query</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '6849'});" href="/sqlservertip/6849/sql-drop-table-investigation-options/">Who Dropped the SQL Table</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Related', 'event_label': '6945'});" href="/sqlservertip/6945/windows-performance-monitor-counters-for-sql-server/">Windows Performance Monitor Counters for SQL Server</a><br><br>
</div>
</div>
<div class="large-6 medium-6 small-12 columns">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Popular Articles</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '1145'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions Using SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '2655'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates with FORMAT Function</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '1599'});" href="/sqlservertip/1599/cursor-in-sql-server/">SQL Server Cursor Example</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '1958'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">SQL Server CROSS APPLY and OUTER APPLY</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '2914'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows into a single row and column for SQL Server data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '6769'});" href="/sqlservertip/6769/sql-server-drop-table-if-exists/">SQL Server DROP TABLE IF EXISTS Examples</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '6904'});" href="/sqlservertip/6904/sql-not-in-operator/">SQL NOT IN Operator</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '1140'});" href="/sqlservertip/1140/how-to-tell-what-sql-server-version-you-are-running/">How to tell what SQL Server versions you are running</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '2509'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates using DATEADD in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '6452'});" href="/sqlservertip/6452/sql-convert-date-to-yyyymmdd/">SQL Convert Date to YYYYMMDD</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '2340'});" href="/sqlservertip/2340/resolving-could-not-open-a-connection-to-sql-server-errors/">Resolving could not open a connection to SQL Server errors</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '6148'});" href="/sqlservertip/6148/sql-server-loop-through-table-rows-without-cursor/">SQL Server Loop through Table Rows without Cursor</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '1704'});" href="/sqlservertip/1704/using-merge-in-sql-server-to-insert-update-and-delete-at-the-same-time/">Using MERGE in SQL Server to insert, update and delete at the same time</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '2985'});" href="/sqlservertip/2985/concatenate-sql-server-columns-into-a-string-with-concat/">Concatenate SQL Server Columns into a String with CONCAT()</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '2542'});" href="/sqlservertip/2542/display-line-numbers-in-a-sql-server-management-studio-query-window/">Display Line Numbers in a SQL Server Management Studio Query Window</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '2537'});" href="/sqlservertip/2537/sql-server-row-count-for-all-tables-in-a-database/">SQL Server Row Count for all Tables in a Database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '2779'});" href="/sqlservertip/2779/ways-to-compare-and-find-differences-for-sql-server-tables-and-data/">Ways to compare and find differences for SQL Server tables and data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '6817'});" href="/sqlservertip/6817/sql-current-date/">How to Get Current Date in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '1522'});" href="/sqlservertip/1522/searching-and-finding-a-string-value-in-all-columns-in-a-sql-server-table/">Searching and finding a string value in all columns in a SQL Server table</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '5658', {'event_category': 'Popular', 'event_label': '5460'});" href="/sqlservertip/5460/sql-server-database-stuck-in-restoring-state/">SQL Server Database Stuck in Restoring State</a><br><br>
</div>
</div>
</div>
<br /><br /><br />
<div class="row">
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="gtag('event', 'click', {'event_category': 'Scripts', 'event_label': 'BotTip'});" target="_blank"><img loading="lazy" border="0" src="/images/Free-Download_20190509.png" alt="get scripts" width="300" height="150"></a></div>
<br />
</div>
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/sql-server-tip-category/54/monitoring/" onclick="gtag('event', 'click', {'event_category': 'NextTip', 'event_label': 'YellowArrow'});"><img loading="lazy" border="0" src="/images/nav_nexttip_clickhere_rev1.png" alt="next tip button" width="300" height="150"></a></div>
<br />
</div>
</div>
<br /><br />
<h5>About the author</h5>
<div class="row">
<div class="large-12 columns">
<a href="/sqlserverauthor/315/eduardo-pivaral/"><img loading="lazy" style="float: left; padding: 0px 10px 0px 0px;" alt="MSSQLTips author Eduardo Pivaral" height="150" src="/images/Eduardo-Pivaral.png" width="100" /></a>
Eduardo Pivaral is an MCSA, SQL Server Database Administrator and Developer with over 15 years experience working in large environments.
<br /><br /><b><a href="/sqlserverauthor/315/eduardo-pivaral/">View all my tips</a></b>
</div>
</div>
<br /><br />
Article Last Updated: 2022-08-03
<a name="comments"></a>
</article>
<div class="row">
</div>
<div class="hide-for-print">
<hr>
<h2>Comments For This Article</h2>
<button class="button round" data-reveal-id="myModal" data-reveal-ajax="/zurb_comments.asp?id=1x5658">Add Comment</button>
<div id="myModal" class="reveal-modal" data-reveal aria-labelledby="modalTitle" aria-hidden="true" role="dialog">
</div>
<style type="text/css">
.ForumPostBodyArea
{
	width: 100%;
	vertical-align: top;
	overflow: auto;
}
</style>
<br /><br /><br />
<table border="0" width="100%" cellspacing="0" cellpadding="4" style="border: 1px solid #CBDCED; table-layout: fixed;">
<tr>
<td width="80%" bgcolor="#E8F3FF">
<b>Wednesday, March 2, 2022 - 2:57:06 PM - Eduardo Pivaral</b>
</td>
<td style="text-align: right;" bgcolor="#E8F3FF">
<a title="read the tip" href="#top">Back To Top</a> <small>(89848)</small>
</td>
</tr>
<tr>
<td colspan="2" class="ForumPostBodyArea">
Hi Christian,<br><br>This is a basic guide, and the output is a simple SELECT query, so you can add/remove columns you need, you can freely remove the columns you don't need.<br>The objective of this tip is to show which events we should capture for deadlocks... the information (more or less) you need to collect is up to you.
</td>
</tr>
</table>
<br>
<table border="0" width="100%" cellspacing="0" cellpadding="4" style="border: 1px solid #CBDCED; table-layout: fixed;">
<tr>
<td width="80%" bgcolor="#E8F3FF">
<b>Wednesday, March 2, 2022 - 2:00:59 PM - Christian</b>
</td>
<td style="text-align: right;" bgcolor="#E8F3FF">
<a title="read the tip" href="#top">Back To Top</a> <small>(89847)</small>
</td>
</tr>
<tr>
<td colspan="2" class="ForumPostBodyArea">
Help a bit to understand the Extended Events but the end result is not so good.<br><br>What does the transaction_id and session_id does for us? It doesn't give any pertinent details.<br><br>Then this: "With both events selected, click on the configure button, and a new window will appear, in this window we will capture the sql_text field to be able to see the query that caused the deadlock". You are aware that sql_text won't show up for lock_deadlock_chain? The only informations you can get in sql_text is the one of the process which got killed.
</td>
</tr>
</table>
<br>
<table border="0" width="100%" cellspacing="0" cellpadding="4" style="border: 1px solid #CBDCED; table-layout: fixed;">
<tr>
<td width="80%" bgcolor="#E8F3FF">
<b>Thursday, January 13, 2022 - 3:55:30 AM - krishna</b>
</td>
<td style="text-align: right;" bgcolor="#E8F3FF">
<a title="read the tip" href="#top">Back To Top</a> <small>(89657)</small>
</td>
</tr>
<tr>
<td colspan="2" class="ForumPostBodyArea">
if deadlock found, use effective resolving techniques. Try to access objects in a similar logical manner in multiple transactions Try to analyze the queries involved in the DL, check corresponding xml of the deadlock also xdl file if needed and with given information go back to the db and look for effective techniques. DO NOT blindly create indexes for every deadlock. Apply your performance improvement skills on these queries too wherever needed.<br>Create a covering index to reduce the possibility of a deadlock.
</td>
</tr>
</table>
<br>
<table border="0" width="100%" cellspacing="0" cellpadding="4" style="border: 1px solid #CBDCED; table-layout: fixed;">
<tr>
<td width="80%" bgcolor="#E8F3FF">
<b>Friday, January 22, 2021 - 3:59:12 PM - Tim Cullen</b>
</td>
<td style="text-align: right;" bgcolor="#E8F3FF">
<a title="read the tip" href="#top">Back To Top</a> <small>(88087)</small>
</td>
</tr>
<tr>
<td colspan="2" class="ForumPostBodyArea">
Great tip! As much as I hate to admit it, I've never used extended event sessions but am looking to get additional information on deadlocks we're seeing in one of our databases and this tip gave me everything I needed to set one up. Thanks!
</td>
</tr>
</table>
<br>
</div>
</div>
<style>
			div.stickyright {
			  position: -webkit-sticky;
			  position: sticky;
			  padding: 0;
			  background-color: white;
			  width: 300px;
			  z-index: 1;
			}
	</style>
<div class="large-3 hide-for-print columns rightsize">
<br />

<div align="center">
<div id='div-gpt-ad-1388505177750-0' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-0'); });
	}	
	</script>
</div>
</div><br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-3' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-3'); });
	}	
	</script>
</div>
</div> <br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-1' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-1'); });
	}
	</script>
</div>
</div> <br /><br /><br />
<div class="stickyright" style="top:55px;">

<div align="center">
<div id='div-gpt-ad-1388505177750-2' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{	
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-2'); });
	}	
	</script>
</div>
</div> <br /><br /><br /> <script language="Javascript">
	function ValidateEmail(inputText)
	{
	
		if (document.optin.consent.checked == false) {
		     alert("Please agree to terms by ticking check box.");
		     return false;
	            }	
	   
		var mailformat = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
		if(inputText.value.match(mailformat))
		{
			document.optin.ea.focus();
			return true;
		}
		else
		{
			alert("You have entered an invalid email address!");
			document.optin.ea.focus();
			return false;
		}
	}

	</script>
<div id="sticky2">
<div id="search-div" style="height:300px; width:300px">
<div id="signup-div">
<div style="text-align: center;"><a href="/get-free-sql-server-tips/?ref=LeftGFSTSlant"><img loading="lazy" alt="get free sql tips" border="0" src="/images/GetFreeSQLTips_black_box.png" width="300" height="150"></a></div>
<form action="/get-free-sql-server-tips/" method="post" name="optin" onsubmit="return ValidateEmail(document.optin.ea)">
<input name="URL" type="hidden" value="leftform" />
<input name="ReferralURL" type="hidden" value="" />
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-10 columns">
<input size="25" type="text" onblur="if (this.value=='') this.value=this.defaultValue" onclick="if (this.defaultValue==this.value) this.value=''" value="enter business email" name="ea">
</div>
<div class="small-2 columns">
<input type="submit" name="Button1" value="Join" />
</div>
</div>
</div>
</div>
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-1 columns">
<input type="checkbox" name="consent" value="1">
</div>
<div class="small-11 columns">
<a href="/privacy/" target="_blank"><img loading="lazy" src="/images/mssqltips-agree-terms.png" alt="agree to terms" width="276" height="67"></a>
</div>
</div>
</div>
</div>
<br /><br />
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<footer class="row hide-for-print">
<hr />
<ul class="small-block-grid-2 medium-block-grid-3 large-block-grid-6" style="margin:10px;">
<li>
<h3><span style="color:#3B6D93">Follow</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=GetFooterMenu">Get Free SQL Tips</a></li>
<li><a rel="noopener" href="https://twitter.com/mssqltips" target="_blank">Twitter</a></li>
<li><a rel="noopener" href="https://www.linkedin.com/groups/2320891/" target="_blank">LinkedIn</a></li>
<li><a rel="noopener" href="https://www.facebook.com/mssqltips/" target="_blank">Facebook</a></li>
<li><a rel="noopener" href="https://www.pinterest.com/mssqltips/" target="_blank">Pinterest</a></li>
<li><a rel="noopener" href="https://feeds.feedburner.com/MSSQLTips-LatestSqlServerTips" target="_blank">RSS</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Learning</span></h3>
<ul>
<li><a href="/sql-server-dba-resources/">DBAs</a></li>
<li><a href="/sql-server-developer-resources/">Developers</a></li>
<li><a href="/sql-server-business-intelligence-resources/">BI Professionals</a></li>
<li><a href="/sql-server-professional-development-resources/">Careers</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Resources</span></h3>
<ul>
<li><a href="/sql-server-tutorials/">Tutorials</a></li>
<li><a href="/sql-server-webcasts/">Webcasts</a></li>
<li><a href="/sql-server-whitepapers/">Whitepapers</a></li>
<li><a href="/sql-server-tools/">Tools</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Search</span></h3>
<ul>
<li><a href="/sql-server-categories/">Tip Categories</a></li>
<li><a href="/search-tip-id/">Search By TipID</a></li>
<li><a href="/sql-server-mssqltips-authors/">Authors</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Community</span></h3>
<ul>
<li><a href="/learn-more-about-mssqltips/">First Timer?</a></li>
<li><a href="/mssqltips-community/1/">Pictures</a></li>
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/sql-server-event-list/">Event Calendar</a></li>
<li><a href="/sql-server-user-groups/">User Groups</a></li>
<li><a href="/mssqltips-author-of-year/">Author of the Year</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">More Info</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=JoinFooterMenu">Join</a></li>
<li><a href="/about/">About</a></li>
<li><a href="/copyright/">Copyright</a></li>
<li><a href="/privacy/">Privacy</a></li>
<li><a href="/disclaimer/">Disclaimer</a></li>
<li><a href="/feedback/">Feedback</a></li>
<li><a href="/advertise/">Advertise</a></li>
</ul>
</li>
</ul>
<hr />
<div class="row">
<div class="large-12 columns text-center">
<p>Copyright (c) 2006-2022 <a href="https://www.edgewoodsolutions.com">Edgewood Solutions, LLC</a> All rights reserved<br />
<small>Some names and products listed are the registered trademarks of their respective owners.</small></p>
</div>
</div>
</footer>

<style type="text/css">
#slideboxtop{
    width:100%;
    height:50px;
    padding:0px;
    background-color:#FFFFFF;      
    border-bottom:1px solid #000000;
    position:fixed;
    top: -350px;
	-moz-box-shadow:-2px 0px 5px #aaa;
	-webkit-box-shadow:-2px 0px 5px #aaa;
/* 	box-shadow:-2px 0px 5px #aaa;    */
}
</style>
<div class="hide-for-small hide-for-medium hide-for-print">
<div id="slideboxtop" style="z-index:1;">
<div style="text-align:center">
<div w3-include-html="/Site-Sponsorship/site-sponsorship.asp"></div>
</div>
</div>
</div>
<script src="/js/jquery-foundation-combined-min.js"></script>
<script type="text/javascript">
var articleLength = $("article").find("p").length;

 

</script>
<script>
    $(document).foundation();
</script>
<script type="text/javascript" src="/css/prettify.combined.js" defer></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function(){
		if  ($(window).scrollTop() > 250)
			$('#slideboxtop').animate({'top':'0px'});
		else
			$('#slideboxtop').stop(true).animate({'top':'-250px'});
	});
});
</script>
<script>
function includeHTML() {
  var z, i, elmnt, file, xhttp;
  /*loop through a collection of all HTML elements:*/
  
  z = document.getElementsByTagName("*");
  for (i = 0; i < z.length; i++) {
    elmnt = z[i];
    /*search for elements with a certain atrribute:*/
    file = elmnt.getAttribute("w3-include-html");
	if (file) {
      /*make an HTTP request using the attribute value as the file name:*/
      xhttp = new XMLHttpRequest();
      xhttp.onreadystatechange = function() {
        if (this.readyState == 4) {
          if (this.status == 200) {elmnt.innerHTML = this.responseText;}
          if (this.status == 404) {elmnt.innerHTML = "Page not found.";}
          /*remove the attribute, and call this function once more:*/
          elmnt.removeAttribute("w3-include-html");
          includeHTML();
        }
      }   
      xhttp.open("GET", file, true);
      xhttp.send();
      /*exit the function:*/
      return;
    }
  }
};
</script>
<script>
 if ($(window).width() > 1000) {
	includeHTML();
	$("div.rightsize").height($("#container").height());
    }	
</script>

<script> 
//<![CDATA[ 
if (screen.width > 0)
{
function deferGoogleJS() { 
var d = document.createElement("script"); 
d.src = "https://www.googletagmanager.com/gtag/js?id=UA-910745-2", 
document.body.appendChild(d) 
} 
window.addEventListener ? window.addEventListener("load", deferGoogleJS, !1) : window.attachEvent ? window.attachEvent("onload", deferGoogleJS) : window.onload = deferGoogleJS; 
window.dataLayer = window.dataLayer || [];

function gtag() { 
dataLayer.push(arguments); 
} 
gtag('js', new Date()); 
gtag('config', 'UA-910745-2'); 
}
//]]> 
</script>
</body>
</html>
