
<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta http-equiv="Content-Language" content="en-us" />
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

<link rel="SHORTCUT ICON" href="/favicon.ico" />
<meta content="width=device-width, initial-scale=1.0" name="viewport" />
<title>Run Python Scripts in a SQL Server Agent Job</title>
<meta name="description" content="In this article we walk through how you can run Python scripts using SQL Server Agent, so you can setup scheduled jobs to run your Python code." />
<link rel="canonical" href="https://www.mssqltips.com/sqlservertip/7083/run-python-scripts-sql-server-agent-job/" />
<link rel="stylesheet" href="/css/foundation-app-combined-min.css">
<script>/*! loadCSS. [c]2017 Filament Group, Inc. MIT License */!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mssqltips.com/sqlservertip/7083/run-python-scripts-sql-server-agent-job/"
  },
  "headline": "Run Python Scripts in a SQL Server Agent Job",
  "image": [
  
    "https://www.mssqltips.com/images_newsletter/7083_NewsletterImage.png"
  
   ],  
  "datePublished": "2021-12-22T00:00:00+05:00",
  "dateModified": "2021-12-22T00:00:00+05:00",
  "author": {
    "@type": "Person",
    "name": "Nai Biao Zhou"
  },
   "publisher": {
    "@type": "Organization",
    "name": "MSSQLTips",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.mssqltips.com/images/mslogo_113x60.png"
    }
  },
  "description": "In this article we walk through how you can run Python scripts using SQL Server Agent, so you can setup scheduled jobs to run your Python code."
}
</script>
<meta property="og:url" content="https://www.mssqltips.com/sqlservertip/7083/run-python-scripts-sql-server-agent-job/" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Run Python Scripts in a SQL Server Agent Job" />
<meta property="og:description" content="In this article we walk through how you can run Python scripts using SQL Server Agent, so you can setup scheduled jobs to run your Python code." />
<meta property="og:image" content="https://www.mssqltips.com/images_newsletter/7083_NewsletterImage.png" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mssqltips">
<meta name="twitter:creator" content="@mssqltips">
<meta name="twitter:title" content="Run Python Scripts in a SQL Server Agent Job">
<meta name="twitter:description" content="In this article we walk through how you can run Python scripts using SQL Server Agent, so you can setup scheduled jobs to run your Python code.">
<meta name="twitter:image" content="https://www.mssqltips.com/images_newsletter/7083_NewsletterImage.png">
<script>

var head = document.getElementsByTagName('head')[0];
var js = document.createElement("script");

js.type = "text/javascript";

if (screen.width > 749)
{
    js.src = "https://securepubads.g.doubleclick.net/tag/js/gpt.js";
}
head.appendChild(js);

if (screen.width > 749)
{

!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

apstag.init({
  pubID: '434bb5e4-3704-4b75-b36c-785a444462bd',
  adServer: 'googletag',
  simplerGPT: true,
  schain: {
    complete: 1,
    ver: '1.0',
    nodes: [
      {
        asi: 'theadengine.com',
        sid: '01307',
        hp: 1,
      },
    ],
  },
});

window.googletag = window.googletag || {cmd: []};

googletag.cmd.push(function() {

   var mapping = googletag.sizeMapping().
   addSize([100, 100], []).
   addSize([320, 400], []).
   addSize([320, 700], []).
   addSize([750, 200],  [[728, 90],[300,250],[160,300],[300,600],[170,90]]).
   addSize([1050, 200], [[728, 90],[300,250],[160,300],[300,600],[170,90]]).build();

   var mapping728 = googletag.sizeMapping()
     .addSize([750, 200], [728, 90])
     .addSize([0, 0], [])
     .build();
   var mapping300 = googletag.sizeMapping()
     .addSize([640, 400], [300, 250])
     .addSize([0, 0], [])
     .build();
   var mapping600 = googletag.sizeMapping()
     .addSize([640, 600], [[160,600],[300,600]])
     .addSize([0, 0], [])
     .build();
   var mapping170 = googletag.sizeMapping()
     .addSize([640, 400], [170,90])
     .addSize([0, 0], [])
     .build();   
   
   
 
   googletag.defineSlot('/53998264/160x600-Primary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-0').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/160x600-Secondary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-1').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Primary', [300, 250], 'div-gpt-ad-1388505177750-2').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Secondary', [300, 250], 'div-gpt-ad-1388505177750-3').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/728x90-Primary', [728, 90], 'ad-slot-leader').defineSizeMapping(mapping728).addService(googletag.pubads()); 
   
   googletag.pubads().setTargeting('SyncFusion','Tools');

   // googletag.pubads().enableLazyLoad();
   googletag.pubads().disableInitialLoad();
   googletag.pubads().collapseEmptyDivs();
   googletag.enableServices();
});


googletag.cmd.push(function(){ 
  apstag.fetchBids({ 
  timeout: 2000 }, 
    function(bids) {
      apstag.setDisplayBids(); 
      googletag.pubads().refresh();
  }); 
}); 

}

</script>
</head>
<body onload="PR.prettyPrint()" style="background-color:white;">
<a name="top"></a>

<div name="container" id="container">
<div class="sticky-no">
<nav class="top-bar" data-topbar role="navigation">
<ul class="title-area">
<li class="name">
<a href="https://www.mssqltips.com/"><img alt="mssqltips logo" src="/images/mslogo_bw_89x45-2.png" width="89" height="45"></a>
</li>

<li class="toggle-topbar menu-icon"><a href="#"><span>Menu</span></a></li>
</ul>
<section class="top-bar-section">

<ul class="right">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'join'});" href="/get-free-sql-server-tips/?ref=JoinHeaderMenu"><span style="color:red;">Join</span></a></li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="#">Beginner</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/1948/sql-server/">What is SQL Server?</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6422/sql-server-concepts/">SQL Server Concepts</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6429/sql-server-download-quick-links/">SQL Server Download Links</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/3700/my-first-sql-server-business-intelligence-project-tutorial/">My First BI Project </a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/2677/sql-server-career-planning/">SQL Server Career Plan</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="#">Tutorials</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedures</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9131/sql-server-index-tutorial-overview/">Indexing</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sql-server-tutorials/">All Tutorials</a></li>
</ul>
</li>
<li class="has-dropdown"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="#">DBA</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/60/database-administration/">Database Administration</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/54/monitoring/">Monitoring</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9194/sql-server-extended-events-tutorial/">Extended Events</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/81/powershell/">PowerShell</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/27/sql-server-agent/">SQL Server Agent</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9268/sql-server-management-studio-overview-ssms/">Management Studio</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/161/backup/">Backup</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/202/restore/">Restore</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/143/availability-groups/">Availability Groups</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="#">T-SQL</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedure Tutorial</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1667/sql-server-join-example/">SQL Server Join Example</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">CROSS APPLY + OUTER APPLY</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1599/cursor-in-sql-server/">Cursor in SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/4054/creating-a-date-dimension-or-calendar-table-in-sql-server/">Calendar Table</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/5993/sql-server-date-and-time-functions-with-examples/">Date and Time Functions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="#">Analytics</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-tip-category/211/power-bi/">Power BI</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-business-intelligence-resources/">Azure Data Factory</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/4200/sql-server-analysis-services-2016-ssas-tutorial/">Analysis Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9073/sql-server-2017-and-python-basics/">Python</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9040/getting-started-with-r-in-sql-server/">R</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="#">Cloud</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/205/amazon-aws/">AWS</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/87/azure/">Azure</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="#">Tools</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6297/melissa-data-quality-solutions-for-ssis/?ps=melissa">Data Quality Tools</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6310/solarwinds-database-performance-analyzer-for-sql-server/?ps=solarwinds-dpa">Database Performance Analyzer</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6367/quest-foglight-for-databases/?ps=quest-foglight">Foglight for SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6845/sql-diagnostic-manager-for-sql-server/?ps=sql-dm">SQL Diagnostic Manager for SQL Server</a></li>
</ul>
</li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'search'});" href="/search/"><span style="color:red;">Search</span></a></li>
</ul>
</section>
</nav>
</div>
<div class="row">
<div class="entry-content large-9 columns" role="content"> <h1>Creating a SQL Server Agent Job to Run Python Scripts in a Virtual Environment</h1>
<div align="center" class="hide-for-print hide-for-small">
<div id="ad-slot-leader" style="width:728px; height:90px; min-width:728px; min-height:90px;">
<script type='text/javascript'>
		   	if (screen.width > 749)
			{	
				googletag.cmd.push(function() {googletag.display('ad-slot-leader'); });
			}	
		   </script>
</div>
</div>
<br />
<article>
<p>By: <a href="/sqlserverauthor/301/nai-biao-zhou/" rel="author" title="author profile for Nai Biao Zhou">Nai Biao Zhou</a> &nbsp;&nbsp;|&nbsp;&nbsp; Updated: 2021-12-22 &nbsp;&nbsp;|&nbsp;&nbsp; <a href="#comments" title="read and post comments">Comments</a> &nbsp;&nbsp;|&nbsp;&nbsp; Related: > <a href="/sql-server-tip-category/27/sql-server-agent/">SQL Server Agent</a></p>
<br />
<h5>Problem</h5>
<p>We often want to automatically launch some Python scripts at scheduled times
and monitor their executions at a central place. The SQL Server Agent services allow
us to schedule jobs on a SQL Server instance and provide powerful features to manage
these jobs (Das, 2020). Using a SQL Server Agent job to run Python scripts can expand
the range of office automation (OA). However, even though SQL Server Machine Learning
Services enable us to run Python scripts on a SQL Server machine with the stored
procedure "sp_execute_external_script" (Ericson et al., 2021), sometimes
we need to execute Python scripts in multiple, independent virtual environments.
In this tutorial, the author explains how to create a Python virtual environment,
how to employ the SQL Server Agent to execute Python scripts in the virtual environment,
and how to access job execution history to check Python script execution status.
</p>
<h5>Solution</h5>
<p>Recently, Python has been proliferating to automate simple tasks such as scraping
data from web pages, updating SharePoint lists, performing data cleansing, and scanning
log files. However, when using a virtual environment, we may need to run multiple
terminal commands to execute Python scripts. A convenient approach is to run a batch
script, a small text file with the .bat file extension (Sweigart, 2020). Moving
forward a single step, to run Python scripts at scheduled times, we use SQL Server
Agent, a Microsoft Windows service, to execute a batch script.</p>
<p>To explain how to create a SQL Server Agent job to run Python scripts in a virtual
environment, let us look at a real-world project. We want to use Python to download
data from an HTML table to an SQL Server database table (Zhou, 2021), and the downloading
process should start at 2:00 AM every morning. To accomplish this, we construct
a Python virtual environment, create a SQL Server job to perform this task at scheduled
times, and check the Python script execution record through the job history log.
<a href="/tipimages2/7083_htmltablescraping.zip" target="_blank">
Here is the complete code to perform the downloading task</a>.
</p>
<p>This article consists of two sections. Section 1 covers the steps to install
Python on Windows. Then, the section provides a step-by-step process to create a
virtual environment, activate the virtual environment, install packages, run a Python
script, and deactivate the virtual environment. In addition to manually typing commands
in the command window, we create a batch script to run the Python script.</p>
<p>Section 2 starts with a brief demonstration of creating a SQL Server Agent job
and specifying a job step to run the Python script. We then create and attach a
schedule to the agent job. Next, we manually run the job. We then let the agent
service run the job automatically. Finally, we check the execution record of the
Python script and the batch script through the job execution history.</p>
<p>We test Python scripts with Python 3.10.0 (64-bit) on Windows 10 Pro 10.0 &lt;X64&gt;.
The DBMS is the Microsoft SQL Server 2019 Developer Edition (64-bit). We use SQL
Server Management Studio 15.0.18338.0 to manage the SQL Server Agent jobs. In addition,
we use Notepad++ v8.1.9.2 (64-bit) to edit the batch script.</p>
<h2><a name="_Ref83843021">1 &ndash; Running the Python Script in a Virtual Environment</a>
</h2>
<p>Every Python distribution contains hundreds of modules, called the Python standard
library. In addition, there is a growing collection of several thousand third-party
packages maintained by the Python community worldwide. All these packages make the
programming job more convenient. However, these packages are evolving, and they
usually have several versions in use. For example, one Python program uses version
1.0 of a module while the other program imports version 2.0. If these two versions
are incompatible, these two Python programs cannot run successfully in one Python
environment. It is a good practice to run each Python program in its individual
environment (Zhou, 2020).</p>
<h4>1.1 Installing Python on Windows</h4>
<p>When enabling Machine Learning Services on a SQL Server instance, we can choose
to install Python on the server. However, we may prefer to install another version
of Python to run non-ML-related tasks, for example, web scarping. At the time of
writing, the latest version is Python 3.10.0. We download a Python installer from
the official Python download website:
<a href="https://www.python.org/downloads/" target="_blank">https://www.python.org/downloads/</a>.
We use the following steps to install the latest version of Python.</p>
<p><strong>1.1.1 Download the Python Installer</strong></p>
<p>Head to the download page and grab the version we need.
<a href="#_Ref89534983" target="_blank">Figure 1</a>
shows the landing page of the official Python download website at the time of this
writing. Click on the "Download Python 3.10.0" button to download the
Python installer. We can then find the file "python-3.10.0-amd64.exe"
in the downloads folder.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.001.png" height="330" width="629" alt="download python" />
</div>
<p style="text-align: center"><a name="_Ref89534983">
Figure
1</a> The Landing page of the Official Python
Download Website</p>
<p><strong>1.1.2 Run the Python Installer</strong></p>
<p>Click on the installer "python-3.10.0-amd64.exe" in the downloads
folder to install Python. The first screen, shown in
<a href="#_Ref89535742" target="_blank">Figure 2</a>,
allows us to determine how to install Python. Note that we do not need to check
the "Add Python 3.10 to PATH" checkbox. We install this version to a
SQL Server machine, and the machine may have multiple versions of Python. We may
not need to run this version in the command prompt (Shalewa, 2020). Since we want
to specify an installation folder, click on the "Customize installation"
link button to continue the installation process.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.002.png" height="367" width="600" alt="install python setup" />
</div>
<p style="text-align: center"><a name="_Ref89535742">
Figure
2</a> Run the Python Installer
</p>
<p><strong>1.1.3 Select Optional Features</strong></p>
<p>The second screen, shown in <a href="#_Ref89536971" target="_blank">
Figure 3</a>, allows us to enable or disable
features. We may uncheck some features. However, for simplicity&rsquo;s sake, we
go ahead with default settings. Click on the "Next" button to continue
installing Python.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.003.png" height="366" width="600" alt="install python setup" />
</div>
<p style="text-align: center"><a name="_Ref89536971">
Figure
3</a> Select Optional Features
</p>
<p><strong>1.1.4 Select Advanced Options</strong></p>
<p>As shown in <a href="#_Ref89537146" target="_blank">
Figure 4</a>, the screen allows us to select
some advanced options. First, check the "install for all users" checkbox.
We then select an install location, such as the "c:\Python310" folder.
Finally, click on the "Install" button to install Python.</p>
<div class="imageborder">
<img loading="lazy" alt="install python setup" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.004.png" height="368" width="600" />
</div>
<p style="text-align: center"><a name="_Ref89537146">
Figure
4</a> Select Advanced Options</p>
<p><strong>1.1.5 Watch the Setup Progress</strong></p>
<p>The Setup Progress screen appears, as shown in
<a href="#_Ref89537706" target="_blank">Figure 5</a>.
The progress bar on the screen visualizes the progression of the setup process.
This step may take a few minutes. We should not see any warning or error message
at this step. After this step is complete, the confirmation window shows up automatically.
</p>
<div class="imageborder">
<img loading="lazy" alt="install python setup" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.005.png" height="367" width="600" />
</div>
<p style="text-align: center"><a name="_Ref89537706">
Figure
5</a> The Progress Bar Shows the Setup Progress
</p>
<p><strong>1.1.6 Confirm the Installation</strong></p>
<p>As shown in <a href="#_Ref89538180" target="_blank">
Figure 6</a>, the conformation window automatically
displays after the setup process is complete. Click on the "Close" button
to finish the Python installation.</p>
<div class="imageborder">
<img loading="lazy" alt="install python setup" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.006.png" height="366" width="600" />
</div>
<p style="text-align: center"><a name="_Ref89538180">
Figure
6</a> The Installation Confirmation
</p>
<p><strong>1.1.7 Verify the Installation</strong></p>
<p>Let us check if we install Python successfully by executing a Python command.
We want to run the "python --version" command on a prompt window. First,
open the Python install location folder. We can see a python.exe file in the folder,
as shown in <a href="#_Ref89545428" target="_blank">
Figure 7</a>.</p>
<div class="imageborder">
<img loading="lazy" alt="windows explorer" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.007.png" height="411" width="660" />
</div>
<p style="text-align: center"><a name="_Ref89545428">
Figure
7</a> Python Install Location Folder
</p>
<p>Next, type the command &quot;cmd&quot; into the location bar, as shown in
<a href="#_Ref89545835" target="_blank">Figure 8</a>.
Then, press the &quot;Enter&quot; key on the keyboard. A command prompt window appears,
and the &quot;cmd&quot; command takes the path of this folder.</p>
<div class="imageborder">
<img loading="lazy" alt="windows explorer" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.008.png" height="405" width="660" />
</div>
<p style="text-align: center"><a name="_Ref89545835">
Figure
8</a> Type the "cmd" Command
into the Location Bar</p>
<p>On the command prompt window, we run the command &quot;python --version&quot;
to check the Python version. As shown in <a href="#_Ref89547131" target="_blank">
Figure 9</a>, the command&apos;s output indicates
that the version is 3.10.0. Therefore, the Python installation worked. Before we
construct a virtual environment, let us prepare the Python script and the database
table.</p>
<div class="imageborder">
<img loading="lazy" alt="python command line" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.009.png" height="152" width="660" />
</div>
<p style="text-align: center"><a name="_Ref89547131">
Figure
9</a> Check the Python Version
</p>
<p>We created a folder "C:\pyapps" to store all those application files
in the author&rsquo;s testing environment. Under this folder, we create a sub-folder
"C:\pyapps\htmltablescraping"
and download the Python script to this folder. The downloaded package should include
a "requirements.txt" file, which contains a list of items for running
this project. The "requirements.txt" file should have the following
lines:</p>
<div class="codediv">
<pre><span style="font-family: 'Cascadia Mono'">beautifulsoup4==4.10.0</span>
<span style="font-family: 'Cascadia Mono'">certifi==2021.10.8</span>
<span style="font-family: 'Cascadia Mono'">charset-normalizer==2.0.6</span>
<span style="font-family: 'Cascadia Mono'">idna==3.2</span>
<span style="font-family: 'Cascadia Mono'">pyodbc==4.0.32</span>
<span style="font-family: 'Cascadia Mono'">requests==2.26.0</span>
<span style="font-family: 'Cascadia Mono'">setuptools==57.4.0</span>
<span style="font-family: 'Cascadia Mono'">soupsieve==2.2.1</span>
<span style="font-family: 'Cascadia Mono'">urllib3==1.26.7&#xa0;</span>
</pre>
</div>
<p>To prepare for running the Python script, we need to configure the database connection
string in the script and create the database table using the following SQL script:
</p>
<div class="codediv">
<pre>
CREATE TABLE [dbo].[stg_language_self_study_programs]( 
   [self_study_program] [nvarchar](50) NOT NULL, 
   [number_of_languages_taught] [nvarchar](50) NOT NULL, 
   [interface_languages] [nvarchar](500) NOT NULL, 
   [media] [nvarchar](100) NOT NULL, 
   [business_model] [nvarchar](250) NOT NULL, 
   [date_extracted] [datetime] NOT NULL DEFAULT getdate(), 
CONSTRAINT [PK_stg_language_self_study_programs] PRIMARY KEY CLUSTERED ([self_study_program] ASC) 
)
</pre>
</div>
<h4>1.2 Using a Virtual Environment</h4>
<p>The author created another folder, "C:\pyvirtuals," to store all
virtual environments. We recommend using the "venv" module to create
lightweight virtual environments. The virtual environments created by this module
are sandboxed, fresh, user-installable library capable, and multi-python safe (Anand,
2020). We use the following steps to create a virtual environment on the SQL Server
machine.</p>
<p><strong>1.2.1 Create a Virtual Environment</strong></p>
<p>If the command prompt window is closed, we open the window in the Python install
location again. We then run the following command to create a Python virtual environment
in the "C:\pyvirtuals\htmltablescraping" folder, which corresponds to
the location of the Python program in the application folder:</p>
<div class="codediv">
<pre>
python -m venv C:\pyvirtuals\htmltablescraping
</pre>
</div>
<p><a href="#_Ref89553513" target="_blank">Figure 10</a>
illustrates how to run the command on the command prompt window. Opening the folder
"C:\pyvirtuals,"
we see a new sub-folder "C:\pyvirtuals\htmltablescraping" that was created
by the command. There is a copy of the Python interpreter and many supporting files
inside this sub-folder.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.010.png" height="147" width="660" alt="python command line" />
</div>
<p style="text-align: center"><a name="_Ref89553513">
Figure
10</a> Create a Virtual Environment
</p>
<p>
<strong>1.2.2 Activate the Virtual
Environment</strong></p>
<p>To run Python programs in this virtual environment, activate the environment
by running the "activate.bat" batch script in the "C:\pyvirtuals\htmltablescraping\Scripts"
folder. First, open the command prompt window in the folder where the batch script
is located. Next, run the batch script. As shown in
<a href="#_Ref89579278" target="_blank">Figure 11</a>,
activating the virtual environment changes the shell&rsquo;s prompt to indicate
the virtual environment we are using.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.011.png" height="147" width="660" alt="python command line" />
</div>
<p style="text-align: center"><a name="_Ref89579278">
Figure
11</a> Activate the Virtual Environment
</p>
<p><strong>&#xa0;1.2.3 Install the Necessary Packages</strong></p>
<p>The Python script needs some packages, for example, beautifulsoup4, requests,
and pyodbc, to scrape raw data from the web page and save formatted data into the
database table. We use the following command to install all these necessary packages
from the "requirements.txt" file:</p>
<div class="codediv">
<pre>
pip install -r C:\pyapps\htmltablescraping\requirements.txt
</pre>
</div>
<p><a href="#_Ref89580546" target="_blank">Figure 12</a>
shows that the installation is in progress. We may see some error messages because
the version of pyodbc used in this Python script is 4.0.32, and we want to install
the package to Python 3.10. Unfortunately, as of this writing, the pyodbc version
does not have pre-built wheel files for Python 3.10. Thompson provided a workaround
to resolve this issue on the Stack Overflow platform (Thompson, 2021).</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.012.png" height="273" width="660" alt="python command line" />
</div>
<p style="text-align: center"><a name="_Ref89580546">
Figure
12</a> Install the Necessary Packages
</p>
<p><strong>1.2.4 Run the Python Script</strong></p>
<p>Let us run the Python script in the folder "C:\pyapps\htmltablescraping"
in this virtual environment. This environment should be active now. If not, we must
activate the virtual environment. Then, we use the following command to run the
Python script:</p>
<div class="codediv">
<pre>
python C:\pyapps\htmltablescraping\HTML_Table_Scraping.py
</pre>
</div>
<p><a href="#_Ref89593996" target="_blank">Figure 13</a>
shows the output in the command window. At the time of this writing, the output
displays the warning message from the Python script execution. In addition, the
database table "[dbo].[stg_language_self_study_programs]" should have
rows, which indicates we run the Python script successfully.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.013.png" height="175" width="660" alt="python command line" />
</div>
<p style="text-align: center"><a name="_Ref89593996">
Figure
13</a> Run the Python Script</p>
<p><strong>1.2.5 Deactivate the Virtual Environment</strong></p>
<p>After using the virtual environment to run the Python script, we can deactivate
a virtual environment by typing "deactivate" in the command window,
as shown in <a href="#_Ref89584348" target="_blank">
Figure 14</a>. The "deactivate"
invokes the batch script "deactivate.bat" in the "C:\pyvirtuals\htmltablescraping\Scripts"
folder. Deactivating the virtual environment changes the shell&rsquo;s prompt back
to the default.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.014.png" height="106" width="660" alt="python command line" />
</div>
<p style="text-align: center"><a name="_Ref89584348">
Figure
14</a> Deactivate the Virtual Environment
</p>
<h4>1.3 Creating a Batch File to Run the Python Script</h4>
<p>Let us recap those steps to run the Python script in the virtual environment.
First, we manually opened the command prompt window in the folder where the batch
script "activate.bat" was located. Then, after we activated the virtual
environment, we ran the Python script. Finally, we deactivated the virtual environment
after the execution was complete. We can use a batch file to include all these steps;
then, we can run the batch file to implement the process.</p>
<p><strong>1.3.1 The %ERRORLEVEL% Variable and the Exit Code</strong></p>
<p>When we run a Python program, the interpreter exits the program when it reaches
the end of the script. In this case, the exit code is 0, which indicates successful
execution of the program. On the other hand, the non-zero exit code indicates a
failure in execution of the program. When we use window command prompt to run an
external command, the command prompt detects the exit code and set the %ERRORLEVEL%
variable to match. In most cases the %ERRORLEVEL% variable will be the same as the
exit code.</p>
<p>We can conduct a test to check the value of the %ERRORLEVEL% variable. In the
sample project, the primary key of the database table is "[self_study_program]."
Therefore, we receive the primary key constraint violation error when re-running
the Python script. We make this error for testing purposes. Let us use the following
SQL command to truncate the table.</p>
<div class="codediv">
<pre>
truncate table [dbo].[stg_language_self_study_programs] 
</pre>
</div>
<p>We then run the Python program twice. The program runs to the end the first time
but throws an exception in the second run. At each execution, we check the value
of the %ERRORLEVEL% variable. As shown in
<a href="#_Ref90118714" target="_blank">Figure 15</a>,
the variable has a value of 0 and 1 when the program execution is successful or
failed, respectively.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.015.png" height="314" width="660" alt="python command line" />
</div>
<p style="text-align: center"><a name="_Ref90118714"></a>
<a name="_Ref90118711">Figure
15 The
Window Command Prompt Detects the Exit Code</a></p>
<p><strong>1.3.2 The Batch Script</strong></p>
<p>We use the following script to include all steps to run the Python script in
the virtual environment. When we use the batch script to run the Python script,
the variable %ERRORLEVEL% contains the return code of the preceding external command
execution. We then return 0 or 1 to the batch script&rsquo;s caller according to
the values in the variable %ERRORLEVEL%.</p>
<div class="codediv">
<pre>
@echo off
REM remember the initial folder location
set original_dir=%CD%
REM the location of the virtual environment
set venv_root_dir="C:\pyvirtuals\htmltablescraping"
REM the location of the Python script
set app_root_dir="C:\pyapps\htmltablescraping"
REM activate the virtual environment
call %venv_root_dir%\Scripts\activate.bat
REM change to the folder of the Python script 
cd %app_root_dir%
REM run the python script 
python HTML_Table_Scraping.py
REM handling exit code from Python script
if %errorlevel% == 0 (
   call :rollback_setting
   echo "Python script execution succeeded." 
   REM terminate the current script, 
   REM but leaves the parent window/script/calling label open.
   exit /b 0
) else (
   call :rollback_setting
   echo "Python script execution failed." 
   REM terminate the current script, 
   REM but leaves the parent window/script/calling label open.
   exit /b 1
)

REM define a function
:rollback_setting
	REM deactivate the virtual environment
	call %venv_root_dir%\Scripts\deactivate.bat
	REM change to the initial folder location
	cd %original_dir%
	REM ensure that the function exits properly.
	exit /b 0
</pre>
</div>
<p>We create a batch file and place it in the &quot;C:\pyapps\htmltablescraping&quot;
folder. Note that we should truncate the table before running this batch file. We
run the batch file twice, and the batch file&apos;s output should look like
<a href="#_Ref89632667" target="_blank">Figure 16</a>.
</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.016.png" height="374" width="660" alt="python command line" />
</div>
<p style="text-align: center"><a name="_Ref89632667">
Figure
16</a> Run the Batch Script Twice
</p>
<p>When the batch script runs successfully, the value of the variable %ERRORLEVEL%
is 0. The batch script prints the statement &quot;Python script execution succeeded&quot;
and returns the code 0 to its caller. When the Python script throws an exception,
the value of the variable %ERRORLEVEL% is 1. The batch script prints the statement &quot;Python
script execution failed&quot; and returns code 1 to its caller.</p>
<h2>2 &ndash; Run the Python Script in SQL Server Agent</h2>
<p>SQL Server Agent defines several subsystems that allow us to run different types
of tasks (Ghanayem et al., 2021). However, as of this writing, we cannot use any
subsystem to execute Python scripts directly. Nevertheless, the "Operating
System (CmdExec)" subsystem supports executing an executable program. For
example, we can use this subsystem to run a batch file. Moreover, the subsystem
can read the return code and errors from the executable programs. These features
allow us to run the Python script in SQL Server Agent.</p>
<h4>2.1 Creating a SQL Server Agent Job</h4>
<p>Microsoft SQL Server Management Studio (SSMS) provides a user-friendly graphic
interface to create SQL Server Agent jobs, specify job steps, set schedules, fire
alerts, and deliver notifications. SSMS also allows us to access job steps execution
history that includes details on the success and failure of executing individual
job steps over the last seven days as recorded in MSDB. On the MSSQLTips platform,
many tutorials introduce creating scheduled SQL Server Agent Jobs and monitoring
job activities. This section briefly covers steps to create a job to run the Python
script and attach a schedule to the job.</p>
<p><strong>2.1.1 Navigate to the SQL Server Agent</strong></p>
<p>To create a SQL Server Job, we first need to ensure that the SQL Server Agent
service is running. We use the &quot;Windows + R&quot; keyboard shortcut to access
the &quot;Run&quot; command dialog box. We then enter the command &quot;services.msc&quot;
to open the services window, as shown in <a href="#_Ref89716597" target="_blank">
Figure 17</a>. The SQL Server Agent service
should have a &quot;Running&quot; status.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.017.png" height="337" width="660" alt="sql server agent service" />
</div>
<p style="text-align: center"><a name="_Ref89716597">
Figure
17</a> Access the Service Window
</p>
<p>Open the SSMS and connect to a SQL Server instance. Then, on the Object Explorer
pane, navigate to SQL Server Agent -&gt; Jobs, as shown in
<a href="#_Ref89717168" target="_blank">Figure 18</a>.
</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.018.png" height="388" width="480" alt="smss sql server agent" />
</div>
<p style="text-align: center"><a name="_Ref89717168">
Figure
18</a> Expand SQL Server Agent in the Object
Explorer Pane</p>
<p><strong>2.1.2 Define a New Job</strong></p>
<p>Right-click on the "Jobs" node and select the "New Job&hellip;"
menu item from the connect menu. The "New Job" window appears. The window
should look like <a href="#_Ref90053687" target="_blank">
Figure 19</a>. In the general tab, we enter
a name for the new job and select the category as "Uncategorized(local)."
</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.019.png" height="622" width="660" alt="create new sql agent job" />
</div>
<p style="text-align: center"><a name="_Ref90053687">
Figure
19</a> Create a New Job</p>
<p><strong>2.1.3 Create a Job Step</strong></p>
<p>Move to the "Steps" tab and click on the &quot;New&hellip;&quot;
button. The window &quot;New Job Step&quot; should show up. We fill the form, as
shown in <a href="#_Ref89718237" target="_blank">Figure
20</a>. The textbox of &quot;Process exit code of a successful command&quot;
defaults to a &quot;0&quot; value. The exit code &quot;0&quot; already represents
success in the batch and Python scripts. We must use the identical definition of
exit codes in every place. In addition, by default, &quot;CmdExec&quot; job steps
run under the context of the SQL Server Agent service account. If any permission
issue occurs during the testing, we should use a proxy account that has permission
to run the batch script. In the Command box, we enter the following command:</p>
<div class="codediv">
<pre>
cmd.exe /c &quot;C:\pyapps\htmltablescraping\batch.bat&quot;
</pre>
</div>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.020.png" height="625" width="660" alt="create new sql agent job" />
</div>
<p style="text-align: center"><a name="_Ref89718237">
Figure
20</a> Create a New Job Step to Run the
Batch Script</p>
<p>Click on the &quot;OK&quot; button to close the &quot;New Job Step&quot; window.
We stay focused on the &quot;New Job&quot; window.</p>
<p><strong>2.1.4 Create a Job Schedule</strong></p>
<p>Now let us create and attach a schedule to the job. Move to the "Schedules"
tab and click on the "New" button to open a "New Job Schedule"
window. For testing purposes, we want the job to run every hour. We define scheduling
rules, as shown in <a href="#_Ref89720302" target="_blank">
Figure 21</a>.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.021.png" height="556" width="606" alt="create new sql agent job" />
</div>
<p style="text-align: center"><a name="_Ref89720302">
Figure
21</a> Create and Attach a Schedule to the
New Job</p>
<p>Click on the "OK" button to close the "New Job Schedule"
window. Then, we go back to the "New Job" window. Click on the "OK"
button to save the job definition and close the "New Job" window. The
new job appears in the "Object Explorer" pane, as shown in
<a href="#_Ref89720111" target="_blank">Figure 22</a>.
</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.022.png" height="392" width="468" alt="sql agent jobs" />
</div>
<p style="text-align: center"><a name="_Ref89720111">
Figure
22</a> A New Job in the Object Explorer
Pane</p>
<h4>2.2 Running the SQL Server Job</h4>
<p>After we attach a schedule to a job, the job runs automatically according to
the predefined rules. In addition, we can run a job manually for troubleshooting
or testing purposes. We check the Python script execution status through the Log
File Viewer, which provides detailed information about job step executions. Before
running the job, we need to truncate the table so that the Python script can run
successfully for the first time.</p>
<p><strong>2.2.1 Run the Job Manually</strong></p>
<p>To run the job, right-click on the job name and select the "Start Job at
Step&hellip;" menu item from the context menu, as shown in
<a href="#_Ref89720730" target="_blank">Figure 23</a>.
</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.023.png" height="609" width="476" alt="start sql agent job" />
</div>
<p style="text-align: center"><a name="_Ref89720730">
Figure
23</a> Run the Agent Job Manually
</p>
<p>After the job is complete, a confirmation dialog, like
<a href="#_Ref89721809" target="_blank">Figure 24</a>,
should show up to confirm the success.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.024.png" height="261" width="420" alt="sql agent job status" />
</div>
<p style="text-align: center"><a name="_Ref89721809">
Figure
24</a> The Agent Job Ran Successfully
</p>
<p>The error occurs when we run the job a second time because of the primary key
constraint violation error. <a href="#_Ref89721936" target="_blank">
Figure 25</a> illustrates the confirmation window
when the job fails.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.025.png" height="266" width="420" alt="sql agent job status" />
</div>
<p style="text-align: center"><a name="_Ref89721936">
Figure
25</a> The Agent Job Failed</p>
<p><strong>2.2.2 View the Job Execution History</strong></p>
<p>We can use the Log File Viewer in SSMS to access job execution history. To open
the Log File Viewer window, navigate to the new job in the Object Explorer pane
again, right-click on the job name, and select the &quot;View History&quot; item
from the context menu, as shown in <a href="#_Ref89802903" target="_blank">
Figure 26</a>.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.026.png" height="605" width="470" alt="view sql agent job history" />
</div>
<p style="text-align: center"><a name="_Ref89802903"></a>
<a name="_Ref89802898">Figure
26 Access
Job Execution History</a></p>
<p>The Log File Viewer window appears, as shown in
<a href="#_Ref89802991" target="_blank">Figure 27</a>.
Since we have run the job twice, there are two entries in the Log file summary section.
Expanding the first entry from bottom to top, we can view detailed information about
the job step execution. For example, we see a warning message from the Python script
execution and a short statement from the echo command in the batch file in the message
section. The text in the message section also indicates that the process exit code
is 0.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.027.png" height="579" width="660" alt="job run details" />
</div>
<p style="text-align: center"><a name="_Ref89802991">
Figure
27</a> The Details of the Successful Job
Execution</p>
<p>We already know that the job failed the second time. Let us check the details.
Navigate to the second entry from the bottom to the top. Expanding the entry, we
access the detailed information about the job step execution. We see the error message
raised in the Python script execution and an assertion from the echo command in
the batch file in the message section, as shown in
<a href="#_Ref90122175" target="_blank">Figure 28</a>.
The history data also indicates that the process exit code is 1, which means a failure.
</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.028.png" height="584" width="660" alt="job run details" />
</div>
<p style="text-align: center"><a name="_Ref90122175">
Figure
28</a> The Details of the Failed Job
</p>
<p><strong>2.2.3 Run the Job Automatically</strong></p>
<p>SQL Server Agent can run a job on a schedule, responding to a specific event
or on-demand (Ghanayem et al., 2021). We created a schedule and attached it to the
job. Therefore, the job runs every hour. We truncate the table so that the job execution
at 10:00 PM will succeed and the execution at 11:00 PM will fail. Let us log out
of the database server now. We log in after 11:00 PM and check the log. As shown
in <a href="#_Ref89804576" target="_blank">Figure 29</a>,
there are two more entries in the Log File Viewer window. Expand the execution record
at 10:00 PM. We see detailed information about the automatic execution. The successful
message in this log is the same as the successful message in the manual execution.
</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.029.png" height="585" width="660" alt="job run details" />
</div>
<p style="text-align: center"><a name="_Ref89804576">
Figure
29</a> The Job Succeeded at 10:00 PM
</p>
<p>Let us check the log of the execution at 11:00 PM. First, expand the execution
record, as shown in <a href="#_Ref89804580" target="_blank">
Figure 30</a>. We then examine detailed information
about the failed execution. The unsuccessful message in this log is the same as
the unsuccessful message in the manual execution. Even though we can use the Log
File Viewer provided by SQL Server Agent to check Python script executions, the
Python script should maintain a log file that records more detailed execution information
for troubleshooting.</p>
<div class="imageborder">
<img loading="lazy" src="/tipimages2/7083_run-python-scripts-sql-server-agent-job.030.png" height="587" width="660" alt="job run details" />
</div>
<p style="text-align: center"><a name="_Ref89804580">
Figure
30</a> The Job Failed at 11:00 PM
</p>
<h2>Summary</h2>
<p>Python, described as a glue language, has become one of the most popular programming
languages worldwide. In addition, SQL Server Agent can manage scheduled tasks. Taking
advantage of these two tools enables us to automate many routine tasks. This article
introduced running a Python script through the SQL Server Agent.</p>
<p>We started with a gentle introduction to run a Python script in a virtual environment.
Then, we went through every step to install Python on a SQL Server machine. Next,
we covered the steps to create a virtual environment. Finally, after exploring commands
to run a Python script in a virtual environment, we created a batch file to automate
some manual steps.</p>
<p>We then briefly explored creating a SQL Server Agent job and a job step. We also
created a schedule and attached it to the job. Next, we moved to job execution.
We ran the job manually and automatically. Finally, we checked the job execution
history. We observed that the Python and batch scripts could transport script execution
information to SQL Server Agent.</p>
<h2>Reference</h2>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Anand
A. (2020). <em>Venvs &amp; Pyenvs &amp; Pipenvs, OH MY!</em> https://towardsdatascience.com/venvs-pyenvs-pipenvs-oh-my-2411149e2f43.
</p>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Das, A.
(2020). <em>Introduction to the SQL Server Agent</em>. https://www.sqlshack.com/introduction-to-the-sql-server-agent.
</p>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Ericson,
G., Buck, A. Dphansen, Coulter, D. &amp; Ray, M. (2021). <em>What is SQL Server
Machine Learning Services with Python and R</em>? https://docs.microsoft.com/en-us/sql/machine-learning/sql-server-machine-learning-services?view=sql-server-ver15.
</p>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Ghanayem,
M., Ray, M., Coulter, D., Rabeler, C., Roth, J., Cai, S., &amp; Guyer, C. (2021).
<em>SQL Server Agent</em>. https://docs.microsoft.com/en-us/sql/ssms/agent/sql-server-agent?view=sql-server-ver15.
</p>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Shalewa
(2020). <em>Why You Should Add Python to PATH and How</em>. https://medium.com/@omoshalewa/why-you-should-add-python-to-path-and-how-58693c17c443.
</p>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Sweigart,
A. (2020). <em>Automate the Boring Stuff with Python, 2nd Edition</em>, San Francisco,
CA: No Starch Press, Inc.</p>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Thompson,
G. (2021). <em>unable to install pyodbc using python 3.10 in windows 10</em>. https://stackoverflow.com/questions/69943254/unable-to-install-pyodbc-using-python-3-10-in-windows-10.
</p>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Zhou,
N. (2020). <em>Learning Python in Visual Studio 2019</em>,
https://www.mssqltips.com/sqlservertip/6442/learning-python-in-visual-studio-2019/.
</p>
<p style="margin-left: 21.6pt; text-indent: -21.6pt; line-height: normal; word-break: break-all;">Zhou,
N. (2021). <em>Using Python to Download Data from an HTML Table to an SQL Server
Database</em>. https://www.mssqltips.com/sqlservertip/7041/python-example-web-scraping-project/.
</p>
<h5>Next Steps</h5>
<ul>
<li>We used the Log File Viewer to check the job execution status in this article.
However, there may be many agent jobs in practice, and we must constantly monitor
their execution status. Therefore, we may need to know other tools and learn
SQL Server Agent more deeply. Several MSSQLTips authors shared their experience
and knowledge about SQL Server Agent. We can access their tips through
<a href="/sql-server-tip-category/27/sql-server-agent/" target="_blank">this
link</a>.
In addition, Richard Waymire explains many uses of SQL Server Agent. We can
access his articles through
<a href="https://www.sqlservercentral.com/stairways/stairway-to-sql-server-agent" target="_blank">
this link</a>.
The job step has sufficient privileges to run the Python script when its owner
is the "sa" account. Nevertheless, other database users may receive
this error, "Non-SysAdmins have been denied permission to run CmdExec
job steps without a proxy account. The step failed." In this case, we
should create a SQL Server Agent proxy account to run the job step. Moreover,
a server usually hosts multiple Python applications. In practice, we do not
store application data on the "C" drive. Instead, we usually employ
a data drive that contains all application-related files.</li>
<li>Check out these related tips:
<ul>
<li>
<a href="/sqlservertip/5911/run-python-scripts-in-sql-server-agent/" target="_blank">
Run Python Scripts in SQL Server Agent</a></li>
<li>
<a href="/sqlservertip/5019/sql-server-agent-job-schedule-reporting/" target="_blank">
SQL Server Agent Job Schedule Reporting</a></li>
<li>
<a href="/sqlservertip/5805/script-out-sql-server-credentials-and-proxies/" target="_blank">
Script out SQL Server Credentials and Proxies</a></li>
<li>
<a href="/sqlservertip/1244/accessing-sql-server-agent-data/" target="_blank">
Accessing SQL Server Agent Data</a></li>
<li>
<a href="/sqlservertip/6442/learning-python-in-visual-studio-2019/" target="_blank">
Learning Python in Visual Studio 2019</a></li>
<li>
<a href="/sqlservertip/6694/crud-operations-in-sql-server-using-python/" target="_blank">
CRUD Operations in SQL Server using Python</a></li>
<li>
<a href="/sqlservertip/1622/generate-sql-agent-job-schedule-report/" target="_blank">
Generate SQL Agent Job Schedule Report</a></li>
<li>
<a href="/sqlservertip/6111/query-sql-server-agent-jobs-job-steps-history-and-schedule-system-tables/" target="_blank">
Query SQL Server Agent Jobs, Job Steps, History and Schedule System Tables</a>
</li>
<li>
<a href="/sqlservertip/7041/python-example-web-scraping-project/" target="_blank">
Using Python to Download Data from an HTML Table to an SQL Server Database</a>
</li>
</ul>
</li>
</ul>
<br /><br />
<div class="row">
<div class="large-6 medium-6 small-12 columns">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Related Articles</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '1394'});" href="/sqlservertip/1394/how-to-store-longer-sql-agent-job-step-output-messages/">How to store longer SQL Agent Job Step output messages</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '1400'});" href="/sqlservertip/1400/disabling-or-enabling-sql-server-agent-jobs/">Disabling or Enabling SQL Server Agent Jobs</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '1730'});" href="/sqlservertip/1730/different-ways-to-execute-a-sql-agent-job/">Different ways to execute a SQL Agent job</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '2163'});" href="/sqlservertip/2163/running-a-ssis-package-from-sql-server-agent-using-a-proxy-account/">Running a SSIS Package from SQL Server Agent Using a Proxy Account</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '2317'});" href="/sqlservertip/2317/running-sql-server-agent-with-a-least-privilege-service-account/">Running SQL Server Agent with a least privilege service account</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '2561'});" href="/sqlservertip/2561/querying-sql-server-agent-job-information/">Querying SQL Server Agent Job Information</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '2729'});" href="/sqlservertip/2729/how-to-start-sql-server-agent-when-agent-xps-show-disabled/">How to start SQL Server Agent when Agent XPs show disabled</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '2850'});" href="/sqlservertip/2850/querying-sql-server-agent-job-history-data/">Querying SQL Server Agent Job History Data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '3052'});" href="/sqlservertip/3052/simple-way-to-create-a-sql-server-job-using-tsql/">Simple way to create a SQL Server Job Using T-SQL</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '4901'});" href="/sqlservertip/4901/how-to-find-long-running-jobs-in-microsoft-sql-server/">How to Find Long Running Jobs in Microsoft SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '4920'});" href="/sqlservertip/4920/creating-multistep-and-dynamic-sql-server-agent-jobs/">Creating Multi-Step and Dynamic SQL Server Agent Jobs</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '4921'});" href="/sqlservertip/4921/queries-to-inventory-your-sql-server-agent-jobs/">Queries to inventory your SQL Server Agent Jobs</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '5019'});" href="/sqlservertip/5019/sql-server-agent-job-schedule-reporting/">SQL Server Agent Job Schedule Reporting</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '5731'});" href="/sqlservertip/5731/how-to-pass-data-between-sql-server-agent-job-steps/">How to Pass Data Between SQL Server Agent Job Steps</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '5911'});" href="/sqlservertip/5911/run-python-scripts-in-sql-server-agent/">Run Python Scripts in SQL Server Agent</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '5969'});" href="/sqlservertip/5969/manage-sql-server-agent-history-more-effectively/">Manage SQL Server Agent History More Effectively</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '6015'});" href="/sqlservertip/6015/enable-sql-server-agent-mail-profile/">Enable SQL Server Agent Mail Profile</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '6111'});" href="/sqlservertip/6111/query-sql-server-agent-jobs-job-steps-history-and-schedule-system-tables/">Query SQL Server Agent Jobs, Job Steps, History and Schedule System Tables</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '6285'});" href="/sqlservertip/6285/automate-sftp-file-transfer-with-sql-server-agent-and-winscp/">Automate SFTP File Transfer with SQL Server Agent and WinSCP</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Related', 'event_label': '6322'});" href="/sqlservertip/6322/sql-server-agent-service-wont-start-due-to-access-denied/">SQL Server Agent Service Won't Start Due to Access Denied</a><br><br>
</div>
</div>
<div class="large-6 medium-6 small-12 columns">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Popular Articles</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '1145'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions Using SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '2655'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates with FORMAT Function</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '1599'});" href="/sqlservertip/1599/cursor-in-sql-server/">SQL Server Cursor Example</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '1958'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">SQL Server CROSS APPLY and OUTER APPLY</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '2914'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows into a single row and column for SQL Server data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '6769'});" href="/sqlservertip/6769/sql-server-drop-table-if-exists/">SQL Server DROP TABLE IF EXISTS Examples</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '1140'});" href="/sqlservertip/1140/how-to-tell-what-sql-server-version-you-are-running/">How to tell what SQL Server versions you are running</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '2509'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates using DATEADD in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '6904'});" href="/sqlservertip/6904/sql-not-in-operator/">SQL NOT IN Operator</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '6148'});" href="/sqlservertip/6148/sql-server-loop-through-table-rows-without-cursor/">SQL Server Loop through Table Rows without Cursor</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '1704'});" href="/sqlservertip/1704/using-merge-in-sql-server-to-insert-update-and-delete-at-the-same-time/">Using MERGE in SQL Server to insert, update and delete at the same time</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '2340'});" href="/sqlservertip/2340/resolving-could-not-open-a-connection-to-sql-server-errors/">Resolving could not open a connection to SQL Server errors</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '6452'});" href="/sqlservertip/6452/sql-convert-date-to-yyyymmdd/">SQL Convert Date to YYYYMMDD</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '6817'});" href="/sqlservertip/6817/sql-current-date/">How to Get Current Date in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '2985'});" href="/sqlservertip/2985/concatenate-sql-server-columns-into-a-string-with-concat/">Concatenate SQL Server Columns into a String with CONCAT()</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '2537'});" href="/sqlservertip/2537/sql-server-row-count-for-all-tables-in-a-database/">SQL Server Row Count for all Tables in a Database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '2779'});" href="/sqlservertip/2779/ways-to-compare-and-find-differences-for-sql-server-tables-and-data/">Ways to compare and find differences for SQL Server tables and data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '1160'});" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL commands in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '5460'});" href="/sqlservertip/5460/sql-server-database-stuck-in-restoring-state/">SQL Server Database Stuck in Restoring State</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7083', {'event_category': 'Popular', 'event_label': '1522'});" href="/sqlservertip/1522/searching-and-finding-a-string-value-in-all-columns-in-a-sql-server-table/">Searching and finding a string value in all columns in a SQL Server table</a><br><br>
</div>
</div>
</div>
<br /><br /><br />
<div class="row">
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="gtag('event', 'click', {'event_category': 'Scripts', 'event_label': 'BotTip'});" target="_blank"><img loading="lazy" border="0" src="/images/Free-Download_20190509.png" alt="get scripts" width="300" height="150"></a></div>
<br />
</div>
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/sql-server-tip-category/27/sql-server-agent/" onclick="gtag('event', 'click', {'event_category': 'NextTip', 'event_label': 'YellowArrow'});"><img loading="lazy" border="0" src="/images/nav_nexttip_clickhere_rev1.png" alt="next tip button" width="300" height="150"></a></div>
<br />
</div>
</div>
<br /><br />
<h5>About the author</h5>
<div class="row">
<div class="large-12 columns">
<a href="/sqlserverauthor/301/nai-biao-zhou/"><img loading="lazy" style="float: left; padding: 0px 10px 0px 0px;" alt="MSSQLTips author Nai Biao Zhou" height="150" src="/images/Nai-Biao-Zhou.png" width="100" /></a>
Nai Biao Zhou is a Senior Software Developer with 20+ years of experience in software development, specializing in Data Warehousing, Business Intelligence, Data Mining and solution architecture design.
<br /><br /><b><a href="/sqlserverauthor/301/nai-biao-zhou/">View all my tips</a></b>
</div>
</div>
<br /><br />
Article Last Updated: 2021-12-22
<a name="comments"></a>
</article>
<div class="row">
</div>
<div class="hide-for-print">
<hr>
<h2>Comments For This Article</h2>
<button class="button round" data-reveal-id="myModal" data-reveal-ajax="/zurb_comments.asp?id=1x7083">Add Comment</button>
<div id="myModal" class="reveal-modal" data-reveal aria-labelledby="modalTitle" aria-hidden="true" role="dialog">
</div>
<style type="text/css">
.ForumPostBodyArea
{
	width: 100%;
	vertical-align: top;
	overflow: auto;
}
</style>
<br /><br /><br />
</div>
</div>
<style>
			div.stickyright {
			  position: -webkit-sticky;
			  position: sticky;
			  padding: 0;
			  background-color: white;
			  width: 300px;
			  z-index: 1;
			}
	</style>
<div class="large-3 hide-for-print columns rightsize">
<br />
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="gtag('event', 'click', {'event_category': 'download-button', 'event_label': 'scripts'});" target="_blank"><img loading="lazy" src="/images/download-scripts.png" alt="download" width="273" height="93"></a></div>
<br /><br />

<div align="center">
<div id='div-gpt-ad-1388505177750-0' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-0'); });
	}	
	</script>
</div>
</div><br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-3' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-3'); });
	}	
	</script>
</div>
</div> <br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-1' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-1'); });
	}
	</script>
</div>
</div> <br /><br /><br />
<div class="stickyright" style="top:55px;">

<div align="center">
<div id='div-gpt-ad-1388505177750-2' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{	
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-2'); });
	}	
	</script>
</div>
</div> <br /><br /><br />
<a href="/mssqltips-author-of-year/" target="_blank"><img loading="lazy" src="/images/MSSQLTips_Vote_20220106.png" alt="vote" width="300" height="100"></a><br><br><br>
<script language="Javascript">
	function ValidateEmail(inputText)
	{
	
		if (document.optin.consent.checked == false) {
		     alert("Please agree to terms by ticking check box.");
		     return false;
	            }	
	   
		var mailformat = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
		if(inputText.value.match(mailformat))
		{
			document.optin.ea.focus();
			return true;
		}
		else
		{
			alert("You have entered an invalid email address!");
			document.optin.ea.focus();
			return false;
		}
	}

	</script>
<div id="sticky2">
<div id="search-div" style="height:300px; width:300px">
<div id="signup-div">
<div style="text-align: center;"><a href="/get-free-sql-server-tips/?ref=LeftGFSTSlant"><img loading="lazy" alt="get free sql tips" border="0" src="/images/GetFreeSQLTips_black_box.png" width="300" height="150"></a></div>
<form action="/get-free-sql-server-tips/" method="post" name="optin" onsubmit="return ValidateEmail(document.optin.ea)">
<input name="URL" type="hidden" value="leftform" />
<input name="ReferralURL" type="hidden" value="" />
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-10 columns">
<input size="25" type="text" onblur="if (this.value=='') this.value=this.defaultValue" onclick="if (this.defaultValue==this.value) this.value=''" value="enter business email" name="ea">
</div>
<div class="small-2 columns">
<input type="submit" name="Button1" value="Join" />
</div>
</div>
</div>
</div>
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-1 columns">
<input type="checkbox" name="consent" value="1">
</div>
<div class="small-11 columns">
<a href="/privacy/" target="_blank"><img loading="lazy" src="/images/mssqltips-agree-terms.png" alt="agree to terms" width="276" height="67"></a>
</div>
</div>
</div>
</div>
<br /><br />
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<footer class="row hide-for-print">
<hr />
<ul class="small-block-grid-2 medium-block-grid-3 large-block-grid-6" style="margin:10px;">
<li>
<h3><span style="color:#3B6D93">Follow</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=GetFooterMenu">Get Free SQL Tips</a></li>
<li><a rel="noopener" href="https://twitter.com/mssqltips" target="_blank">Twitter</a></li>
<li><a rel="noopener" href="https://www.linkedin.com/groups/2320891/" target="_blank">LinkedIn</a></li>
<li><a rel="noopener" href="https://www.facebook.com/mssqltips/" target="_blank">Facebook</a></li>
<li><a rel="noopener" href="https://www.pinterest.com/mssqltips/" target="_blank">Pinterest</a></li>
<li><a rel="noopener" href="https://feeds.feedburner.com/MSSQLTips-LatestSqlServerTips" target="_blank">RSS</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Learning</span></h3>
<ul>
<li><a href="/sql-server-dba-resources/">DBAs</a></li>
<li><a href="/sql-server-developer-resources/">Developers</a></li>
<li><a href="/sql-server-business-intelligence-resources/">BI Professionals</a></li>
<li><a href="/sql-server-professional-development-resources/">Careers</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Resources</span></h3>
<ul>
<li><a href="/sql-server-tutorials/">Tutorials</a></li>
<li><a href="/sql-server-webcasts/">Webcasts</a></li>
<li><a href="/sql-server-whitepapers/">Whitepapers</a></li>
<li><a href="/sql-server-tools/">Tools</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Search</span></h3>
<ul>
<li><a href="/sql-server-categories/">Tip Categories</a></li>
<li><a href="/search-tip-id/">Search By TipID</a></li>
<li><a href="/sql-server-mssqltips-authors/">Authors</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Community</span></h3>
<ul>
<li><a href="/learn-more-about-mssqltips/">First Timer?</a></li>
<li><a href="/mssqltips-community/1/">Pictures</a></li>
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/sql-server-event-list/">Event Calendar</a></li>
<li><a href="/sql-server-user-groups/">User Groups</a></li>
<li><a href="/mssqltips-author-of-year/">Author of the Year</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">More Info</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=JoinFooterMenu">Join</a></li>
<li><a href="/about/">About</a></li>
<li><a href="/copyright/">Copyright</a></li>
<li><a href="/privacy/">Privacy</a></li>
<li><a href="/disclaimer/">Disclaimer</a></li>
<li><a href="/feedback/">Feedback</a></li>
<li><a href="/advertise/">Advertise</a></li>
</ul>
</li>
</ul>
<hr />
<div class="row">
<div class="large-12 columns text-center">
<p>Copyright (c) 2006-2022 <a href="https://www.edgewoodsolutions.com">Edgewood Solutions, LLC</a> All rights reserved<br />
<small>Some names and products listed are the registered trademarks of their respective owners.</small></p>
</div>
</div>
</footer>

<style type="text/css">
#slideboxtop{
    width:100%;
    height:50px;
    padding:0px;
    background-color:#FFFFFF;      
    border-bottom:1px solid #000000;
    position:fixed;
    top: -350px;
	-moz-box-shadow:-2px 0px 5px #aaa;
	-webkit-box-shadow:-2px 0px 5px #aaa;
/* 	box-shadow:-2px 0px 5px #aaa;    */
}
</style>
<div class="hide-for-small hide-for-medium hide-for-print">
<div id="slideboxtop" style="z-index:1;">
<div style="text-align:center">
<div w3-include-html="/Site-Sponsorship/site-sponsorship.asp"></div>
</div>
</div>
</div>
<script src="/js/jquery-foundation-combined-min.js"></script>
<script type="text/javascript">
var articleLength = $("article").find("p").length;

 

</script>
<script>
    $(document).foundation();
</script>
<script type="text/javascript" src="/css/prettify.combined.js" defer></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function(){
		if  ($(window).scrollTop() > 250)
			$('#slideboxtop').animate({'top':'0px'});
		else
			$('#slideboxtop').stop(true).animate({'top':'-250px'});
	});
});
</script>
<script>
function includeHTML() {
  var z, i, elmnt, file, xhttp;
  /*loop through a collection of all HTML elements:*/
  
  z = document.getElementsByTagName("*");
  for (i = 0; i < z.length; i++) {
    elmnt = z[i];
    /*search for elements with a certain atrribute:*/
    file = elmnt.getAttribute("w3-include-html");
	if (file) {
      /*make an HTTP request using the attribute value as the file name:*/
      xhttp = new XMLHttpRequest();
      xhttp.onreadystatechange = function() {
        if (this.readyState == 4) {
          if (this.status == 200) {elmnt.innerHTML = this.responseText;}
          if (this.status == 404) {elmnt.innerHTML = "Page not found.";}
          /*remove the attribute, and call this function once more:*/
          elmnt.removeAttribute("w3-include-html");
          includeHTML();
        }
      }   
      xhttp.open("GET", file, true);
      xhttp.send();
      /*exit the function:*/
      return;
    }
  }
};
</script>
<script>
 if ($(window).width() > 1000) {
	includeHTML();
	$("div.rightsize").height($("#container").height());
    }	
</script>

<script> 
//<![CDATA[ 
if (screen.width > 0)
{
function deferGoogleJS() { 
var d = document.createElement("script"); 
d.src = "https://www.googletagmanager.com/gtag/js?id=UA-910745-2", 
document.body.appendChild(d) 
} 
window.addEventListener ? window.addEventListener("load", deferGoogleJS, !1) : window.attachEvent ? window.attachEvent("onload", deferGoogleJS) : window.onload = deferGoogleJS; 
window.dataLayer = window.dataLayer || [];

function gtag() { 
dataLayer.push(arguments); 
} 
gtag('js', new Date()); 
gtag('config', 'UA-910745-2'); 
}
//]]> 
</script>
</body>
</html>
