
<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta http-equiv="Content-Language" content="en-us" />
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

<link rel="SHORTCUT ICON" href="/favicon.ico" />
<meta content="width=device-width, initial-scale=1.0" name="viewport" />
<title>How to get length of Text, NText and Image columns in SQL Server</title>
<meta name="description" content="There is sometimes a need to figure out the maximum space that is being used by a particular column in your database.  You would initially think that the LEN() function would allow you to do this, but this function does not work on Text, NText or Image da" />
<link rel="canonical" href="https://www.mssqltips.com/sqlservertip/1188/how-to-get-length-of-text-ntext-and-image-columns-in-sql-server/" />
<link rel="stylesheet" href="/css/foundation-app-combined-min.css">
<script>/*! loadCSS. [c]2017 Filament Group, Inc. MIT License */!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mssqltips.com/sqlservertip/1188/how-to-get-length-of-text-ntext-and-image-columns-in-sql-server/"
  },
  "headline": "How to get length of Text, NText and Image columns in SQL Server",
  "image": [
  
    "https://www.mssqltips.com/images_newsletter/1188_NewsletterImage.png"
  
   ],  
  "datePublished": "2007-02-27T00:00:00+05:00",
  "dateModified": "2022-04-04T00:00:00+05:00",
  "author": {
    "@type": "Person",
    "name": "Greg Robidoux"
  },
   "publisher": {
    "@type": "Organization",
    "name": "MSSQLTips",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.mssqltips.com/images/mslogo_113x60.png"
    }
  },
  "description": "There is sometimes a need to figure out the maximum space that is being used by a particular column in your database.  You would initially think that the LEN() function would allow you to do this, but this function does not work on Text, NText or Image da"
}
</script>
<meta property="og:url" content="https://www.mssqltips.com/sqlservertip/1188/how-to-get-length-of-text-ntext-and-image-columns-in-sql-server/" />
<meta property="og:type" content="website" />
<meta property="og:title" content="How to get length of Text, NText and Image columns in SQL Server" />
<meta property="og:description" content="There is sometimes a need to figure out the maximum space that is being used by a particular column in your database.  You would initially think that the LEN() function would allow you to do this, but this function does not work on Text, NText or Image da" />
<meta property="og:image" content="https://www.mssqltips.com/images_newsletter/1188_NewsletterImage.png" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mssqltips">
<meta name="twitter:creator" content="@mssqltips">
<meta name="twitter:title" content="How to get length of Text, NText and Image columns in SQL Server">
<meta name="twitter:description" content="There is sometimes a need to figure out the maximum space that is being used by a particular column in your database.  You would initially think that the LEN() function would allow you to do this, but this function does not work on Text, NText or Image da">
<meta name="twitter:image" content="https://www.mssqltips.com/images_newsletter/1188_NewsletterImage.png">
<script>

var head = document.getElementsByTagName('head')[0];
var js = document.createElement("script");

js.type = "text/javascript";

if (screen.width > 749)
{
    js.src = "https://securepubads.g.doubleclick.net/tag/js/gpt.js";
}
head.appendChild(js);

if (screen.width > 749)
{

!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

apstag.init({
  pubID: '434bb5e4-3704-4b75-b36c-785a444462bd',
  adServer: 'googletag',
  simplerGPT: true,
  schain: {
    complete: 1,
    ver: '1.0',
    nodes: [
      {
        asi: 'theadengine.com',
        sid: '01307',
        hp: 1,
      },
    ],
  },
});

window.googletag = window.googletag || {cmd: []};

googletag.cmd.push(function() {

   var mapping = googletag.sizeMapping().
   addSize([100, 100], []).
   addSize([320, 400], []).
   addSize([320, 700], []).
   addSize([750, 200],  [[728, 90],[300,250],[160,300],[300,600],[170,90]]).
   addSize([1050, 200], [[728, 90],[300,250],[160,300],[300,600],[170,90]]).build();

   var mapping728 = googletag.sizeMapping()
     .addSize([750, 200], [728, 90])
     .addSize([0, 0], [])
     .build();
   var mapping300 = googletag.sizeMapping()
     .addSize([640, 400], [300, 250])
     .addSize([0, 0], [])
     .build();
   var mapping600 = googletag.sizeMapping()
     .addSize([640, 600], [[160,600],[300,600]])
     .addSize([0, 0], [])
     .build();
   var mapping170 = googletag.sizeMapping()
     .addSize([640, 400], [170,90])
     .addSize([0, 0], [])
     .build();   
   
   
 
   googletag.defineSlot('/53998264/160x600-Primary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-0').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/160x600-Secondary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-1').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Primary', [300, 250], 'div-gpt-ad-1388505177750-2').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Secondary', [300, 250], 'div-gpt-ad-1388505177750-3').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/728x90-Primary', [728, 90], 'ad-slot-leader').defineSizeMapping(mapping728).addService(googletag.pubads()); 
   
   googletag.pubads().setTargeting('SyncFusion','Dev');

   // googletag.pubads().enableLazyLoad();
   googletag.pubads().disableInitialLoad();
   googletag.pubads().collapseEmptyDivs();
   googletag.enableServices();
});


googletag.cmd.push(function(){ 
  apstag.fetchBids({ 
  timeout: 2000 }, 
    function(bids) {
      apstag.setDisplayBids(); 
      googletag.pubads().refresh();
  }); 
}); 

}

</script>
</head>
<body onload="PR.prettyPrint()" style="background-color:white;">
<a name="top"></a>

<div name="container" id="container">
<div class="sticky-no">
<nav class="top-bar" data-topbar role="navigation">
<ul class="title-area">
<li class="name">
<a href="https://www.mssqltips.com/"><img alt="mssqltips logo" src="/images/mslogo_bw_89x45-2.png" width="89" height="45"></a>
</li>

<li class="toggle-topbar menu-icon"><a href="#"><span>Menu</span></a></li>
</ul>
<section class="top-bar-section">

<ul class="right">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'join'});" href="/get-free-sql-server-tips/?ref=JoinHeaderMenu"><span style="color:red;">Join</span></a></li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="#">Beginner</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/1948/sql-server/">What is SQL Server?</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6422/sql-server-concepts/">SQL Server Concepts</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6429/sql-server-download-quick-links/">SQL Server Download Links</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/3700/my-first-sql-server-business-intelligence-project-tutorial/">My First BI Project </a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/2677/sql-server-career-planning/">SQL Server Career Plan</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="#">Tutorials</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedures</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9131/sql-server-index-tutorial-overview/">Indexing</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sql-server-tutorials/">All Tutorials</a></li>
</ul>
</li>
<li class="has-dropdown"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="#">DBA</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/60/database-administration/">Database Administration</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/54/monitoring/">Monitoring</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9194/sql-server-extended-events-tutorial/">Extended Events</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/81/powershell/">PowerShell</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/27/sql-server-agent/">SQL Server Agent</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9268/sql-server-management-studio-overview-ssms/">Management Studio</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/161/backup/">Backup</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/202/restore/">Restore</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/143/availability-groups/">Availability Groups</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="#">T-SQL</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedure Tutorial</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1667/sql-server-join-example/">SQL Server Join Example</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">CROSS APPLY + OUTER APPLY</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1599/cursor-in-sql-server/">Cursor in SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/4054/creating-a-date-dimension-or-calendar-table-in-sql-server/">Calendar Table</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/5993/sql-server-date-and-time-functions-with-examples/">Date and Time Functions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="#">Analytics</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-tip-category/211/power-bi/">Power BI</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-business-intelligence-resources/">Azure Data Factory</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/4200/sql-server-analysis-services-2016-ssas-tutorial/">Analysis Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9073/sql-server-2017-and-python-basics/">Python</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9040/getting-started-with-r-in-sql-server/">R</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="#">Cloud</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/205/amazon-aws/">AWS</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/87/azure/">Azure</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="#">Tools</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6297/melissa-data-quality-solutions-for-ssis/?ps=melissa">Data Quality Tools</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6310/solarwinds-database-performance-analyzer-for-sql-server/?ps=solarwinds-dpa">Database Performance Analyzer</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6367/quest-foglight-for-databases/?ps=quest-foglight">Foglight for SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6845/sql-diagnostic-manager-for-sql-server/?ps=sql-dm">SQL Diagnostic Manager for SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/7159/solarwinds-sentryone-sql-server-performance-tuning/?ps=solarwinds-s1">SolarWinds SQL Sentry</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/7224/dbi-performance-suite-for-db2-and-sql-server/?ps=dbi-software">DBI Web Performance Suite</a></li>
</ul>
</li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'search'});" href="/search/"><span style="color:red;">Search</span></a></li>
</ul>
</section>
</nav>
</div>
<div class="row">
<div class="entry-content large-9 columns" role="content"> <h1>How to get length of Text, NText and Image columns in SQL Server</h1>
<article>
<p>By: <a href="/sqlserverauthor/37/greg-robidoux/" rel="author" title="author profile for Greg Robidoux">Greg Robidoux</a> &nbsp;&nbsp;|&nbsp;&nbsp; Updated: 2022-04-04 &nbsp;&nbsp;|&nbsp;&nbsp; <a href="#comments" title="read and post comments">Comments (2)</a> &nbsp;&nbsp;|&nbsp;&nbsp; Related: <a href="/sql-server-developer-resources/">More</a> > <a href="/sql-server-tip-category/106/data-types/">Data Types</a></p>
<br />
<h5>Problem</h5>
<p>There is sometimes a need to figure out the maximum space that is being used
by a particular column in your database. You would initially think that the
<a href="/sqlservertutorial/9356/sql-len-function/" target="_blank">
LEN()</a> function would allow you to do this, but this function does not work on
Text, NText or Image data types, so how do you figure out the length of a value
in a column that has one of these data types?</p>
<div align="center" class="hide-for-print hide-for-small"> <div id="ad-slot-leader" style="width:728px; height:90px; min-width:728px; min-height:90px;"> <script type='text/javascript'> if (screen.width > 749) { googletag.cmd.push(function() {googletag.display('ad-slot-leader'); }); }	</script> </div></div><h5>Solution</h5>
<p>In addition to the
<a href="/sqlservertutorial/9356/sql-len-function/" target="_blank">
LEN()</a> function, SQL Server also has a
<a href="/sqlservertutorial/9352/sql-datalength-function/" target="_blank">
DATALENGTH()</a> function. This function can be used on all data types in your table.</p>
<p>Here is an example of running these commands on an IMAGE data type using the
<strong>LEN()</strong> function:</p>
<div class="codediv">
<pre>
SELECT name, LEN(packagedata) 
FROM msdb.dbo.sysssispackages
</pre>
</div>
<div class="imageborder">
<img alt="invalid argument error" border="0" height="42" loading="lazy" src="/tipimages/1188_len_error.gif" width="546"></div>
<p>Here is an example of running these commands on an IMAGE data type using the
<strong>DATALENGTH()</strong> function:</p>
<div class="codediv">
<pre>
SELECT name, DATALENGTH(packagedata) 
FROM msdb.dbo.sysssispackages
</pre>
</div>
<div class="imageborder">
<img alt="data length output" border="0" height="91" loading="lazy" src="/tipimages/1188_datalength_1.gif" width="429"></div>
<p>If you wanted to find out the maximum length used for all of your records you
could issue a command such as the following:</p>
<div class="codediv">
<pre>
SELECT TOP 1 name, DATALENGTH(packagedata) 
FROM msdb.dbo.sysssispackages
ORDER BY 2 DESC
</pre>
</div>
<div class="imageborder">
<img alt="data length output " border="0" height="41" loading="lazy" src="/tipimages/1188_datalength_2.gif" width="310"></div>
<p>That's all there is to it. Another little function that you probably won't
use often, but this is helpful to know it is there when you do need to use it.</p>
<h5>Next Steps</h5>
<ul>
<li>Add this command to your SQL Server T-SQL toolbox </li>
<li>Take a look at these other useful T-SQL functions
<ul>
<li>
<a href="/sqlservertip/1026/sql-server-text-data-manipulation/" target="_blank">
SQL Server Text Data Manipulation</a> </li>
<li>
<a href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/" target="_blank">
Date/Time Conversions Using SQL Server</a> </li>
<li>
<a href="/sqlservertip/1038/retrieving-sql-server-index-properties-with-indexproperty/" target="_blank">
Retrieving SQL Server Index Properties with INDEXPROPERTY</a> </li>
<li>
<a href="/sqlservertip/1033/retrieving-sql-server-database-properties-with-databasepropertyex/" target="_blank">
Retrieving SQL Server Database Properties with DATABASEPROPERTYEX</a></li>
</ul>
</li>
</ul>
<br /><br />
<div class="row">
<div class="large-6 medium-6 small-12 columns">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Related Articles</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '2111'});" href="/sqlservertip/2111/decimal-conversions-in-sql-server-change-datatype-format/">Decimal Conversions in SQL Server Change Datatype Format</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '2242'});" href="/sqlservertip/2242/row-sizes-exceeding-8060-bytes-in-sql-2005/">Row sizes exceeding 8060 bytes in Sql 2005</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '2548'});" href="/sqlservertip/2548/using-bit-columns-with-nulls-when-three-options-exist-in-sql-server/">Using bit columns with NULLs when three options exist in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '2749'});" href="/sqlservertip/2749/sql-server-data-type-precedence/">SQL Server Data Type Precedence</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '2944'});" href="/sqlservertip/2944/comparing-sql-server-and-oracle-datatypes/">Comparing SQL Server and Oracle datatypes</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '2983'});" href="/sqlservertip/2983/security-for-sql-server-user-defined-data-types/">Security for SQL Server User Defined Data Types</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '3323'});" href="/sqlservertip/3323/comparing-sql-server-datatypes-size-and-performance-for-storing-numbers/">Comparing SQL Server Datatypes, Size and Performance for Storing Numbers</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '3372'});" href="/sqlservertip/3372/precision-and-scale-impact-for-sql-server-data-types/">Precision and Scale Impact for SQL Server Data Types</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '4008'});" href="/sqlservertip/4008/handling-error-converting-data-type-varchar-to-numeric-in-sql-server/">Handling error converting data type varchar to numeric in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '4137'});" href="/sqlservertip/4137/sql-server-performance-test-for-bit-data-type-in-a-where-clause/">SQL Server Performance Test for Bit Data Type in a WHERE Clause</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '4322'});" href="/sqlservertip/4322/sql-server-differences-of-char-nchar-varchar-and-nvarchar-data-types/">SQL Server differences of char, nchar, varchar and nvarchar data types</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '4485'});" href="/sqlservertip/4485/comparison-of-the-varcharmax-and-varcharn-sql-server-data-types/">Comparison of the VARCHAR(max) and VARCHAR(n) SQL Server Data Types </a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '4535'});" href="/sqlservertip/4535/overview-of-sql-server-sqlvariant-data-type/">Overview of SQL Server sql_variant Data Type</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '6447'});" href="/sqlservertip/6447/sql-server-bit-data-type/">SQL Server Bit Data Type</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '6575'});" href="/sqlservertip/6575/sql-server-data-types/">SQL Server Data Types Quick Reference Guide</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Related', 'event_label': '6989'});" href="/sqlservertip/6989/sql-server-data-types-handling-errors/">Always use the right case for data type names in SQL Server</a><br><br>
</div>
</div>
<div class="large-6 medium-6 small-12 columns">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Popular Articles</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '1145'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions Using SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '2655'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates with FORMAT Function</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '1958'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">SQL Server CROSS APPLY and OUTER APPLY</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '1599'});" href="/sqlservertip/1599/cursor-in-sql-server/">SQL Server Cursor Example</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '6769'});" href="/sqlservertip/6769/sql-server-drop-table-if-exists/">SQL Server DROP TABLE IF EXISTS Examples</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '2914'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows into a single row and column for SQL Server data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '6904'});" href="/sqlservertip/6904/sql-not-in-operator/">SQL NOT IN Operator</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '1140'});" href="/sqlservertip/1140/how-to-tell-what-sql-server-version-you-are-running/">How to tell what SQL Server versions you are running</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '2509'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates using DATEADD in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '6452'});" href="/sqlservertip/6452/sql-convert-date-to-yyyymmdd/">SQL Convert Date to YYYYMMDD</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '6148'});" href="/sqlservertip/6148/sql-server-loop-through-table-rows-without-cursor/">SQL Server Loop through Table Rows without Cursor</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '2340'});" href="/sqlservertip/2340/resolving-could-not-open-a-connection-to-sql-server-errors/">Resolving could not open a connection to SQL Server errors</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '6817'});" href="/sqlservertip/6817/sql-current-date/">How to Get Current Date in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '1704'});" href="/sqlservertip/1704/using-merge-in-sql-server-to-insert-update-and-delete-at-the-same-time/">Using MERGE in SQL Server to insert, update and delete at the same time</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '2537'});" href="/sqlservertip/2537/sql-server-row-count-for-all-tables-in-a-database/">SQL Server Row Count for all Tables in a Database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '2985'});" href="/sqlservertip/2985/concatenate-sql-server-columns-into-a-string-with-concat/">Concatenate SQL Server Columns into a String with CONCAT()</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '2779'});" href="/sqlservertip/2779/ways-to-compare-and-find-differences-for-sql-server-tables-and-data/">Ways to compare and find differences for SQL Server tables and data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '1522'});" href="/sqlservertip/1522/searching-and-finding-a-string-value-in-all-columns-in-a-sql-server-table/">Searching and finding a string value in all columns in a SQL Server table</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '5460'});" href="/sqlservertip/5460/sql-server-database-stuck-in-restoring-state/">SQL Server Database Stuck in Restoring State</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '1188', {'event_category': 'Popular', 'event_label': '1160'});" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL commands in SQL Server</a><br><br>
</div>
</div>
</div>
<br /><br /><br />
<div class="row">
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="gtag('event', 'click', {'event_category': 'Scripts', 'event_label': 'BotTip'});" target="_blank"><img loading="lazy" border="0" src="/images/Free-Download_20190509.png" alt="get scripts" width="300" height="150"></a></div>
<br />
</div>
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/sql-server-tip-category/106/data-types/" onclick="gtag('event', 'click', {'event_category': 'NextTip', 'event_label': 'YellowArrow'});"><img loading="lazy" border="0" src="/images/nav_nexttip_clickhere_rev1.png" alt="next tip button" width="300" height="150"></a></div>
<br />
</div>
</div>
<br /><br />
<h5>About the author</h5>
<div class="row">
<div class="large-12 columns">
<a href="/sqlserverauthor/37/greg-robidoux/"><img loading="lazy" style="float: left; padding: 0px 10px 0px 0px;" alt="MSSQLTips author Greg Robidoux" height="150" src="/images/Greg-Robidoux-2020-2-100x150.jpg" width="100" /></a>
Greg Robidoux is the President of Edgewood Solutions and a co-founder of MSSQLTips.com.
<br /><br /><b><a href="/sqlserverauthor/37/greg-robidoux/">View all my tips</a></b>
</div>
</div>
<br /><br />
Article Last Updated: 2022-04-04
<a name="comments"></a>
</article>
<div class="row">
</div>
<div class="hide-for-print">
<hr>
<h2>Comments For This Article</h2>
<button class="button round" data-reveal-id="myModal" data-reveal-ajax="/zurb_comments.asp?id=1x1188">Add Comment</button>
<div id="myModal" class="reveal-modal" data-reveal aria-labelledby="modalTitle" aria-hidden="true" role="dialog">
</div>
<style type="text/css">
.ForumPostBodyArea
{
	width: 100%;
	vertical-align: top;
	overflow: auto;
}
</style>
<br /><br /><br />
<table border="0" width="100%" cellspacing="0" cellpadding="4" style="border: 1px solid #CBDCED; table-layout: fixed;">
<tr>
<td width="80%" bgcolor="#E8F3FF">
<b>Wednesday, December 26, 2012 - 2:24:33 PM - Rodney</b>
</td>
<td style="text-align: right;" bgcolor="#E8F3FF">
<a title="read the tip" href="#top">Back To Top</a> <small>(21139)</small>
</td>
</tr>
<tr>
<td colspan="2" class="ForumPostBodyArea">
<p>It is important to note that DATALENGTH returns the number of BYTES used to store the string INCLUDING any ending whitespace, while the LEN function returns the number of CHARACTERS in a string EXCLUDING any ending whitespace.</p>
<p>For example, if you insert the value 'TEST' into an NVARCHAR field, the LEN function returns 4 while the DATALENGTH function returns 8 (each character in an NVARCHAR field requires two bytes of storage). &nbsp;If you instead inserted the value 'TEST &nbsp; ' (with three spaces at the end of the string) the LEN function would still return 4 while the DATALENGTH function returns 14 (8 bytes for TEST plus 6 bytes for the three trailing spaces). &nbsp;Granted you still can't use the LEN function on large data types, but you should keep this difference in mind if you are planning to use the value in any string manipulations or character space calculations.</p>
</td>
</tr>
</table>
<br>
<table border="0" width="100%" cellspacing="0" cellpadding="4" style="border: 1px solid #CBDCED; table-layout: fixed;">
<tr>
<td width="80%" bgcolor="#E8F3FF">
<b>Friday, June 29, 2012 - 1:09:05 PM - John</b>
</td>
<td style="text-align: right;" bgcolor="#E8F3FF">
<a title="read the tip" href="#top">Back To Top</a> <small>(18269)</small>
</td>
</tr>
<tr>
<td colspan="2" class="ForumPostBodyArea">
Greg,
Nice tip. Helped me out :-)
John
</td>
</tr>
</table>
<br>
</div>
</div>
<style>
			div.stickyright {
			  position: -webkit-sticky;
			  position: sticky;
			  padding: 0;
			  background-color: white;
			  width: 300px;
			  z-index: 1;
			}
	</style>
<div class="large-3 hide-for-print columns rightsize">
<br />
<div align="center" class="hide-for-print"><a href="/sql-server-whitepaper/174/sql-server-performance-tuning-checklist/" onclick="gtag('event', 'click', {'event_category': 'download-button', 'event_label': 'scripts'});" target="_blank"><img loading="lazy" src="/images/download-perf-checklist.png" alt="download" width="273" height="93"></a></div>
<br /><br />

<div align="center">
<div id='div-gpt-ad-1388505177750-0' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-0'); });
	}	
	</script>
</div>
</div><br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-3' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-3'); });
	}	
	</script>
</div>
</div> <br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-1' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-1'); });
	}
	</script>
</div>
</div> <br /><br /><br />
<div class="stickyright" style="top:55px;">

<div align="center">
<div id='div-gpt-ad-1388505177750-2' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{	
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-2'); });
	}	
	</script>
</div>
</div> <br /><br /><br /> <script language="Javascript">
	function ValidateEmail(inputText)
	{
	
		if (document.optin.consent.checked == false) {
		     alert("Please agree to terms by ticking check box.");
		     return false;
	            }	
	   
		var mailformat = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
		if(inputText.value.match(mailformat))
		{
			document.optin.ea.focus();
			return true;
		}
		else
		{
			alert("You have entered an invalid email address!");
			document.optin.ea.focus();
			return false;
		}
	}

	</script>
<div id="sticky2">
<div id="search-div" style="height:300px; width:300px">
<div id="signup-div">
<div style="text-align: center;"><a href="/get-free-sql-server-tips/?ref=LeftGFSTSlant"><img loading="lazy" alt="get free sql tips" border="0" src="/images/GetFreeSQLTips_black_box.png" width="300" height="150"></a></div>
<form action="/get-free-sql-server-tips/" method="post" name="optin" onsubmit="return ValidateEmail(document.optin.ea)">
<input name="URL" type="hidden" value="leftform" />
<input name="ReferralURL" type="hidden" value="" />
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-10 columns">
<input size="25" type="text" onblur="if (this.value=='') this.value=this.defaultValue" onclick="if (this.defaultValue==this.value) this.value=''" value="enter business email" name="ea">
</div>
<div class="small-2 columns">
<input type="submit" name="Button1" value="Join" />
</div>
</div>
</div>
</div>
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-1 columns">
<input type="checkbox" name="consent" value="1">
</div>
<div class="small-11 columns">
<a href="/privacy/" target="_blank"><img loading="lazy" src="/images/mssqltips-agree-terms.png" alt="agree to terms" width="276" height="67"></a>
</div>
</div>
</div>
</div>
<br /><br />
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<footer class="row hide-for-print">
<hr />
<ul class="small-block-grid-2 medium-block-grid-3 large-block-grid-6" style="margin:10px;">
<li>
<h3><span style="color:#3B6D93">Follow</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=GetFooterMenu">Get Free SQL Tips</a></li>
<li><a rel="noopener" href="https://twitter.com/mssqltips" target="_blank">Twitter</a></li>
<li><a rel="noopener" href="https://www.linkedin.com/groups/2320891/" target="_blank">LinkedIn</a></li>
<li><a rel="noopener" href="https://www.facebook.com/mssqltips/" target="_blank">Facebook</a></li>
<li><a rel="noopener" href="https://www.pinterest.com/mssqltips/" target="_blank">Pinterest</a></li>
<li><a rel="noopener" href="https://feeds.feedburner.com/MSSQLTips-LatestSqlServerTips" target="_blank">RSS</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Learning</span></h3>
<ul>
<li><a href="/sql-server-dba-resources/">DBAs</a></li>
<li><a href="/sql-server-developer-resources/">Developers</a></li>
<li><a href="/sql-server-business-intelligence-resources/">BI Professionals</a></li>
<li><a href="/sql-server-professional-development-resources/">Careers</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Resources</span></h3>
<ul>
<li><a href="/sql-server-tutorials/">Tutorials</a></li>
<li><a href="/sql-server-webcasts/">Webcasts</a></li>
<li><a href="/sql-server-whitepapers/">Whitepapers</a></li>
<li><a href="/sql-server-tools/">Tools</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Search</span></h3>
<ul>
<li><a href="/sql-server-categories/">Tip Categories</a></li>
<li><a href="/search-tip-id/">Search By TipID</a></li>
<li><a href="/sql-server-mssqltips-authors/">Authors</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Community</span></h3>
<ul>
<li><a href="/learn-more-about-mssqltips/">First Timer?</a></li>
<li><a href="/mssqltips-community/1/">Pictures</a></li>
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/sql-server-event-list/">Event Calendar</a></li>
<li><a href="/sql-server-user-groups/">User Groups</a></li>
<li><a href="/mssqltips-author-of-year/">Author of the Year</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">More Info</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=JoinFooterMenu">Join</a></li>
<li><a href="/about/">About</a></li>
<li><a href="/copyright/">Copyright</a></li>
<li><a href="/privacy/">Privacy</a></li>
<li><a href="/disclaimer/">Disclaimer</a></li>
<li><a href="/feedback/">Feedback</a></li>
<li><a href="/advertise/">Advertise</a></li>
</ul>
</li>
</ul>
<hr />
<div class="row">
<div class="large-12 columns text-center">
<p>Copyright (c) 2006-2022 <a href="https://www.edgewoodsolutions.com">Edgewood Solutions, LLC</a> All rights reserved<br />
<small>Some names and products listed are the registered trademarks of their respective owners.</small></p>
</div>
</div>
</footer>

<style type="text/css">
#slideboxtop{
    width:100%;
    height:50px;
    padding:0px;
    background-color:#FFFFFF;      
    border-bottom:1px solid #000000;
    position:fixed;
    top: -350px;
	-moz-box-shadow:-2px 0px 5px #aaa;
	-webkit-box-shadow:-2px 0px 5px #aaa;
/* 	box-shadow:-2px 0px 5px #aaa;    */
}
</style>
<div class="hide-for-small hide-for-medium hide-for-print">
<div id="slideboxtop" style="z-index:1;">
<div style="text-align:center">
<div w3-include-html="/Site-Sponsorship/site-sponsorship.asp"></div>
</div>
</div>
</div>
<script src="/js/jquery-foundation-combined-min.js"></script>
<script type="text/javascript">
var articleLength = $("article").find("p").length;

 

</script>
<script>
    $(document).foundation();
</script>
<script type="text/javascript" src="/css/prettify.combined.js" defer></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function(){
		if  ($(window).scrollTop() > 250)
			$('#slideboxtop').animate({'top':'0px'});
		else
			$('#slideboxtop').stop(true).animate({'top':'-250px'});
	});
});
</script>
<script>
function includeHTML() {
  var z, i, elmnt, file, xhttp;
  /*loop through a collection of all HTML elements:*/
  
  z = document.getElementsByTagName("*");
  for (i = 0; i < z.length; i++) {
    elmnt = z[i];
    /*search for elements with a certain atrribute:*/
    file = elmnt.getAttribute("w3-include-html");
	if (file) {
      /*make an HTTP request using the attribute value as the file name:*/
      xhttp = new XMLHttpRequest();
      xhttp.onreadystatechange = function() {
        if (this.readyState == 4) {
          if (this.status == 200) {elmnt.innerHTML = this.responseText;}
          if (this.status == 404) {elmnt.innerHTML = "Page not found.";}
          /*remove the attribute, and call this function once more:*/
          elmnt.removeAttribute("w3-include-html");
          includeHTML();
        }
      }   
      xhttp.open("GET", file, true);
      xhttp.send();
      /*exit the function:*/
      return;
    }
  }
};
</script>
<script>
 if ($(window).width() > 1000) {
	includeHTML();
	$("div.rightsize").height($("#container").height());
    }	
</script>

<script> 
//<![CDATA[ 
if (screen.width > 0)
{
function deferGoogleJS() { 
var d = document.createElement("script"); 
d.src = "https://www.googletagmanager.com/gtag/js?id=UA-910745-2", 
document.body.appendChild(d) 
} 
window.addEventListener ? window.addEventListener("load", deferGoogleJS, !1) : window.attachEvent ? window.attachEvent("onload", deferGoogleJS) : window.onload = deferGoogleJS; 
window.dataLayer = window.dataLayer || [];

function gtag() { 
dataLayer.push(arguments); 
} 
gtag('js', new Date()); 
gtag('config', 'UA-910745-2'); 
}
//]]> 
</script>
</body>
</html>
