
<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta http-equiv="Content-Language" content="en-us" />
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

<link rel="SHORTCUT ICON" href="/favicon.ico" />
<meta content="width=device-width, initial-scale=1.0" name="viewport" />
<title>Create, Populate, and Subset a Pandas Dataframe from a CSV File</title>
<meta name="description" content="Learn how to transfer data via a CSV file from a SQL Server database to a Pandas dataframe and then subset the dataframe in Python." />
<link rel="canonical" href="https://www.mssqltips.com/sqlservertip/6938/create-populate-subset-pandas-dataframe-csv/" />
<link rel="stylesheet" href="/css/foundation-app-combined-min.css">
<script>/*! loadCSS. [c]2017 Filament Group, Inc. MIT License */!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mssqltips.com/sqlservertip/6938/create-populate-subset-pandas-dataframe-csv/"
  },
  "headline": "Create, Populate, and Subset a Pandas Dataframe from a CSV File",
  "image": [
  
    "https://www.mssqltips.com/images_newsletter/6938_NewsletterImage.png"
  
   ],  
  "datePublished": "2021-08-16T00:00:00+05:00",
  "dateModified": "2021-08-16T00:00:00+05:00",
  "author": {
    "@type": "Person",
    "name": "Rick Dobson"
  },
   "publisher": {
    "@type": "Organization",
    "name": "MSSQLTips",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.mssqltips.com/images/mslogo_113x60.png"
    }
  },
  "description": "Learn how to transfer data via a CSV file from a SQL Server database to a Pandas dataframe and then subset the dataframe in Python."
}
</script>
<meta property="og:url" content="https://www.mssqltips.com/sqlservertip/6938/create-populate-subset-pandas-dataframe-csv/" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Create, Populate, and Subset a Pandas Dataframe from a CSV File" />
<meta property="og:description" content="Learn how to transfer data via a CSV file from a SQL Server database to a Pandas dataframe and then subset the dataframe in Python." />
<meta property="og:image" content="https://www.mssqltips.com/images_newsletter/6938_NewsletterImage.png" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mssqltips">
<meta name="twitter:creator" content="@mssqltips">
<meta name="twitter:title" content="Create, Populate, and Subset a Pandas Dataframe from a CSV File">
<meta name="twitter:description" content="Learn how to transfer data via a CSV file from a SQL Server database to a Pandas dataframe and then subset the dataframe in Python.">
<meta name="twitter:image" content="https://www.mssqltips.com/images_newsletter/6938_NewsletterImage.png">
<script>

var head = document.getElementsByTagName('head')[0];
var js = document.createElement("script");

js.type = "text/javascript";

if (screen.width > 749)
{
    js.src = "https://securepubads.g.doubleclick.net/tag/js/gpt.js";
}
head.appendChild(js);

if (screen.width > 749)
{

!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

apstag.init({
  pubID: '434bb5e4-3704-4b75-b36c-785a444462bd',
  adServer: 'googletag',
  simplerGPT: true,
  schain: {
    complete: 1,
    ver: '1.0',
    nodes: [
      {
        asi: 'theadengine.com',
        sid: '01307',
        hp: 1,
      },
    ],
  },
});

window.googletag = window.googletag || {cmd: []};

googletag.cmd.push(function() {

   var mapping = googletag.sizeMapping().
   addSize([100, 100], []).
   addSize([320, 400], []).
   addSize([320, 700], []).
   addSize([750, 200],  [[728, 90],[300,250],[160,300],[300,600],[170,90]]).
   addSize([1050, 200], [[728, 90],[300,250],[160,300],[300,600],[170,90]]).build();

   var mapping728 = googletag.sizeMapping()
     .addSize([750, 200], [728, 90])
     .addSize([0, 0], [])
     .build();
   var mapping300 = googletag.sizeMapping()
     .addSize([640, 400], [300, 250])
     .addSize([0, 0], [])
     .build();
   var mapping600 = googletag.sizeMapping()
     .addSize([640, 600], [[160,600],[300,600]])
     .addSize([0, 0], [])
     .build();
   var mapping170 = googletag.sizeMapping()
     .addSize([640, 400], [170,90])
     .addSize([0, 0], [])
     .build();   
   
   
 
   googletag.defineSlot('/53998264/160x600-Primary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-0').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/160x600-Secondary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-1').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Primary', [300, 250], 'div-gpt-ad-1388505177750-2').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Secondary', [300, 250], 'div-gpt-ad-1388505177750-3').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/728x90-Primary', [728, 90], 'ad-slot-leader').defineSizeMapping(mapping728).addService(googletag.pubads()); 
   
   googletag.pubads().setTargeting('SyncFusion','DBA');

   // googletag.pubads().enableLazyLoad();
   googletag.pubads().disableInitialLoad();
   googletag.pubads().collapseEmptyDivs();
   googletag.enableServices();
});


googletag.cmd.push(function(){ 
  apstag.fetchBids({ 
  timeout: 2000 }, 
    function(bids) {
      apstag.setDisplayBids(); 
      googletag.pubads().refresh();
  }); 
}); 

}

</script>
</head>
<body onload="PR.prettyPrint()" style="background-color:white;">
<a name="top"></a>

<div name="container" id="container">
<div class="sticky-no">
<nav class="top-bar" data-topbar role="navigation">
<ul class="title-area">
<li class="name">
<a href="https://www.mssqltips.com/"><img alt="mssqltips logo" src="/images/mslogo_bw_89x45-2.png" width="89" height="45"></a>
</li>

<li class="toggle-topbar menu-icon"><a href="#"><span>Menu</span></a></li>
</ul>
<section class="top-bar-section">

<ul class="right">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'join'});" href="/get-free-sql-server-tips/?ref=JoinHeaderMenu"><span style="color:red;">Join</span></a></li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="#">Beginner</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/1948/sql-server/">What is SQL Server?</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6422/sql-server-concepts/">SQL Server Concepts</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6429/sql-server-download-quick-links/">SQL Server Download Links</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/3700/my-first-sql-server-business-intelligence-project-tutorial/">My First BI Project </a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/2677/sql-server-career-planning/">SQL Server Career Plan</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="#">Tutorials</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedures</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9131/sql-server-index-tutorial-overview/">Indexing</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sql-server-tutorials/">All Tutorials</a></li>
</ul>
</li>
<li class="has-dropdown"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="#">DBA</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/60/database-administration/">Database Administration</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/54/monitoring/">Monitoring</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9194/sql-server-extended-events-tutorial/">Extended Events</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/81/powershell/">PowerShell</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/27/sql-server-agent/">SQL Server Agent</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9268/sql-server-management-studio-overview-ssms/">Management Studio</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/161/backup/">Backup</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/202/restore/">Restore</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/143/availability-groups/">Availability Groups</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="#">T-SQL</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedure Tutorial</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1667/sql-server-join-example/">SQL Server Join Example</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">CROSS APPLY + OUTER APPLY</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1599/cursor-in-sql-server/">Cursor in SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/4054/creating-a-date-dimension-or-calendar-table-in-sql-server/">Calendar Table</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/5993/sql-server-date-and-time-functions-with-examples/">Date and Time Functions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="#">Analytics</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-tip-category/211/power-bi/">Power BI</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-business-intelligence-resources/">Azure Data Factory</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/4200/sql-server-analysis-services-2016-ssas-tutorial/">Analysis Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9073/sql-server-2017-and-python-basics/">Python</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9040/getting-started-with-r-in-sql-server/">R</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="#">Cloud</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/205/amazon-aws/">AWS</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/87/azure/">Azure</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="#">Tools</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6297/melissa-data-quality-solutions-for-ssis/?ps=melissa">Data Quality Tools</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6310/solarwinds-database-performance-analyzer-for-sql-server/?ps=solarwinds-dpa">Database Performance Analyzer</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6367/quest-foglight-for-databases/?ps=quest-foglight">Foglight for SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6845/sql-diagnostic-manager-for-sql-server/?ps=sql-dm">SQL Diagnostic Manager for SQL Server</a></li>
</ul>
</li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'search'});" href="/search/"><span style="color:red;">Search</span></a></li>
</ul>
</section>
</nav>
</div>
<div class="row">
<div class="entry-content large-9 columns" role="content"> <h1>Create, Populate, and Subset a Pandas Dataframe from a CSV File</h1>
<div align="center" class="hide-for-print hide-for-small">
<div id="ad-slot-leader" style="width:728px; height:90px; min-width:728px; min-height:90px;">
<script type='text/javascript'>
		   	if (screen.width > 749)
			{	
				googletag.cmd.push(function() {googletag.display('ad-slot-leader'); });
			}	
		   </script>
</div>
</div>
<br />
<article>
<p>By: <a href="/sqlserverauthor/57/rick-dobson/" rel="author" title="author profile for Rick Dobson">Rick Dobson</a> &nbsp;&nbsp;|&nbsp;&nbsp; Updated: 2021-08-16 &nbsp;&nbsp;|&nbsp;&nbsp; <a href="#comments" title="read and post comments">Comments</a> &nbsp;&nbsp;|&nbsp;&nbsp; Related: <a href="/sql-server-dba-resources/">More</a> > <a href="/sql-server-tip-category/162/other-database-platforms/">Other Database Platforms</a></p>
<br />
<h5>Problem</h5>
<p>Demonstrate how to transfer data via a .csv file from a SQL Server database to
a Pandas dataframe and then subset the dataframe in Python.</p>
<h5>Solution</h5>
<p>A Pandas dataframe is an in-memory data store that can be manipulated with the
Python programming language. The Python programming language is popular with
many developers because of its easy programming style and its applicability to a
wide variety of use cases. Python is particularly popular among professionals
charged with mining a dataset, implementing data science projects, or building web-based
HTML solutions.</p>
<p>After creating and populating a Pandas dataframe from a more durable data store,
such as a SQL Server table or a results set created by a T-SQL statement, you can
readily perform many classic data science applications with Python. Examples
include data visualization, modeling, clustering, machine learning, and statistical
analyses. When implementing one of these use cases, there is sometimes a need
to reconfigure the design of a Pandas dataframe as well as subset the data in it;
this tutorial illustrates approaches for achieving these goals.</p>
<p>After reading this tutorial, you will be equipped to create, populate, and subset
a Pandas dataframe from a dataset that comes from SQL Server. Selected specific
topics covered include:</p>
<ul>
<li>Exporting a .csv file for a results set based on a T-SQL query statement.
</li>
<li>Importing a .csv file into a Pandas dataframe. This dataframe serves
as a vehicle for acquainting you with dataframe design Issues. For example,
the tutorial illustrates how to add a new index and drop a column that is no longer
needed.</li>
<li>Demonstrating how to subset the contents of a dataframe by displaying
<ul>
<li>A subset of the dataframe columns or</li>
<li>A subset of the dataframe rows</li>
</ul>
</li>
</ul>
<h2>Learning about dataframes by creating and populating them</h2>
<p>To run the code samples demonstrated in this tutorial, you will need Python and the
Pandas library installed on a computer workstation. The Python programming
application and the Pandas library are available without charge.</p>
<p>You can download Python from this
<a href="https://www.python.org/downloads/windows/" target="_blank">
link</a>. Installation
guidance for the Pandas library is available from this
<a href="https://pandas.pydata.org/pandas-docs/stable/getting_started/install.html" target="_blank">
link</a>. All the Python
and Pandas custom code demonstrated in this tip is available in the download for
this tip.</p>
<p>You can use whatever developer tool you wish for examining and modifying the
Python script files referenced in this tutorial. However, this tutorial demonstrates
the use of IDLE functionality, an integrated developer environment, for reading and editing, and
running Python code. IDLE downloads automatically with the installation of
Python from the Python.org website.</p>
<h4>Exporting a .csv file for a SQL Server results set</h4>
<p>The following screen shot shows a SQL Server Management Studio (SSMS) session
containing a simple query and an excerpt from its results set. The full results
set contains close prices and exponential moving averages for the close prices based
on seven different period lengths (ema_3 through ema_200) for six ticker symbols
(SDOW, UDOW, TQQQ, SPXL, SQQQ, SPXS). By right-clicking the rectangle to the
top left of the results set and just below the Results tab, you can save the contents
of the results set to a .csv file in a destination of your choice. For this
demonstration, the results set was saved in a file named ema_values_for_period_length_by_symbol_and_date.csv
within the DataScienceSamples directory of the C drive.</p>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_1" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.001.png" height="661" width="803" />
</div>
<h4>Reading a .csv file into a Pandas dataframe</h4>
<p>The following screen shot is a listing from the read_csv.py file that shows how
to read the .csv file created in the preceding subsection into a Pandas dataframe.
The screen shot also illustrates two different ways to display the contents of the
dataframe.</p>
<ul>
<li>The main section of each approach to displaying the contents of a dataframe
resides within block comment markers (&ldquo;&rdquo;&rdquo;&hellip;&rdquo;&rdquo;&rdquo;).
</li>
<li>At the top of the code window is an import statement which references the
Pandas library; both approaches for displaying dataframe contents require the
import statement.</li>
<li>The import statement at the top of the code window assigns an alias name
of pd to the Pandas library.</li>
<li>You can run either (or both) of the Python scripts by putting a single line
comment marker (#) before both the leading and trailing block comment markers
of each script. For example, the leading and trailing block comment marker
would change from &ldquo;&rdquo;&rdquo; to #&rdquo;&rdquo;&rdquo; for either
(or both) of the approaches that you want to run.</li>
<li>The core statements from either script shows how to invoke the read_csv
function and a print function.
<ul>
<li>The read_csv function reads the ema_values_for_period_length_by_symbol_and_date.csv
file created and saved from SSMS. The contents of the file are saved
in a Pandas dataframe object named df.</li>
<li>The Python print function displays in the Python Shell window the contents
of the df function according to default Python set_options settings.
</li>
<li>Unless you explicitly change the default settings, this results in the
display of the first and last five rows along with a subset of the beginning
and ending dataframe columns. The display does not by default show
all the rows and columns from df. </li>
<li>The second script includes two lines that can cause a print statement
to display all columns within all rows from a dataframe
<ul>
<li>Setting the pd.options.display.width parameter equal to 0
can cause Python to print all characters from each row of your source
dataframe.</li>
<li>Also, assigning df.shape[0] to the display.max.rows parameter of
set_options causes all rows to display.</li>
</ul>
</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_2" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.002.png" height="719" width="676" />
</div>
<p>The top Python script in the preceding screen shot generates the following output
in the Python Shell window.</p>
<ul>
<li>The first row shows NaN values instead of NULL values in the first row for
ema_30, ema_50, and ema_200. The read_csv function automatically translates
NULL values into NaN values. This conforms to Python conventions for denoting
missing numeric values.</li>
<li>Highlighting has been added to emphasize the native RangeIndex value identifiers
for distinct dataframe rows. These values, which appear at the left edge
of the dataframe, commence at 0 and extend through one less than the count of
dataframe rows (5147 in this example).</li>
<li>The full set of dataframe column names and their data types appear below
the print function output for the dataframe.
<ul>
<li>The first column name is date, and the last column name is ema_200.
</li>
<li>As you can see, the default excerpt for displaying the dataframe excludes
columns named ema_3, ema_8, ema_10, and ema_20.</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_3" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.003.png" height="646" width="703" />
</div>
<p>The next two screen shots show excerpts from the output from the second commented
script block in the read_csv.py file listing. </p>
<p>The first screen shot is for the top ten dataframe rows.</p>
<ul>
<li>The values 0 through 9 are RangeIndex values for the first set of ten rows.
These RangeIndex values are not in the .csv file, but they are added by the
read_csv function to track the rows in a dataframe.</li>
<li>All ten columns appear in the output from the column named date through
the column named ema_200. This outcome is because of the pd.options.display.width
= 0 statement. Recall that the output from the first script omitted columns
ema_3, ema_8, ema_10, and ema_20.</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_4" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.004.png" height="326" width="900" />
</div>
<p>The second screen shot is for the bottom four dataframe rows and the column metadata
for the dataframe.</p>
<ul>
<li>The output confirms again that the RangeIndex values extend through 5147.
<ul>
<li>Recall that 5147 is the count of dataframe rows less one.</li>
<li>Also, this is the same final RangeIndex value from the first commented
output script block.</li>
<li>In other words, the excerpted values appearing in the output from the
first commented script block do not affect the actual number of rows transferred
from the .csv file to the dataframe.</li>
</ul>
</li>
<li>The display of column metadata is unaffected by the changes in the second
script block. You can still see the column names and their data types.
<ul>
<li>Python stores string values with an object data type. Although
the date column values have a format that appears to represent a date value,
they are saved as string values because the read_csv function outputs just
numeric and string data types to dataframes.</li>
<li>The data types for close through ema_200 all have a float64 data type.
These columns store floating point numeric values with 64 bits of precision.
</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_5" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.005.png" height="376" width="900" />
</div>
<h2>Configuring a datetime index for a dataframe from a column of date string values
</h2>
<p>As you can tell from the preceding screen shot, the date column in the df dataframe
does not represent datetime values. Instead, date column values are string
objects. Therefore, if you want to perform tasks, such as extract date and/or
time values from a datetime value, you cannot use the built-in Python functions
and properties for working with datetime values. However, you can easily use
these functions and properties after converting the date column values to datetime
values and saving the converted values as the index for the dataframe. This
section shows one way to perform the conversion and indicates its impact on the
dataframe metadata.</p>
<p>Here is a Python script to perform the conversion. There are two major
parts to the script. First, it illustrates how to reconstruct the dataframe
from the .csv file created in the previous section. The initial dataframe
is based on the application of the csv_read function for the .csv file. Next,
three additional Python statements display the dataframe contents as well as reveal
metadata about the dataframe.</p>
<ul>
<li>The first statement after the read_csv function displays the contents of
the df dataframe with default excerpts, such as the first and last five rows.
</li>
<li>The second statement provides typical metadata about the df dataframe, such
as the column names and their data types.</li>
<li>The third statement shows the name for the df dataframe index as well as
some information about the design of the index.</li>
</ul>
<p>The second major portion of the script commences with a single-line comment about
replacing the original index for the dataframe.</p>
<ul>
<li>This section begins by applying the to_datetime Pandas method to the string
values in the date column that is populated from reading the .csv file.
The converted values are assigned to a column named datetime_index.</li>
<li>Next, the set_index method for the df dataframe is invoked to assign the
datetime_index column as the index for the df dataframe.</li>
<li>After performing this operation, the date column in the df dataframe from
the imported .csv file, which is merely a series of string values, is dropped
because it is no longer needed.</li>
<li>The second major portion of the script concludes by printing the values,
displaying typical metadata, and displaying routine information about the index
for the df dataframe.</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_6" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.006.png" height="774" width="700" />
</div>
<p>Here is an excerpt from the output from the preceding Python script. The
excerpt shows the output from the script&rsquo;s first major portion. Highlighting
is added to three areas of the output.</p>
<ul>
<li>The shape of the df dataframe is 5148 rows by 10 columns. These shape
values appear in square brackets (they are highlighted) below the df dataframe.
</li>
<li>The 10 dataframe columns are comprised of two object columns and eight float64
columns. Note especially that the name of the first column is date.
The column names and an index for them are highlighted.</li>
<li>The index name for the dataframe is RangeIndex.
<ul>
<li>Its starting value is 0.</li>
<li>Successive index values start at 0 and increase by 1 from the preceding
index value.</li>
<li>The index values stop at 5148 so they do not include this row number.
</li>
<li>This information is highlighted at the bottom of the following screen
shot.</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_7" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.007.png" height="722" width="778" />
</div>
<p>Here is a screen shot with output from the second major portion of the script.
Recall that the second major portion of the script adds a new index to the df dataframe
based on the datetime converted date column values from the read_csv version of
the df dataframe. Additionally, the second major portion of the script drops
the original date column from the df dataframe after using it to create a datetime
index.</p>
<ul>
<li>The output for this portion of the script has a shape of 5148 rows with
just 9, instead of 10, columns. This is because the original date column
is dropped in the second portion of the script. There is a column of dates
in the df dataframe, but its column header name appears one row below the nine
column names comprising the shape of the df dataframe.</li>
<li>The listing of columns from df.info() does not include the date column &ndash;
again, this is because the original date column is dropped in the second portion
of the script.</li>
<li>The last segment of the output appearing in the second portion of the script
is for the index values of the df dataframe.
<ul>
<li>The name of the index is DatetimeIndex instead of RangeIndex as is the
case for the dataframe&rsquo;s first version. However, the printed
output from the index appears with a name of date, which is because a column
named date served as the original source for generating the source DatetimeIndex
values.</li>
<li>Each of the 5148 index values has a datetime64[ns] type. This
data type can be processed as datetime values in Pandas. Recall that
the source date column values are just string values; they look like dates,
but they are just strings.</li>
<li>The row count (or dataframe length) of index values is 5148 &ndash;
one index value for each row in the dataframe.</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_8" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.008.png" height="750" width="767" />
</div>
<h2>How to subset columns and rows from within a dataframe</h2>
<p>It can often be useful to extract a subset of columns or rows from a dataframe.
This can make it easier to focus on what matters most in a data science project
or to exclude columns with an unacceptably high proportion of missing values.
Some data science models, such as
<a href="https://en.wikipedia.org/wiki/Random_forest" target="_blank">
random forests</a>, call for
using multiple sets of columns and rows and then averaging the results across different
sets of columns from a source dataframe.</p>
<p>Extracting a subset of the rows in a dataframe can also be useful for data analysis
projects. For example, the sample dataset for this tip contains close price
and moving averages with different period lengths for six symbols. If you
build a model to predict prices for one symbol, will it predict prices validly for
another symbol? Are there sets of symbols that exhibit similar price trends
over time? By extracting different sets of rows that match different symbols,
then you can answer questions like those just posed.</p>
<p>No matter the reason, it can often be useful to form a new dataframe based on
a subset of columns and/or rows from a larger source dataframe.</p>
<h4>Compiling a row subset based on boolean values</h4>
<p>The following screen shot shows the Python script for creating a subset of the
rows for the sample dataframe used with this tip. The script file has the
name df_filter_query_demo_1.py. The header for the IDLE window in which the
Python script displays also indicates the file resides in the python_programs directory
of the C drive. The numbered red bullets identify parts of the script.</p>
<ul>
<li>The first bullet references the Pandas library.</li>
<li>The second bullet invokes the read_csv function to import the .csv file
created in the first section of this tip.</li>
<li>The third bullet converts the string values in the date column before setting
the converted column as an index for the df dataframe.
<ul>
<li>When a column is set as an index for the dataframe, then the approach
silently drops the source column from the dataframe.</li>
<li>The syntax for converting the string values in the date column to datetime
values and making the converted values dataframe index values is slightly
more compact than in the preceding section. Just as with T-SQL, Python
offers multiple approaches to achieving some tasks.</li>
<li>Also, you should keep in mind that an index for a pandas dataframe has
different performance implications than does an index for a table in SQL
Server. A comparison of Python versus SQL Server indexes is beyond
the scope of this tip.</li>
</ul>
</li>
<li>The fourth bullet displays an excerpt from the dataframe created with the
preceding steps. The excerpt is based on default set_options parameter
settings for displaying a dataframe.</li>
<li>Dataframe row filtering begins with the fifth bullet.
<ul>
<li>The code associated with this bullet creates a new dataframe named df_is_sdow
with two columns.</li>
<li>The first column contains datetime index values from the df dataframe.
</li>
<li>The second column contains boolean values of True or False.
<ul>
<li>A boolean column value is True when its symbol value is SDOW.
</li>
<li>Otherwise, the boolean value for an index is False. In other
words, a symbol value that is different than SDOW in the df dataframe
corresponds to a value of False in the boolean column of the df_is_sdow
dataframe.</li>
</ul>
</li>
</ul>
</li>
<li>The sixth bullet prints out the rows from the df_is_sdow dataframe.</li>
<li>The seventh bullet prints out the counts for rows with True or False values.
</li>
<li>The syntax for the eighth bullet embeds the df_is_sdow dataframe name in
a square selection bracket set ([]) for the df dataframe. The syntax for
this expression returns just rows from the df dataframe that correspond to a
boolean value of True in the matching row from the df_is_sdow dataframe.
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_9" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.009.png" height="681" width="750" />
</div>
<p>Here is an excerpt of a screen shot of the output from running the preceding
script. The excerpt is from the Python shell window. Especially
significant blocks of output have numbers in square boxes to the right of output.
These numbers correspond to the bullet numbers in the preceding script.</p>
<ul>
<li>The first significant block of output corresponds to the print function
from the fourth bullet in the preceding script.
<ul>
<li>It uses the default print settings to display the first and last five
rows. Also, you can see the first three columns and the last three
columns.</li>
<li>The datetime index values with a name of date appear to the left of
the first column (symbol)</li>
<li>The shape of the df dataframe appears in square brackets below the df
dataframe excerpt. The df dataframe has 5148 rows and 9 columns.
</li>
</ul>
</li>
<li>The second major block of output corresponds to the sixth bullet in the
preceding script. This output is for df_is_sdow.
<ul>
<li>The df_is_sdow dataframe contains filtered values represented by Boolean
values of True and False.</li>
<li>The filter is based on the symbol value from the df dataframe.</li>
<li>The boolean value is from</li>
<li>The filter is based on the symbol value from the df dataframe.
The boolean value in the df_is_sdow is
<ul>
<li>True when the corresponding symbol is SDOW in the df dataframe
</li>
<li>False when the corresponding symbol is not SDOW in the df dataframe.
</li>
</ul>
</li>
</ul>
</li>
<li>The third major block of output corresponds to the seventh bullet in the
preceding script. The output consists of counts for rows with True and
False from the df_is_sdow dataframe. There are 858 rows with True
4290 rows with False.</li>
<li>The last major block of output corresponds to the eighth bullet in the preceding
script. This output consists of the filtered df dataframe output.
<ul>
<li>The filter is based on the rows of the df_is_sdow dataframe.
</li>
<li>The shape of the filtered dataframe indicates 858 rows, which corresponds
to the number of True values in the df_is_sdow dataframe.</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_10" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.010.png" height="861" width="698" />
</div>
<h4>Selecting a column subset</h4>
<p>Selecting a subset of one or more columns from a dataframe is very straightforward.
Merely take the original dataframe name, such as df, and follow it with square brackets.
Then, include either one column name in quote marks (&ldquo;column_name&rdquo;)
or a comma separated list of two or more column names where each name is in quote
marks. Here is a Python script to illustrate both approaches. There
are three major sections to the script.</p>
<ul>
<li>The beginning section configures a dataframe to filter.
<ul>
<li>The import pandas statement at the top of the script makes a reference
to the pandas library.</li>
<li>Then, additional code focuses on configuring a dataframe to filter.
<ul>
<li>The read&#xad;_csv function reads the .csv file created from SQL
Server in the first section of this tip.</li>
<li>The dataframe created from the output of the read_csv function receives
additional processing such as
<ul>
<li>Converting the date column to a datetime index named date.
This operation is performed with the help of the inplace parameter
for the set_index method of the df dataframe object. Setting
the inplace parameter to True eliminates the need to drop the date
column after the conversion.</li>
<li>Assigning a value of 0 to the options.display.width pandas parameter
enables printing more dataframe columns on a single row to avoid
truncation of output with the print function.</li>
</ul>
</li>
<li>The beginning section ends by displaying the df dataframe.
This is the dataframe that will be filtered to populate another series
or dataframe object based on a filtered version of the original dataframe.
</li>
</ul>
</li>
</ul>
</li>
<li>The second section starts with a comment line about displaying a filtered
version of the original dataframe with just one column of values.
<ul>
<li>The filtered output from the original dataframe populates just one column
of values in a pandas series object.
<ul>
<li>A pandas dataframe is composed of a set of two or more series objects.
</li>
<li>When the output from filtering a dataframe consists of a single
column of values, then the output populates a series.</li>
<li>Otherwise, the filtered output populates a dataframe.</li>
</ul>
</li>
<li>The assignment statement &ldquo;series_closes = df[&ldquo;close&rdquo;]&ldquo;
populates the series_closes object with the set of close column values from
the df dataframe.</li>
<li>After displaying the series values, the Python code returns the name
of the object returned by the df[&ldquo;close&rdquo;] term.</li>
</ul>
</li>
<li>The third section starts with a comment line about returning multiple columns
of values. The third section of code performs three functions in a way
that is roughly like the code in the second section.
<ul>
<li>First, it filters an original dataframe (df) and populates another dataframe
(df_syms_closes_and_some_emas) with the filtered output.</li>
<li>Second, it displays the values in the freshly populated dataframe.
</li>
<li>Third, it displays the object type for the output from the filtering
operation.</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_11" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.011.png" height="668" width="857" />
</div>
<p>Here is an image of the output from the preceding script in the Python Shell
window.</p>
<ul>
<li>The dataframe towards the top of the image is the dataframe to be filtered
in one of two ways.</li>
<li>The dataframe in the middle of the image displays the series output along
with the datetime index values from filtering the original dataframe for just
one column. Note that the object type is Series.</li>
<li>The dataframe at the bottom of the image shows the dataframe output from
filtering the original dataframe by more than one column.
<ul>
<li>The filtering process returns six columns from the original dataframe.
The columns retained by the filtering process are named symbol, close, ema_10,
ema_30, ema_50, and ema_200</li>
<li>The object type returned by the filtering process is another dataframe
named df_syms_close_and_some_emas.</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_12" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.012.png" height="942" width="831" />
</div>
<h4>Trading date range and shapes for filtered row sets</h4>
<p>Instead of creating filtered dataframe row sets based on boolean values as in
the &ldquo;Compiling a row subset based on boolean values&rdquo; subsection, you
can use criteria directly inserted into dataframe column selection criteria brackets.
Unlike the dataframe brackets in the prior subsection, these brackets filter rowsets
with specified settings. This subsection illustrates two demonstrations on
how to achieve this kind of row filtering with one or two distinct criteria.</p>
<p>The script for implementing both demonstrations appears below. The
script is divided into three parts by repeated single-line comment markers (##f&hellip;###)
across the width of the IDLE window. </p>
<ul>
<li>The top part prepares a dataframe to facilitate the two demonstrations.
<ul>
<li>The first two code segments in this part read a .csv file into a dataframe
and then converts a column of strings representing dates into a datetime
series that is set as the index for the dataframe.</li>
<li>Next, the dataframe&rsquo;s index is used to add two new columns that
are derived from the datetime series serving as an index.
<ul>
<li>The first new column has the name Year in the df dataframe.</li>
<li>The second new column has the name Month in the df dataframe.
</li>
</ul>
</li>
<li>The top part closes by presenting metadata for the dataframe before
printing the top and bottom five rows.</li>
</ul>
</li>
<li>The second part of the script shows the syntax for successively filtering
a rowset based on the df dataframe.
<ul>
<li>The syntax for defining a filtered rowset is: (df[df[&quot;Year&quot;]
== YYYY]) where YYYY are four digits representing a year.</li>
<li>The YYYY values in this tip represent four years from 2018 through 2021.
<ul>
<li>The trading dates for 2018, 2019, and 2020 are for all trading dates
throughout each year.</li>
<li>The trading dates for 2021 are for the trading dates through the
end of May.</li>
</ul>
</li>
<li>Four print functions in the second part of the script display in the
Python shell window the rowset for each of the four years.</li>
</ul>
</li>
<li>The third part of the script shows the syntax for filtering based on a combination
of two date criteria.
<ul>
<li>There is just one example created in the final part of the script.
The filtered rowset in this part reveals a syntax for creating a filtered
rowset based concurrently on two criteria.</li>
<li>The vertical bar operator (|) performs an &ldquo;or&rdquo; operation
between two criteria &ndash; one for rows from 2021 and the other for rows
from 2020.</li>
<li>The output from both criteria are stored in df_year_21_or_20, and a
print function displays the combined filtered outputs in the Python shell
window.</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.013.png" height="881" width="712" />
</div>
<p>The following screen shot shows the metadata along
with the first and last five rows for the source dataframe in this subsection.
</p>
<ul>
<li>There are eleven columns in the dataframe.
<ul>
<li>Nine of these columns are from the read_csv function that reads into
Python a .csv file exported from SQL Server.</li>
<li>Two additional columns are derived from the datetimeindex for the new
sample dataframe. The datetimeindex is derived originally from the
date column in the .csv file exported from SQL Server.
<ul>
<li>One additional column has the name Year. It has an int64 data
type.</li>
<li>The second additional column has the name Month. It also has
an int64 data type.</li>
</ul>
</li>
<li>The metadata for datetimeindex indicates its data type is datetime64[ns],
which is an integer data type with 64 bits of precision that can denote
datetime values down to the level of a nanosecond.</li>
</ul>
</li>
<li>Below the metadata is a df dataframe excerpt displaying the top and bottom
five rows.
<ul>
<li>The rows remain sorted in the same order as they were in SQL Server.
This order is described in the &ldquo;Exporting a .csv file for a SQL Server
results set&rdquo; subsection.</li>
<li>There are a total 5148 rows in the df dataframe. This is confirmed
by the first number in the shape brackets below the listing of excerpted
df dataframe values.</li>
</ul>
</li>
</ul>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_14" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.014.png" height="734" width="686" />
</div>
<p>The following table summarizes key design features
and output from the first example.</p>
<ul>
<li>Recall that the example is to create four filtered dataframes. Each
filtered dataframe contains the rows from one year of rows in the df dataframe.
</li>
<li>The table has five rows &ndash; one for each of the four years in the df
dataframe followed by a fifth row with summary data for all the years.</li>
<li>The four filtered dataframes completely segment all the rows in the df dataframe
by year.</li>
<li>The first number in the Shape column denotes the count of rows in the filtered
dataframe for each year.
<ul>
<li>The count of trading days per year is not invariant across years because
of the days on which market holidays fall as well as other special issues.
</li>
<li>Additionally, the year 2021 only has 612 trading days because the trading
data was pulled through the end of May in 2021 &ndash; not all the trading
days in a year as is true for the dataframes based on 2018, 2019, and 2020.
</li>
</ul>
</li>
<li>The most important point about the rows per filtered dataframe and the rows
for the df dataframe is that the sum of the rows (612, 1518, 1512, and 1506)
for the filtered dataframes equals the number or rows in the df dataframe (5148).
</li>
</ul>
<table cellpadding="4" cellspacing="0" border="1" align="center">
<tr>
<th colspan="3">
Trading
Date Range, Trading Date Criteria vs. Rows x Columns in Filtered Rows Shape
</th>
</tr>
<tr>
<td>
Trading Date Range
</td>
<td>
Trading Date Criteria
</td>
<td>
Shape [Rows x Columns]
</td>
</tr>
<tr>
<td>
2021
</td>
<td>
df[&quot;Year&quot;] == 2021
</td>
<td>
[612 rows x 11 columns]
</td>
</tr>
<tr>
<td>
2020
</td>
<td>
df[&quot;Year&quot;] == 2020
</td>
<td>
[1518 rows x 11 columns]
</td>
</tr>
<tr>
<td>
2019
</td>
<td>
df[&quot;Year&quot;] == 2019
</td>
<td>
[1512 rows x 11 columns]
</td>
</tr>
<tr>
<td>
2018
</td>
<td>
df[&quot;Year&quot;] == 2018
</td>
<td>
[1506 rows x 11 columns]
</td>
</tr>
<tr>
<td>
Jan2018 &ndash; May2021
</td>
<td>
All trading dates in Trading Date Range
</td>
<td>
[5148 rows x 11 columns]
</td>
</tr>
</table>
<p>The last screen shot in this tip shows the output
for the script that creates a filtered dataframe based on two criteria &ndash; one
for rows with a date in 2020 and another for rows with a date in 2021. The
following screen shot shows the two criteria generate a filtered dataframe with
2130 rows. This outcome is consistent with the sum of the dataframe row counts
for 2020 (1518) and 2021(612).</p>
<div class="imageborder">
<img loading="lazy" alt="Pandus_Dataframes_fig_15" src="/tipimages2/6938_create-populate-subset-pandas-dataframe.015.png" height="377" width="654" />
</div>
<p>You may be wondering which is the best approach (boolean values or criteria expressions)
to creating a filtered dataframe based on the rows in a source dataframe.
The answer may be that it depends.</p>
<ul>
<li>On the one hand, it takes more lines of code to set up dataframe filtering
based on boolean values. This is because a developer must create a dataframe
with boolean values before you can attempt to perform filtering.</li>
<li>The criteria-based approach allows you to specify the criteria and do the
filtering in one step.</li>
<li>The directness of the criteria-based may appeal to those who are comfortable
specifying criteria in different dataframe filtering contexts.</li>
<li>On the other hand, the boolean approach allows you to easily verify your
criteria for filtering before you invoke the filtering for the criteria.
</li>
</ul>
<h5>Next Steps</h5>
<p>This
<a href="/tipimages2/6938_Create_Populate_Subset_Pandus_Dataframe.zip" target="_blank">tip&rsquo;s download file</a> contains six files to help you get a hands-on feel for implementing
the Python solutions in this tip.</p>
<ul>
<li>A key file is a .csv file with the sample data referenced by the Python
script files.</li>
<li>There are also five Python script files with sample code for all the solutions
presented in this tip. Each Python script file has a .py extension.
</li>
<li>You may need to edit the Python script files based on where you save the
.csv file. This is because the Python script files have hard code to expect
the .csv file in the C:\DataScienceSamples folder.</li>
</ul>
<p>After verifying the code works as described with the sample data file, you are
encouraged to use your own custom data files. This will most likely require
changes to the Python scripts in this sample that depend on column names and row
values in your custom sample data.</p>
<br /><br />
Last Updated: 2021-08-16
<br /><br /><br />
<div class="row">
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="gtag('event', 'click', {'event_category': 'Scripts', 'event_label': 'BotTip'});" target="_blank"><img loading="lazy" border="0" src="/images/Free-Download_20190509.png" alt="get scripts" width="300" height="150"></a></div>
<br />
</div>
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/sql-server-tip-category/162/other-database-platforms/" onclick="gtag('event', 'click', {'event_category': 'NextTip', 'event_label': 'YellowArrow'});"><img loading="lazy" border="0" src="/images/nav_nexttip_clickhere_rev1.png" alt="next tip button" width="300" height="150"></a></div>
<br />
</div>
</div>
<br /><br />
<h5>About the author</h5>
<div class="row">
<div class="large-6 columns">
<a href="/sqlserverauthor/57/rick-dobson/"><img loading="lazy" style="float: left; padding: 0px 3px 0px 0px;" alt="MSSQLTips author Rick Dobson" height="90" src="/images/RickDobson.JPG" width="60" /></a>
Rick Dobson is a Microsoft Certified Technical Specialist and well accomplished SQL Server and Access author.
<br /><br /><b><a href="/sqlserverauthor/57/rick-dobson/">View all my tips</a></b>
</div>
<div class="large-6 columns">
<b>Related Resources</b><br />
<ul>
<li><a href="/sql-server-dba-resources/">More SQL Server DBA Tips...</a></li>
</ul>
</div>
</div>
<br /><br />
<a name="comments"></a>
</article>
<div class="row">
</div>
<div class="hide-for-print">
<hr>
<h2>Comments For This Article</h2>
<button class="button round" data-reveal-id="myModal" data-reveal-ajax="/zurb_comments.asp?id=1x6938">Add Comment</button>
<div id="myModal" class="reveal-modal" data-reveal aria-labelledby="modalTitle" aria-hidden="true" role="dialog">
</div>
<style type="text/css">
.ForumPostBodyArea
{
	width: 100%;
	vertical-align: top;
	overflow: auto;
}
</style>
<br /><br /><br />
</div>
</div>
<style>
			div.stickyright {
			  position: -webkit-sticky;
			  position: sticky;
			  padding: 0;
			  background-color: white;
			  width: 300px;
			  z-index: 1;
			}
	</style>
<div class="large-3 hide-for-print columns rightsize">
<br />
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="gtag('event', 'click', {'event_category': 'download-button', 'event_label': 'scripts'});" target="_blank"><img loading="lazy" src="/images/download-index-scripts-1.png" alt="download" width="273" height="93"></a></div>
<br /><br />

<div align="center">
<div id='div-gpt-ad-1388505177750-0' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-0'); });
	}	
	</script>
</div>
</div><br /><br /><br />
<div style="padding:2px; background-color:#FFFFFF; ">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Recommended Reading</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '6938', {'event_category': 'Recommended', 'event_label': '3662'});" href="/sqlservertip/3662/sql-server-and-postgresql-linked-server-configuration-part-2/">SQL Server and PostgreSQL Linked Server Configuration - Part 2</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '6938', {'event_category': 'Recommended', 'event_label': '4396'});" href="/sqlservertip/4396/creating-a-sql-server-2014-linked-server-for-an-oracle-11g-database/">Creating a SQL Server 2014 Linked Server for an Oracle 11g Database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '6938', {'event_category': 'Recommended', 'event_label': '6559'});" href="/sqlservertip/6559/oracle-to-sql-server-migration-with-sql-server-migration-assistant/">How to Migrate an Oracle Database to SQL Server using SQL Server Migration Assistant for Oracle - Part 1</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '6938', {'event_category': 'Recommended', 'event_label': '6672'});" href="/sqlservertip/6672/sql-update-statement-with-join-in-sql-server-oracle-postgresql/">SQL Update Statement with Join in SQL Server vs Oracle vs PostgreSQL</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '6938', {'event_category': 'Recommended', 'event_label': '6942'});" href="/sqlservertip/6942/exploring-snowflake-tasks/">Exploring Snowflake Tasks</a><br><br>
</div>
</div>
<br><br><br><br>

<div align="center">
<div id='div-gpt-ad-1388505177750-3' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-3'); });
	}	
	</script>
</div>
</div> <br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-1' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-1'); });
	}
	</script>
</div>
</div> <br /><br /><br />
<div class="stickyright" style="top:55px;">
 
<div align="center">
<div id='div-gpt-ad-1388505177750-2' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{	
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-2'); });
	}	
	</script>
</div>
</div> <br /><br /><br /> <script language="Javascript">
	function ValidateEmail(inputText)
	{
	
		if (document.optin.consent.checked == false) {
		     alert("Please agree to terms by ticking check box.");
		     return false;
	            }	
	   
		var mailformat = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
		if(inputText.value.match(mailformat))
		{
			document.optin.ea.focus();
			return true;
		}
		else
		{
			alert("You have entered an invalid email address!");
			document.optin.ea.focus();
			return false;
		}
	}

	</script>
<div id="sticky2">
<div id="search-div" style="height:300px; width:300px">
<div id="signup-div">
<div style="text-align: center;"><a href="/get-free-sql-server-tips/?ref=LeftGFSTSlant"><img loading="lazy" alt="get free sql tips" border="0" src="/images/GetFreeSQLTips_black_box.png" width="300" height="150"></a></div>
<form action="/get-free-sql-server-tips/" method="post" name="optin" onsubmit="return ValidateEmail(document.optin.ea)">
<input name="URL" type="hidden" value="leftform" />
<input name="ReferralURL" type="hidden" value="" />
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-10 columns">
<input size="25" type="text" onblur="if (this.value=='') this.value=this.defaultValue" onclick="if (this.defaultValue==this.value) this.value=''" value="enter business email" name="ea">
</div>
<div class="small-2 columns">
<input type="submit" name="Button1" value="Join" />
</div>
</div>
</div>
</div>
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-1 columns">
<input type="checkbox" name="consent" value="1">
</div>
<div class="small-11 columns">
<a href="/privacy/" target="_blank"><img loading="lazy" src="/images/mssqltips-agree-terms.png" alt="agree to terms" width="276" height="67"></a>
</div>
</div>
</div>
</div>
<br /><br />
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<footer class="row hide-for-print">
<hr />
<ul class="small-block-grid-2 medium-block-grid-3 large-block-grid-6" style="margin:10px;">
<li>
<h3><span style="color:#3B6D93">Follow</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=GetFooterMenu">Get Free SQL Tips</a></li>
<li><a rel="noopener" href="https://twitter.com/mssqltips" target="_blank">Twitter</a></li>
<li><a rel="noopener" href="https://www.linkedin.com/groups/2320891/" target="_blank">LinkedIn</a></li>
<li><a rel="noopener" href="https://www.facebook.com/mssqltips/" target="_blank">Facebook</a></li>
<li><a rel="noopener" href="https://www.pinterest.com/mssqltips/" target="_blank">Pinterest</a></li>
<li><a rel="noopener" href="https://feeds.feedburner.com/MSSQLTips-LatestSqlServerTips" target="_blank">RSS</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Learning</span></h3>
<ul>
<li><a href="/sql-server-dba-resources/">DBAs</a></li>
<li><a href="/sql-server-developer-resources/">Developers</a></li>
<li><a href="/sql-server-business-intelligence-resources/">BI Professionals</a></li>
<li><a href="/sql-server-professional-development-resources/">Careers</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Resources</span></h3>
<ul>
<li><a href="/sql-server-tutorials/">Tutorials</a></li>
<li><a href="/sql-server-webcasts/">Webcasts</a></li>
<li><a href="/sql-server-whitepapers/">Whitepapers</a></li>
<li><a href="/sql-server-tools/">Tools</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Search</span></h3>
<ul>
<li><a href="/sql-server-categories/">Tip Categories</a></li>
<li><a href="/search-tip-id/">Search By TipID</a></li>
<li><a href="/sql-server-mssqltips-authors/">Authors</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Community</span></h3>
<ul>
<li><a href="/learn-more-about-mssqltips/">First Timer?</a></li>
<li><a href="/mssqltips-community/1/">Pictures</a></li>
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/sql-server-event-list/">Event Calendar</a></li>
<li><a href="/sql-server-user-groups/">User Groups</a></li>
<li><a href="/mssqltips-author-of-year/">Author of the Year</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">More Info</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=JoinFooterMenu">Join</a></li>
<li><a href="/about/">About</a></li>
<li><a href="/copyright/">Copyright</a></li>
<li><a href="/privacy/">Privacy</a></li>
<li><a href="/disclaimer/">Disclaimer</a></li>
<li><a href="/feedback/">Feedback</a></li>
<li><a href="/advertise/">Advertise</a></li>
</ul>
</li>
</ul>
<hr />
<div class="row">
<div class="large-12 columns text-center">
<p>Copyright (c) 2006-2021 <a href="https://www.edgewoodsolutions.com">Edgewood Solutions, LLC</a> All rights reserved<br />
<small>Some names and products listed are the registered trademarks of their respective owners.</small></p>
</div>
</div>
</footer>

<style type="text/css">
#slideboxtop{
    width:100%;
    height:50px;
    padding:0px;
    background-color:#FFFFFF;      
    border-bottom:1px solid #000000;
    position:fixed;
    top: -350px;
	-moz-box-shadow:-2px 0px 5px #aaa;
	-webkit-box-shadow:-2px 0px 5px #aaa;
/* 	box-shadow:-2px 0px 5px #aaa;    */
}
</style>
<div class="hide-for-small hide-for-medium hide-for-print">
<div id="slideboxtop" style="z-index:1;">
<div style="text-align:center">
<div w3-include-html="/Site-Sponsorship/site-sponsorship.asp"></div>
</div>
</div>
</div>
<script src="/js/jquery-foundation-combined-min.js"></script>
<script type="text/javascript">
var articleLength = $("article").find("p").length;

 

</script>
<script>
    $(document).foundation();
</script>
<script type="text/javascript" src="/css/prettify.combined.js" defer></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function(){
		if  ($(window).scrollTop() > 250)
			$('#slideboxtop').animate({'top':'0px'});
		else
			$('#slideboxtop').stop(true).animate({'top':'-250px'});
	});
});
</script>
<script>
function includeHTML() {
  var z, i, elmnt, file, xhttp;
  /*loop through a collection of all HTML elements:*/
  
  z = document.getElementsByTagName("*");
  for (i = 0; i < z.length; i++) {
    elmnt = z[i];
    /*search for elements with a certain atrribute:*/
    file = elmnt.getAttribute("w3-include-html");
	if (file) {
      /*make an HTTP request using the attribute value as the file name:*/
      xhttp = new XMLHttpRequest();
      xhttp.onreadystatechange = function() {
        if (this.readyState == 4) {
          if (this.status == 200) {elmnt.innerHTML = this.responseText;}
          if (this.status == 404) {elmnt.innerHTML = "Page not found.";}
          /*remove the attribute, and call this function once more:*/
          elmnt.removeAttribute("w3-include-html");
          includeHTML();
        }
      }   
      xhttp.open("GET", file, true);
      xhttp.send();
      /*exit the function:*/
      return;
    }
  }
};
</script>
<script>
 if ($(window).width() > 1000) {
	includeHTML();
	$("div.rightsize").height($("#container").height());
    }	
</script>

<script> 
//<![CDATA[ 
if (screen.width > 749)
{
function deferGoogleJS() { 
var d = document.createElement("script"); 
d.src = "https://www.googletagmanager.com/gtag/js?id=UA-910745-2", 
document.body.appendChild(d) 
} 
window.addEventListener ? window.addEventListener("load", deferGoogleJS, !1) : window.attachEvent ? window.attachEvent("onload", deferGoogleJS) : window.onload = deferGoogleJS; 
window.dataLayer = window.dataLayer || [];

function gtag() { 
dataLayer.push(arguments); 
} 
gtag('js', new Date()); 
gtag('config', 'UA-910745-2'); 
}
//]]> 
</script>
</body>
</html>
