
<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta http-equiv="Content-Language" content="en-us" />
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

<link rel="SHORTCUT ICON" href="/favicon.ico" />
<meta content="width=device-width, initial-scale=1.0" name="viewport" />
<title>How to Resolve Merge Conflicts in Git for SSIS Projects</title>
<meta name="description" content="In this part of the tip we will show you how to simulate a merge conflict when using Git for an Integration Services project." />
<link rel="canonical" href="https://www.mssqltips.com/sqlservertip/6682/how-to-resolve-merge-conflicts-in-git-for-ssis-projects/" />
<link rel="stylesheet" href="/css/foundation-minimized.css">
<link rel="stylesheet" href="/css/app.css">
<script>/*! loadCSS. [c]2017 Filament Group, Inc. MIT License */!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mssqltips.com/sqlservertip/6682/how-to-resolve-merge-conflicts-in-git-for-ssis-projects/"
  },
  "headline": "How to Resolve Merge Conflicts in Git for SSIS Projects",
  "image": [
  
    "https://www.mssqltips.com/images_newsletter/6682_NewsletterImage.png"
  
   ],  
  "datePublished": "2021-01-07T00:00:00+05:00",
  "dateModified": "2021-01-07T00:00:00+05:00",
  "author": {
    "@type": "Person",
    "name": "Koen Verbeeck"
  },
   "publisher": {
    "@type": "Organization",
    "name": "MSSQLTips",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.mssqltips.com/images/mslogo_113x60.png"
    }
  },
  "description": "In this part of the tip we will show you how to simulate a merge conflict when using Git for an Integration Services project."
}
</script>
<meta property="og:url" content="https://www.mssqltips.com/sqlservertip/6682/how-to-resolve-merge-conflicts-in-git-for-ssis-projects/" />
<meta property="og:type" content="website" />
<meta property="og:title" content="How to Resolve Merge Conflicts in Git for SSIS Projects" />
<meta property="og:description" content="In this part of the tip we will show you how to simulate a merge conflict when using Git for an Integration Services project." />
<meta property="og:image" content="https://www.mssqltips.com/images_newsletter/6682_NewsletterImage.png" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mssqltips">
<meta name="twitter:creator" content="@mssqltips">
<meta name="twitter:title" content="How to Resolve Merge Conflicts in Git for SSIS Projects">
<meta name="twitter:description" content="In this part of the tip we will show you how to simulate a merge conflict when using Git for an Integration Services project.">
<meta name="twitter:image" content="https://www.mssqltips.com/images_newsletter/6682_NewsletterImage.png">
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
 
window.googletag = window.googletag || {cmd: []};

googletag.cmd.push(function() {

   var mapping = googletag.sizeMapping().
   addSize([100, 100], []).
   addSize([320, 400], []).
   addSize([320, 700], []).
   addSize([750, 200],  [[728, 90],[300,250],[160,300],[300,600],[170,90]]).
   addSize([1050, 200], [[728, 90],[300,250],[160,300],[300,600],[170,90]]).build();

   var mapping728 = googletag.sizeMapping()
     .addSize([750, 200], [728, 90])
     .addSize([0, 0], [])
     .build();
   var mapping300 = googletag.sizeMapping()
     .addSize([640, 400], [300, 250])
     .addSize([0, 0], [])
     .build();
   var mapping600 = googletag.sizeMapping()
     .addSize([640, 600], [[160,600],[300,600]])
     .addSize([0, 0], [])
     .build();
   var mapping170 = googletag.sizeMapping()
     .addSize([640, 400], [170,90])
     .addSize([0, 0], [])
     .build();   
   
   
 
   googletag.defineSlot('/53998264/160x600-Primary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-0').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/160x600-Secondary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-1').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Primary', [300, 250], 'div-gpt-ad-1388505177750-2').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Secondary', [300, 250], 'div-gpt-ad-1388505177750-3').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/728x90-Primary', [728, 90], 'ad-slot-leader').defineSizeMapping(mapping728).addService(googletag.pubads()); 


   googletag.pubads().enableLazyLoad();
   // googletag.pubads().disableInitialLoad();
   googletag.pubads().collapseEmptyDivs();
   googletag.enableServices();
});

</script>
</head>
<body onload="PR.prettyPrint()" style="background-color:white;">
<a name="top"></a>
<div class="sticky-no">
<nav class="top-bar" data-topbar role="navigation" ">
<ul class="title-area">
<li class="name">
<a href="https://www.mssqltips.com/"><img alt="mssqltips logo" src="/images/mslogo_bw_89x45-2.png"></a>
</li>

<li class="toggle-topbar menu-icon"><a href="#"><span>Menu</span></a></li>
</ul>
<section class="top-bar-section">

<ul class="right">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'join', 'click']);" href="/get-free-sql-server-tips/?ref=JoinHeaderMenu"><span style="color:red;">Join</span></a></li>
<li class="has-dropdown hide-for-medium"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sql-server-tutorials/">Beginner</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertip/1948/what-is-sql-server/">What is SQL Server?</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertip/6422/sql-server-concepts/">SQL Server Concepts</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertip/6429/sql-server-download-quick-links/">SQL Server Download Links</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertutorial/3700/my-first-sql-server-business-intelligence-project-tutorial/">My First BI Project </a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertip/2677/sql-server-career-planning/">SQL Server Career Plan</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sql-server-tutorials/">Tutorials</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedures</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/9131/sql-server-index-tutorial-overview/">Indexing</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sql-server-tutorials/">All Tutorials</a></li>
</ul>
</li>
<li class="has-dropdown"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-dba-resources/">DBA</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/60/database-administration/">Database Administration</a></li>
<li class="has-dropdown"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="#">Perfomance</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/54/monitoring/">Monitoring</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sqlservertutorial/9194/sql-server-extended-events-tutorial/">Extended Events</a></li>
</ul>
</li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/81/powershell/">PowerShell</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/27/sql-server-agent/">SQL Server Agent</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sqlservertutorial/9268/sql-server-management-studio-overview-ssms/">Management Studio</a></li>
<li class="has-dropdown"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="#">High Availability</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/161/backup/">Backup</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/202/restore/">Restore</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/143/availability-groups/">Availability Groups</a></li>
</ul>
</li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown">
<a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sql-server-developer-resources/">T-SQL</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedure Tutorial</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1667/sql-server-join-example/">SQL Server Join Example</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">CROSS APPLY + OUTER APPLY</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1599/cursor-in-sql-server/">Cursor in SQL Server</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/4054/creating-a-date-dimension-or-calendar-table-in-sql-server/">Calendar Table</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/5993/sql-server-date-and-time-functions-with-examples/">Date and Time Functions</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-business-intelligence-resources/">Analytics</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-tip-category/211/power-bi/">Power BI</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-business-intelligence-resources/">Azure Data Factory</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/4200/sql-server-analysis-services-2016-ssas-tutorial/">Analysis Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/9073/sql-server-2017-and-python-basics/">Python</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/9040/getting-started-with-r-in-sql-server/">R</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="_gaq.push(['_trackEvent', 'hmenu', 'cloud', 'click']);" href="#">Cloud</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'cloud', 'click']);" href="/sql-server-tip-category/205/amazon-aws/">AWS</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'cloud', 'click']);" href="/sql-server-tip-category/87/azure/">Azure</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'cloud', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="_gaq.push(['_trackEvent', 'hmenu', 'showcase', 'click']);" href="#">Tools</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'showcase', 'click']);" href="/sqlservertip/6297/melissa-data-quality-solutions-for-ssis/?ps=melissa">Data Quality Tools</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'showcase', 'click']);" href="/sqlservertip/6310/solarwinds-database-performance-analyzer-for-sql-server/?ps=solarwinds-dpa">Database Performance Analyzer</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'showcase', 'click']);" href="/sqlservertip/6367/quest-foglight-for-databases/?ps=quest-foglight">Foglight for SQL Server</a></li>
</ul>
</li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'search', 'click']);" href="/search/"><span style="color:red;">Search</span></a></li>
</ul>
</section>
</nav>
</div>
<div class="row">
<div class="entry-content large-9 columns" role="content"> <h1>How to Resolve Merge Conflicts in Git for SSIS Projects</h1>
<div id="sticky-anchor-outline"></div>
<div align="center" class="hide-for-print hide-for-small">
<div id="ad-slot-leader" style="width:728px; height:90px; min-width:728px; min-height:90px;">
<script type='text/javascript'>
			 googletag.cmd.push(function() {googletag.display('ad-slot-leader'); });
		   </script>
</div>
</div>
<br />
<article>
<p>By: <a href="/sqlserverauthor/114/koen-verbeeck/" rel="author" title="author profile for Koen Verbeeck">Koen Verbeeck</a> &nbsp;&nbsp;|&nbsp;&nbsp; Updated: 2021-01-07 &nbsp;&nbsp;|&nbsp;&nbsp; <a href="#comments" title="read and post comments">Comments</a> &nbsp;&nbsp;|&nbsp;&nbsp; Related: <a href="/sqlservertip/6667/branching-and-merging-strategy-in-git-for-ssis-projects/">1</a> | <a href="/sqlservertip/6682/how-to-resolve-merge-conflicts-in-git-for-ssis-projects/">2</a> | <a href="/sql-server-developer-resources/">More</a> > <a href="/sql-server-tip-category/206/devops/">DevOps</a></p>
<br />
<h5>Problem</h5>
<p>When working on the same project with multiple developers, a conflict may arise
when developers check their code into the git repository. In this part of the tip
series,
we'll show you how to simulate a merge conflict in an Integration Services
project.</p>
<h5>Solution</h5>
<p>In
<a href="/sqlservertip/6667/branching-and-merging-strategy-in-git-for-ssis-projects/" target="_blank">part 1 of the tip</a>, the basics
of branching in git was described, as well as some guidelines for using git in Integration
Services (SSIS) projects. If you haven't already, please read part 1 before
proceeding with this part of the tip. To recap, two developers working on two different
branches can have the following structure:</p>
<div class="imageborder">
<img alt="git branches layout" src="/tipimages2/6682_git-branching-merging-ssis.001.png" />
</div>
<p>When <strong>branch 2</strong> is checked into the dev branch, it's possible a conflict
will arise if the two developers have been working on the same objects.</p>
<h2>Merge Conflict in Git</h2>
<p>Let's illustrate the concept of a merge conflict. Let's assume we
have a sample project with one package in it:</p>
<div class="imageborder">
<img alt="sample project" src="/tipimages2/6682_git-branching-merging-ssis.002.png" />
</div>
<p>Two developers of the team have been given assigned to two work items:</p><ul>
<li>Add a new package, performing some task.</li>
<li>Add an extra task to an existing package.</li>
</ul>
<p>The guideline &quot;do not work on the same package by multiple developers&quot;
is followed, but both developers will be working inside the same SSIS project.
</p>
<p>Each developer creates his own branch. The first developer creates a new branch
called &quot;feature/add-package&quot;. To create a new branch, go to the Team
Explorer tab and click the <em>home</em> button. Next, click on <em>Branches</em>
in the <em>Project</em> section.</p>
<div class="imageborder">
<img alt="go to branches" src="/tipimages2/6682_git-branching-merging-ssis.003.png" />
</div>
<p>Click on New Branch, supply a name. Make sure the dev branch is selected as the
source for the new branch.</p>
<div class="imageborder">
<img alt="add branch to add new package" src="/tipimages2/6682_git-branching-merging-ssis.004.png" />
</div>
<p>This will create a new branch in the local repo. To sync it to the remote repo,
right-click the newly created branch and select &quot;Push Branch&quot;.</p>
<div class="imageborder">
<img alt="push new branch to remote repo" src="/tipimages2/6682_git-branching-merging-ssis.005.png" />
</div>
<p>Repeat the same process to create a new branch &quot;feature/add-task&quot;
for the second developer.</p>
<div class="imageborder">
<img alt="second branch add to local and remote repo" src="/tipimages2/6682_git-branching-merging-ssis.006.png" />
</div>
<p>Make sure the &quot;add-package&quot; branch is checked out (displayed in bold).
Open up the package in Solution Explorer and add a new package to the project:
</p>
<div class="imageborder">
<img alt="add new package" src="/tipimages2/6682_git-branching-merging-ssis.007.png" />
</div>
<p>Save the entire project and commit the changes by right-clicking the package/project
and selecting &quot;commit&quot;.</p>
<div class="imageborder">
<img alt="commit changes" src="/tipimages2/6682_git-branching-merging-ssis.008.png" />
</div>
<p>Another method to commit is to go to Team Explorer and then to the Changes section.
</p>
<div class="imageborder">
<img alt="go to changes in Team Explorer" src="/tipimages2/6682_git-branching-merging-ssis.009.png" />
</div>
<p>There you have a full list of all the changes in the project which haven't
been committed yet.</p>
<div class="imageborder">
<img alt="team explorer" src="/tipimages2/6682_git-branching-merging-ssis.010.png" />
</div>
<p>In the list of changes, you can see the SSIS project file (with the extension.dtproj)
has also been changed. This is because the project file keeps a list of packages
that are included in the project.</p>
<p>Supply a meaningful commit message and hit <em>Commit All</em>. When the changes
are committed, they are only saved to the local repository. We still need to push
them to the remote repository. When you commit in Visual Studio, you'll get
an information message with a link to sync your changes to the server.</p>
<div class="imageborder">
<img alt="go to sync menu" src="/tipimages2/6682_git-branching-merging-ssis.011.png" />
</div>
<p>This will lead you to the <em>Synchronization</em> menu where you can also explicitly
push your changes to the remote server.</p>
<div class="imageborder">
<img alt="push changes to remote" src="/tipimages2/6682_git-branching-merging-ssis.012.png" />
</div>
<p>If you want to verify this in Azure Devops, make sure to select the correct branch:
</p>
<div class="imageborder">
<img alt="select correct branch in Azure Devops" src="/tipimages2/6682_git-branching-merging-ssis.013.png" />
</div>
<p>If you select a different branch, you will not see the new package in the project
because these branches have a different snapshot of the repository.</p>
<p>The work of the first developer is now done and the branch can be merged into
the dev branch. To do this, a pull request needs to be created. A pull request will
take the code from a source branch and merge it into a destination branch.</p>
<p>In Team Explorer, you can go to the Pull Requests section and click on &quot;New
Pull Request&quot;.</p>
<div class="imageborder">
<img alt="create new pull request link" src="/tipimages2/6682_git-branching-merging-ssis.014.png" />
</div>
<p>This will open Azure Devops in a new browser tab where you can actually create
the pull request.</p>
<div class="imageborder">
<img alt="create new pull request" src="/tipimages2/6682_git-branching-merging-ssis.015.png" />
</div>
<p>You need to specify a name (it sometimes is automatically filled in if you work
with work items) and a description. You can assign a reviewer who can either approve
or decline the pull request. You can also make a link to existing work items and
add tags. At the top, make sure you have selected the dev branch as the destination
branch. When you click on Create, git will automatically check if any of the commits
on the source branch will cause a merge conflict in the destination branch.</p>
<div class="imageborder">
<img alt="no merge conflict found" src="/tipimages2/6682_git-branching-merging-ssis.016.png" />
</div>
<p>Any reviewers can approve the branch (or reject it). By clicking on <em>Complete</em>,
you get the following pop-up:</p>
<div class="imageborder">
<img alt="complete merge request" src="/tipimages2/6682_git-branching-merging-ssis.017.png" />
</div>
<p>Typically, you'll want the source branch to be deleted since the work is
done. If you keep branches open for too long, they will become more and more out
of sync with the dev branch. This will make merging harder and more complex.</p>
<p>When looking at branches in Visual Studio, it's possible the deleted branch
is still shown due to
<a href="https://developercommunity.visualstudio.com/content/problem/691248/deleted-branch-still-showing-in-source-control-exp.html" target="_blank">
a bug</a>. You are still able to fetch (although it shouldn't be possible),
but when you do a pull on the local branch, an error will be shown:</p>
<div class="imageborder">
<img alt="deleted branch still shown in VS" src="/tipimages2/6682_git-branching-merging-ssis.018.png" />
</div>
<p>You can delete the local branch &quot;feature/add-package&quot; after you have
checked out the other branch &quot;feature/add-task&quot;. This is the current
state of our repo:</p>
<div class="imageborder">
<img alt="one branch merged" src="/tipimages2/6682_git-branching-merging-ssis.019.png" />
</div>
<p>We have one commit on the add-package branch, no commits on the add-task branch,
and the right branch has been successfully merged back into the dev branch.</p>
<p>The second developer can now work on the other branch and add a new task to the
SSIS package. Check out the &quot;feature/add-task&quot; branch. If you open up
the project, you see the package we just added is not there. This is because the
work was done in another branch which is not visible in the current branch.</p>
<p>Add a new task to the control flow of the existing package:</p>
<div class="imageborder">
<img alt="add new task to package" src="/tipimages2/6682_git-branching-merging-ssis.020.png" />
</div>
<p>Since the sample package is only needed to demonstrate the git capabilities,
the new task doesn't need to be configured. Commit and push the change just
as we did before.</p>
<div class="imageborder">
<img alt="view changes and commit of adding task" src="/tipimages2/6682_git-branching-merging-ssis.021.png" />
</div>
<p>Since the work on this branch is now done, a pull request can be created to merge
the branch with the dev branch.</p>
<div class="imageborder">
<img alt="create new pull request" src="/tipimages2/6682_git-branching-merging-ssis.022.png" />
</div>
<p>When the merge is created, a conflict is now detected:</p>
<div class="imageborder">
<img alt="merge conflict detected" src="/tipimages2/6682_git-branching-merging-ssis.023.png" />
</div>
<p>You can ignore the .suo file since it is a
<a href="https://docs.microsoft.com/en-us/visualstudio/extensibility/internals/solution-user-options-dot-suo-file?view=vs-2019" target="_blank">
user file</a> and not important to the project. To ignore further conflicts in this
file, you can add it to the
<a href="https://docs.microsoft.com/en-us/azure/devops/repos/git/ignore-files?view=azure-devops&amp;tabs=visual-studio" target="_blank">
git.ignore file</a>.</p>
<p>The status of the repo is now like this:</p>
<div class="imageborder">
<img alt="merge conflict graph" src="/tipimages2/6682_git-branching-merging-ssis.024.png" />
</div>
<p>We have now successfully simulated a merge conflict. Be sure to check out part
3 where we will propose multiple solutions to resolve this conflict!</p>
<h5>Next Steps</h5>
<ul>
<li>When creating a pull request, you have additional tabs with the commits
contained in the pull request and a list of the files that have changed. For
each file, you get a comparison between the old and new version. Familiarize
yourself with the layout.</li>
<li>If you haven't already, check out
<a href="/sqlservertip/6667/branching-and-merging-strategy-in-git-for-ssis-projects/" target="_blank">part 1 of this
tip</a>!</li>
<li>
<a href="/sqlservertip/6640/basics-of-gitflow-workflow-for-sql-database-projects/?_utm_source=KoenVerbeeck" target="_blank">
Basics of Gitflow Workflow for SQL Database Projects Part 1</a></li>
<li>For more SSIS tips, check out
<a href="/sql-server-tip-category/17/integration-services-development/" target="_blank">this overview</a>.</li>
</ul>
<br /><br />
Last Updated: 2021-01-07
<br /><br /><br />
<div class="row">
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="_gaq.push(['_trackEvent', 'Scripts', 'Click', 'BotTip']);" target="_blank"><img border="0" src="/images/Free-Download_20190509.png" alt="get scripts" width="300" height="150"></a></div>
<br />
</div>
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/sql-server-tip-category/206/devops/" onclick="_gaq.push(['_trackEvent', 'NextTip', 'Click', 'YellowArrow']);"><img border="0" src="/images/nav_nexttip_clickhere_rev1.png" alt="next tip button" width="300" height="150"></a></div>
<br />
</div>
</div>
<br /><br />
<h5>About the author</h5>
<div class="row">
<div class="large-6 columns">
<a href="/sqlserverauthor/114/koen-verbeeck/"><img style="float: left; padding: 0px 3px 0px 0px;" alt="MSSQLTips author Koen Verbeeck" height="90" src="/images/Koen-Verbeeck-2018-2.png" width="60" /></a>
Koen Verbeeck is a BI professional, specializing in the Microsoft BI stack with a particular love for SSIS.
<br /><br /><b><a href="/sqlserverauthor/114/koen-verbeeck/">View all my tips</a></b>
</div>
<div class="large-6 columns">
<b>Related Resources</b><br />
<ul>
<li><a href="/sqlservertip/6667/branching-and-merging-strategy-in-git-for-ssis-projects/" title="Branching and Merging Strategy in Git for SSIS Projects">Branching and Merging Strategy in Git for SSIS Pro...</a></li><li><a href="/sqlservertip/6682/how-to-resolve-merge-conflicts-in-git-for-ssis-projects/" title="How to Resolve Merge Conflicts in Git for SSIS Projects">How to Resolve Merge Conflicts in Git for SSIS Pro...</a></li><li><a href="/sql-server-developer-resources/">More Database Developer Tips...</a></li>
</ul>
</div>
</div>
<br /><br />
<a name="comments"></a>
<div class="row hide-for-small hide-for-print">
<div class="large-12 columns">
<a href="/contribute/">Become a paid author</a>
</div>
<hr />
</div>
<br /><br />
</article>
<div class="row">
</div>
<div class="hide-for-print">
<hr>
<h2>Comments For This Article</h2>
<button class="button round" data-reveal-id="myModal" data-reveal-ajax="/zurb_comments.asp?id=1x6682">Add Comment</button>
<div id="myModal" class="reveal-modal" data-reveal aria-labelledby="modalTitle" aria-hidden="true" role="dialog">
</div>
<style type="text/css">
.ForumPostBodyArea
{
	width: 100%;
	vertical-align: top;
	overflow: auto;
}
</style>
<br /><br /><br />
</div>
</div>
<div class="large-3 hide-for-print columns">
<br />
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="_gaq.push(['_trackEvent', 'Scripts', 'Click', 'Right']);" target="_blank"><img src="/images/download-index-scripts-1.png" alt="download"></a></div>
<br /><br />

<div align="center">
<div id='div-gpt-ad-1388505177750-0' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-0'); });
	</script>
</div>
</div><br /><br /><br />
<div style="padding:2px; background-color:#FFFFFF; ">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Recommended Reading</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6682', '6667']);" href="/sqlservertip/6667/branching-and-merging-strategy-in-git-for-ssis-projects/">Branching and Merging Strategy in Git for SSIS Projects</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6682', '2971']);" href="/sqlservertip/2971/creating-a-visual-studio-database-project-for-an-existing-sql-server-database/">Creating a Visual Studio Database Project for an existing SQL Server Database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6682', '5740']);" href="/sqlservertip/5740/getting-started-with-github-for-sql-server-developers/">Getting Started with GitHub for SQL Server Developers</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6682', '5985']);" href="/sqlservertip/5985/continuous-database-deployments-with-azure-devops/">Continuous database deployments with Azure DevOps</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6682', '6510']);" href="/sqlservertip/6510/using-azure-devops-ci-cd-to-deploy-azure-data-factory-environments/">Using Azure DevOps CI CD to Deploy Azure Data Factory Environments</a><br><br>
</div>
</div>
<br><br><br><br>

<div id="sticky" align="center">
<div id='div-gpt-ad-1388505177750-2' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-2'); });
	</script>
</div>
</div><br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-1' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-1'); });
	</script>
</div>
</div> <br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-3' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-3'); });
	</script>
</div>
</div> <br /><br /><br />
<div id="sticky-anchor"></div>
<div align="center">
<script language="Javascript">
	function ValidateEmail(inputText)
	{
	
		if (document.optin.consent.checked == false) {
		     alert("Please agree to terms by ticking check box.");
		     return false;
	            }	
	   
		var mailformat = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
		if(inputText.value.match(mailformat))
		{
			document.optin.ea.focus();
			return true;
		}
		else
		{
			alert("You have entered an invalid email address!");
			document.optin.ea.focus();
			return false;
		}
	}

	</script>
<div id="sticky2">
<div id="search-div" style="height:300px; width:300px">
<div id="signup-div">
<div style="text-align: center;"><a href="/get-free-sql-server-tips/?ref=LeftGFSTSlant"><img alt="get free sql tips" border="0" src="/images/GetFreeSQLTips_black_box.png"></a></div>
<form action="/get-free-sql-server-tips/" method="post" name="optin" onsubmit="return ValidateEmail(document.optin.ea)">
<input name="URL" type="hidden" value="leftform" />
<input name="ReferralURL" type="hidden" value="" />
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-10 columns">
<input size="25" type="text" onblur="if (this.value=='') this.value=this.defaultValue" onclick="if (this.defaultValue==this.value) this.value=''" value="enter business email" name="ea">
</div>
<div class="small-2 columns">
<input type="submit" name="Button1" value="Join" />
</div>
</div>
</div>
</div>
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-1 columns">
<input type="checkbox" name="consent" value="1">
</div>
<div class="small-11 columns">
<a href="/privacy/" target="_blank"><img src="/images/mssqltips-agree-terms.png" alt="agree to terms"></a>
</div>
</div>
</div>
</div>
<br /><br />
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="sticky-anchor-2"></div>
<footer class="row hide-for-print">
<hr />
<ul class="small-block-grid-3 large-block-grid-6">
<li>
<h3><span style="color:#3B6D93">Follow</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=GetFooterMenu">Get Free SQL Tips</a></li>
<li><a rel="noopener" href="https://twitter.com/mssqltips" target="_blank">Twitter</a></li>
<li><a rel="noopener" href="https://www.linkedin.com/groups/2320891/" target="_blank">LinkedIn</a></li>
<li><a rel="noopener" href="https://www.facebook.com/mssqltips/" target="_blank">Facebook</a></li>
<li><a rel="noopener" href="https://www.pinterest.com/mssqltips/" target="_blank">Pinterest</a></li>
<li><a rel="noopener" href="https://feeds.feedburner.com/MSSQLTips-LatestSqlServerTips" target="_blank">RSS</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Learning</span></h3>
<ul>
<li><a href="/sql-server-dba-resources/">DBAs</a></li>
<li><a href="/sql-server-developer-resources/">Developers</a></li>
<li><a href="/sql-server-business-intelligence-resources/">BI Professionals</a></li>
<li><a href="/sql-server-professional-development-resources/">Careers</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Resources</span></h3>
<ul>
<li><a href="/sql-server-tutorials/">Tutorials</a></li>
<li><a href="/sql-server-webcasts/">Webcasts</a></li>
<li><a href="/sql-server-whitepapers/">Whitepapers</a></li>
<li><a href="/sql-server-tools/">Tools</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Search</span></h3>
<ul>
<li><a href="/sql-server-categories/">Tip Categories</a></li>
<li><a href="/search-tip-id/">Search By TipID</a></li>
<li><a href="/sql-server-mssqltips-authors/">Authors</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Community</span></h3>
<ul>
<li><a href="/learn-more-about-mssqltips/">First Timer?</a></li>
<li><a href="/mssqltips-community/1/">Pictures</a></li>
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/sql-server-event-list/">Event Calendar</a></li>
<li><a href="/sql-server-user-groups/">User Groups</a></li>
<li><a href="/mssqltips-author-of-year/">Author of the Year</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">More Info</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=JoinFooterMenu">Join</a></li>
<li><a href="/about/">About</a></li>
<li><a href="/copyright/">Copyright</a></li>
<li><a href="/privacy/">Privacy</a></li>
<li><a href="/disclaimer/">Disclaimer</a></li>
<li><a href="/feedback/">Feedback</a></li>
<li><a href="/advertise/">Advertise</a></li>
</ul>
</li>
</ul>
<hr />
<div class="row">
<div class="large-12 columns text-center">
<p>Copyright (c) 2006-2021 <a href="https://www.edgewoodsolutions.com">Edgewood Solutions, LLC</a> All rights reserved<br />
<small>Some names and products listed are the registered trademarks of their respective owners.</small></p>
</div>
</div>
</footer>

<style type="text/css">
#slideboxtop{
    width:100%;
    height:50px;
    padding:0px;
    background-color:#FFFFFF;      
    border-bottom:1px solid #000000;
    position:fixed;
    top: -350px;
	-moz-box-shadow:-2px 0px 5px #aaa;
	-webkit-box-shadow:-2px 0px 5px #aaa;
/* 	box-shadow:-2px 0px 5px #aaa;    */
}
</style>
<div class="hide-for-small hide-for-medium hide-for-print">
<div id="slideboxtop" style="z-index:1;">
<div style="text-align:center">
<div w3-include-html="/Site-Sponsorship/site-sponsorship.asp"></div>
</div>
</div>
</div>
<script src="/js/vendor/jquery.min.js"></script>
<script src="/js/foundation/foundation.combined.js"></script>
<script type="text/javascript">
var articleLength = $("article").find("p").length;

 

</script>
<script>
    $(document).foundation();
</script>
<script type="text/javascript" src="/css/prettify.combined.js"></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function(){
		if  ($(window).scrollTop() > 250)
			$('#slideboxtop').animate({'top':'0px'});
		else
			$('#slideboxtop').stop(true).animate({'top':'-250px'});
	});
});
</script>

<style type="text/css">
#sticky {
    padding: 0ex;
    background-color: #fff;
}

#sticky.stick {
    margin-top: 60px !important;
    position: fixed;
    top: 0;
    z-index: 1;
}

#sticky2.stick {
    margin-top: 360px !important;
    position: fixed;
    top: 0;
    z-index: 1;
}
#sticky-outline {
    padding: 0ex;
    width: 100%;
    background-color: #fff;
}

#sticky-outline.stick {
    margin-top: 45px !important;
    position: fixed;
    top: 0;
    z-index: 1;
}

.fullWidth {
    width: 100%;
    margin-left: auto;
    margin-right: auto;
    max-width: 100%;
}
</style>
<script type="text/javascript">
function sticky_relocate() {
    var window_top = $(window).scrollTop();
	
    var div_top = $('#sticky-anchor').offset().top;
	var div_bottom = $('#sticky-anchor-2').offset().top - 600;

	var div_top2 = $('#sticky-anchor-outline').offset().top;
	
    var window_width = $(window).width();
    var window_height = $(window).height();
    
	if (window_top > div_top && window_width > 1100 && window_height > 400 && window_top < div_bottom ) {
        $('#sticky').addClass('stick');
		$('#sticky2').addClass('stick');
        $('#sticky-anchor').height($('#sticky').outerHeight());
    } else {
        $('#sticky').removeClass('stick');
		$('#sticky2').removeClass('stick');
        $('#sticky-anchor').height(0);
    }
	if (window_top > div_top2 ) {
        $('#sticky-outline').addClass('stick');
    } else {
        $('#sticky-outline').removeClass('stick');
    }	
		
}

$(function() {
    $(window).scroll(sticky_relocate);
    sticky_relocate();
});

</script>
<script>
function includeHTML() {
  var z, i, elmnt, file, xhttp;
  /*loop through a collection of all HTML elements:*/
  z = document.getElementsByTagName("*");
  for (i = 0; i < z.length; i++) {
    elmnt = z[i];
    /*search for elements with a certain atrribute:*/
    file = elmnt.getAttribute("w3-include-html");
    if (file) {
      /*make an HTTP request using the attribute value as the file name:*/
      xhttp = new XMLHttpRequest();
      xhttp.onreadystatechange = function() {
        if (this.readyState == 4) {
          if (this.status == 200) {elmnt.innerHTML = this.responseText;}
          if (this.status == 404) {elmnt.innerHTML = "Page not found.";}
          /*remove the attribute, and call this function once more:*/
          elmnt.removeAttribute("w3-include-html");
          includeHTML();
        }
      }      
      xhttp.open("GET", file, true);
      xhttp.send();
      /*exit the function:*/
      return;
    }
  }
};
</script>
<script>
includeHTML();
</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-910745-2']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
</body>
</html>
