<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta http-equiv="Content-Language" content="en-us" />
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

<link rel="SHORTCUT ICON" href="/favicon.ico" />
<meta content="width=device-width, initial-scale=1.0" name="viewport" />
<title>Improve Power BI Performance with Horizontal Filtering</title>
<meta name="description" content="In this third part of this Power BI optimization series we look at how horizontal filtering and other changes can improve overall performance." />
<link rel="canonical" href="https://www.mssqltips.com/sqlservertip/6552/improve-power-bi-performance-with-horizontal-filtering/" />
<link rel="stylesheet" href="/css/foundation-minimized.css">
<link rel="stylesheet" href="/css/app.css">
<script>/*! loadCSS. [c]2017 Filament Group, Inc. MIT License */!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mssqltips.com/sqlservertip/6552/improve-power-bi-performance-with-horizontal-filtering/"
  },
  "headline": "Improve Power BI Performance with Horizontal Filtering",
  "image": [
  
    "https://www.mssqltips.com/images_newsletter/6552_NewsletterImage.png"
  
   ],  
  "datePublished": "2020-09-09T00:00:00+05:00",
  "dateModified": "2020-09-09T00:00:00+05:00",
  "author": {
    "@type": "Person",
    "name": "Kenneth A. Omorodion"
  },
   "publisher": {
    "@type": "Organization",
    "name": "MSSQLTips",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.mssqltips.com/images/mslogo_113x60.png"
    }
  },
  "description": "In this third part of this Power BI optimization series we look at how horizontal filtering and other changes can improve overall performance."
}
</script>
<meta property="og:url" content="https://www.mssqltips.com/sqlservertip/6552/improve-power-bi-performance-with-horizontal-filtering/" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Improve Power BI Performance with Horizontal Filtering" />
<meta property="og:description" content="In this third part of this Power BI optimization series we look at how horizontal filtering and other changes can improve overall performance." />
<meta property="og:image" content="https://www.mssqltips.com/images_newsletter/6552_NewsletterImage.png" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mssqltips">
<meta name="twitter:creator" content="@mssqltips">
<meta name="twitter:title" content="Improve Power BI Performance with Horizontal Filtering">
<meta name="twitter:description" content="In this third part of this Power BI optimization series we look at how horizontal filtering and other changes can improve overall performance.">
<meta name="twitter:image" content="https://www.mssqltips.com/images_newsletter/6552_NewsletterImage.png">
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
 
window.googletag = window.googletag || {cmd: []};

googletag.cmd.push(function() {

   var mapping = googletag.sizeMapping().
   addSize([100, 100], []).
   addSize([320, 400], []).
   addSize([320, 700], []).
   addSize([750, 200],  [[728, 90],[300,250],[160,300],[300,600],[170,90]]).
   addSize([1050, 200], [[728, 90],[300,250],[160,300],[300,600],[170,90]]).build();

   var mapping728 = googletag.sizeMapping()
     .addSize([750, 200], [728, 90])
     .addSize([0, 0], [])
     .build();
   var mapping300 = googletag.sizeMapping()
     .addSize([640, 400], [300, 250])
     .addSize([0, 0], [])
     .build();
   var mapping600 = googletag.sizeMapping()
     .addSize([640, 600], [[160,600],[300,600]])
     .addSize([0, 0], [])
     .build();
   var mapping170 = googletag.sizeMapping()
     .addSize([640, 400], [170,90])
     .addSize([0, 0], [])
     .build();   
   
   
 
   googletag.defineSlot('/53998264/160x600-Primary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-0').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/160x600-Secondary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-1').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Primary', [300, 250], 'div-gpt-ad-1388505177750-2').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Secondary', [300, 250], 'div-gpt-ad-1388505177750-3').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Third', [300, 250], 'div-gpt-ad-1442415667485-0').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/728x90-Primary', [728, 90], 'ad-slot-leader').defineSizeMapping(mapping728).addService(googletag.pubads()); 
   googletag.defineSlot('/53998264/170x90-pos1', [170, 90], 'div-gpt-ad-1481919244109-0').defineSizeMapping(mapping170).addService(googletag.pubads());
   googletag.defineSlot('/53998264/170x90-pos2', [170, 90], 'div-gpt-ad-1481919244109-1').defineSizeMapping(mapping170).addService(googletag.pubads());
   googletag.defineSlot('/53998264/170x90-pos3', [170, 90], 'div-gpt-ad-1481919244109-2').defineSizeMapping(mapping170).addService(googletag.pubads());
   googletag.defineSlot('/53998264/170x90-pos4', [170, 90], 'div-gpt-ad-1481919244109-3').defineSizeMapping(mapping170).addService(googletag.pubads());



   googletag.pubads().enableLazyLoad();
   // googletag.pubads().disableInitialLoad();
   googletag.pubads().collapseEmptyDivs();
   googletag.enableServices();
});

</script>
</head>
<body onload="PR.prettyPrint()" style="background-color:white;">
<a name="top"></a>
<div class="sticky">
<nav class="top-bar" data-topbar role="navigation" ">
<ul class="title-area">
<li class="name">
<a href="https://www.mssqltips.com/"><img alt="mssqltips logo" src="/images/mslogo_bw_89x45-2.png"></a>
</li>

<li class="toggle-topbar menu-icon"><a href="#"><span>Menu</span></a></li>
</ul>
<section class="top-bar-section">

<ul class="right">
<li class="has-dropdown"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sql-server-tutorials/">Beginner</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertip/1948/what-is-sql-server/">What is SQL Server?</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertip/6422/sql-server-concepts/">SQL Server Concepts</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertip/6429/sql-server-download-quick-links/">SQL Server Download Links</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertutorial/3700/my-first-sql-server-business-intelligence-project-tutorial/">My First BI Project </a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sqlservertip/2677/sql-server-career-planning/">SQL Server Career Plan</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'beginner', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sql-server-tutorials/">Tutorials</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedures</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/9131/sql-server-index-tutorial-overview/">Indexing</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tutorial', 'click']);" href="/sql-server-tutorials/">All Tutorials</a></li>
</ul>
</li>
<li class="has-dropdown"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-dba-resources/">DBA</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/60/database-administration/">Database Administration</a></li>
<li class="has-dropdown"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="#">Perfomance</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/54/monitoring/">Monitoring</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sqlservertutorial/9194/sql-server-extended-events-tutorial/">Extended Events</a></li>
</ul>
</li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/81/powershell/">PowerShell</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/27/sql-server-agent/">SQL Server Agent</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sqlservertutorial/9268/sql-server-management-studio-overview-ssms/">Management Studio</a></li>
<li class="has-dropdown"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="#">High Availability</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/161/backup/">Backup</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/202/restore/">Restore</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-tip-category/143/availability-groups/">Availability Groups</a></li>
</ul>
</li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'dba', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown">
<a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sql-server-developer-resources/">T-SQL</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedure Tutorial</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1667/sql-server-join-example/">SQL Server Join Example</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">CROSS APPLY + OUTER APPLY</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1599/cursor-in-sql-server/">Cursor in SQL Server</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/4054/creating-a-date-dimension-or-calendar-table-in-sql-server/">Calendar Table</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sqlservertip/5993/sql-server-date-and-time-functions-with-examples/">Date and Time Functions</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'tsql', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-business-intelligence-resources/">Business Intelligence</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-tip-category/211/power-bi/">Power BI</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-business-intelligence-resources/">Azure Data Factory</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/4200/sql-server-analysis-services-2016-ssas-tutorial/">Analysis Services</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/9073/sql-server-2017-and-python-basics/">Python</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sqlservertutorial/9040/getting-started-with-r-in-sql-server/">R</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'bi', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="_gaq.push(['_trackEvent', 'hmenu', 'cloud', 'click']);" href="#">Cloud</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'cloud', 'click']);" href="/sql-server-tip-category/205/amazon-aws/">AWS</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'cloud', 'click']);" href="/sql-server-tip-category/87/azure/">Azure</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'cloud', 'click']);" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium hide-for-small">
<a onclick="_gaq.push(['_trackEvent', 'hmenu', 'showcase', 'click']);" href="#">Tools</a>
<ul class="dropdown">
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'showcase', 'click']);" href="/sqlservertip/6297/melissa-data-quality-solutions-for-ssis/?ps=melissa">Data Quality Tools</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'showcase', 'click']);" href="/sqlservertip/6310/solarwinds-database-performance-analyzer-for-sql-server/?ps=solarwinds-dpa">Database Performance Analyzer</a></li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'showcase', 'click']);" href="/sqlservertip/6367/quest-foglight-for-databases/?ps=quest-foglight">Foglight for SQL Server</a></li>
</ul>
</li>
<li><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'join', 'click']);" href="/get-free-sql-server-tips/?ref=JoinHeaderMenu"><span style="color:red;">Join</span></a></li>
<li class="hide-for-large"><a onclick="_gaq.push(['_trackEvent', 'hmenu', 'search', 'click']);" href="/search/">Search</a></li>
<li class="hide-for-medium hide-for-small">
<form action="/search/" method="get">
<div class="large-7 columns">
<input type="text" placeholder="Search MSSQLTips" name="q">
</div>
<div class="large-5 columns">
<input class="button round" type="submit" value="Search" name="B1">
</div>
</form>
</li>
</ul>
</section>
</nav>
</div>
<div class="row">
<div class="entry-content large-9 columns" role="content"> <h1>Improve Power BI Performance with Horizontal Filtering</h1>
<div id="sticky-anchor-outline"></div>
<div align="center" class="hide-for-print">
<div id="ad-slot-leader" style="width:728px; height:90px;">
<script type='text/javascript'>
			 googletag.cmd.push(function() {googletag.display('ad-slot-leader'); });
		   </script>
</div>
</div>
<br />
<article>
<p>By: <a href="/sqlserverauthor/376/kenneth-a-omorodion/" rel="author" title="author profile for Kenneth A. Omorodion">Kenneth A. Omorodion</a> &nbsp;&nbsp;|&nbsp;&nbsp; Updated: 2020-09-09 &nbsp;&nbsp;|&nbsp;&nbsp; <a href="#comments" title="read and post comments">Comments</a> &nbsp;&nbsp;|&nbsp;&nbsp; Related: <a href="/sqlservertip/6518/power-bi-performance-optimization-tips/">1</a> | <a href="/sqlservertip/6517/improve-power-bi-performance-with-auto-datetime-and-dax-variables/">2</a> | <a href="/sqlservertip/6552/improve-power-bi-performance-with-horizontal-filtering/">3</a> | <a href="/sql-server-developer-resources/">More</a> > <a href="/sql-server-tip-category/211/power-bi/">Power BI</a></p>
<br />
<h5>Problem</h5>
<p>In
<a href="/sqlservertip/6518/power-bi-performance-optimization-tips/" target="_blank">
Part 1</a> and
<a href="/sqlservertip/6517/improve-power-bi-performance-with-auto-datetime-and-dax-variables/" target="_blank">
Part 2</a> of this series, I demonstrated how implementing
Vertical Filtering, preference for custom columns created in Power Query, disabling
"Auto
date/time" in data load options settings&#xa0;and using more variables
in DAX measures calculations could help improve performance of Power BI reports.
</p>
<p>In this third part of the series, I will demonstrate how removing unnecessary rows
or <em>Horizontal Filtering</em> and the disabling of Power Query query load for
non-required tables could be used to optimize Power BI report performance. I would
encourage you to read Part 1 and Part 2 of this series to ensure you understand all
discussed options available for performance optimization in Power BI.</p>
<h5>Solution</h5>
<p>This part of the series will focus on what steps to take to configure performance
optimization using <em>Horizontal Filtering</em> and the disabling of Power Query
query load for non-required tables.</p>
<h2>Power BI Horizontal Filtering</h2>
<p>This is particularly useful where the model size is rather large and one
would not be able to efficiently develop visuals or create calculations in Power
BI without considerable impact on the speed of rendering of visuals and having very
slow query performance. Horizontal Filtering is another word for limiting the number
of rows in a dataset, thereby improving model performance.</p>
<p>It is important to note that Horizontal filtering could be achieved by loading
models with filtered rowsets either by <strong>Filtering by time</strong> or
<strong>Filtering by entity</strong>. However, for the purpose of this tip, I am
concentrating on the former, which helps in performance optimization of slow models
in Power BI. You can read more on Horizontal Filtering methods
<a href="https://docs.microsoft.com/en-us/power-bi/guidance/import-modeling-data-reduction" target="_blank">
here</a>.</p>
<p>Microsoft suggests that you do not automatically load all available history data,
apart from cases where this is a known reporting requirement. What we are trying
to achieve with this technique is ways to only load a subset of the history data
into the data model thereby considerably reducing the amount of data we are working
with at any particular time, thus improving speed of query refreshes and visual
rendering while creating visuals. Optimally, when we finish creating the visuals
and published to Power BI service, we can readjust the dataset to load full history
data. This process is summarized this below.</p>
<ol>
<li>Import the dataset</li>
<li>Create a parameter for the Order Date column</li>
<li>Apply the parameter to filter the Order Date column using the Custom option
</li>
<li>Load the filtered dataset into the data model</li>
<li>Create visuals as needed with the reduced/filtered dataset</li>
<li>Save and Publish to Power BI Service workspace</li>
<li>Go to Power BI Service and configure gateway (if required), Configure parameter
settings, and configure schedule refresh (as needed)</li>
<li>Manually refresh the dataset</li>
</ol>
<h2>Step 1: Import the dataset</h2>
<p>Okay, we know what we want to achieve now and what steps to follow to achieve
it, so let's see how this is done. </p>
<p>I am using the <strong><em>SalesOrderHeader</em></strong>
dataset imported from AdventureworksDB2014. This is just for illustration purposes;
any other dataset can be adapted for this technique. The three diagrams below show
how I have imported the dataset into Power BI Desktop.</p>
<div class="imageborder">
<img alt="Screenshot showing connection to SQL Server database" src="/tipimages2/6552_performance-optimization-power-bi.001.png" />
</div>
<p>Then select the table you require as shown below.</p>
<div class="imageborder">
<img alt="Screenshot showing connection to SQL Server database table" src="/tipimages2/6552_performance-optimization-power-bi.002.png" />
</div>
<p>The table is now in Power Query Editor in Power BI Desktop as seen below.</p>
<div class="imageborder">
<img alt="Screenshot showing source table loaded into Power Query" src="/tipimages2/6552_performance-optimization-power-bi.003.png" />
</div>
<h2>Step 2: Create a parameter for the Order Date column</h2>
<p>Next step is to create a parameter to hold a date value for use in filtering.</p>
<p>The diagram below shows how to configure the parameter. Just give the parameter
a name, I called mine <strong><em>RowsReturned. </em></strong>You can give a description
for it but its optional. Then you need to select a data type, so I selected "Date/Time"
since I am planning to filter on a date column. For "Suggested Values"
choose "Any value". For "Current Value" I just choose a
date value existing in the OrderDate column of the dataset. Learn more about
<a href="https://powerbi.microsoft.com/en-us/blog/deep-dive-into-query-parameters-and-power-bi-templates/" target="_blank">creating
Query Parameters
here</a>.</p>
<div class="imageborder">
<img alt="Screenshot showing how to create parameters for date value" src="/tipimages2/6552_performance-optimization-power-bi.004.png" />
</div>
<p>After creating the parameter, it should look like the diagram below.</p>
<div class="imageborder">
<img alt="Screenshot showing Current value of parameter created" src="/tipimages2/6552_performance-optimization-power-bi.005.png" />
</div>
<h2>Step 3: Apply the parameter to filter the Order Date column using the Custom
option</h2>
<p>Now it's time for us to apply the created parameter to the OrderDate column
for filtering. Before doing this, you can quickly check how many rows your dataset
currently has, in my case it was about 31,465 rows before filtering. I have used
the OrderDate column in this tip, you can choose to use any other date column as
required. See the following diagrams for how this is done.</p>
<p>In the diagram below, I have selected the "Custom Filter" option
for configuring the filtering with the parameter created earlier.</p>
<div class="imageborder">
<img alt="Screenshot showing how to configure the date filtering on a date column" src="/tipimages2/6552_performance-optimization-power-bi.006.png" />
</div>
<p>The next diagram below shows the dialog box to enter the filter conditions. So,
I have entered "is after or equal to" on the "Keep rows where OrderDate''&lsquo;.
You can use any other selections like "is before or equal to", this
really depends on your business need. But, for the purpose of this tip, I wanted
to choose a date within my OrderDate values to eradicate chances of issues. Then,
I further selected "Parameter" from the date dropdown. This is the parameter
I created earlier with value of "01/01/2014". Note that I have not entered
anything on the selection box below the top ones, but you can adapt that aspect
to your business need to further provide filtering conditions.</p>
<div class="imageborder">
<img alt="Screenshot showing how to apply the parameter for column filtering" src="/tipimages2/6552_performance-optimization-power-bi.007.png" />
</div>
<h2>Step 4: Load the filtered dataset into the data model</h2>
<p>Next step is to load the already filtered dataset into the data model and verify
number of rows now loaded. Click "Close &amp; Apply" to load the model.
As can be seen in the diagram below, my dataset now has only 11,761 rows (from an
initial 31,465). This can be more efficient when applied to larger datasets with
millions of rows drastically reducing the size of the data to work
with.</p>
<div class="imageborder">
<img alt="Screenshot showing card visual of total number of rows after filtering" src="/tipimages2/6552_performance-optimization-power-bi.008.png" />
</div>
<h2>Step 5: Create visuals as needed with the filtered dataset</h2>
<p>For this tip, I am not going to dwell much on how to create visuals, but I have
created a column chart showing total customers by year. This currently is showing
only 2014 for year in accordance with our filter condition applied earlier. See
diagram below.</p>
<div class="imageborder">
<img alt="Screenshot showing card visual and Column visual of total number of rows after filtering" src="/tipimages2/6552_performance-optimization-power-bi.009.png" />
</div>
<h2>Step 6: Save and Publish to Power BI Service</h2>
<p>Next is to save the work and publish the report/dataset to Power BI Service workspace
as seen in the diagram below.</p>
<div class="imageborder">
<img alt="Screenshot showing how to save and publish the report or dataset to Power BI service" src="/tipimages2/6552_performance-optimization-power-bi.010.png" />
</div>
<h2>Step 7: Configure Power BI gateway,
parameter settings, and schedule refresh</h2>
<p>Next step is to configure the parameter settings in Power BI Service. Before
doing this try to view what is currently showing on the report, it should be exactly
what you have created in Power BI Desktop with only 2014 data in this instance as
shown below.</p>
<div class="imageborder">
<img alt="Screenshot showing card visual and Column chart visual of total number of rows after initial publishing to Power BI service" src="/tipimages2/6552_performance-optimization-power-bi.011.png" />
</div>
<p>Then, let's go configure the Parameter settings so we can override the filtering
and load all history data and get all 31,465 rows again. This is as seen in diagrams
below.</p>
<p>Click on "Datasets &amp; Dataflows". Then, click on "schedule
refresh" icon</p>
<div class="imageborder">
<img alt="Screenshot showing how to navigate to configure parameter settings" src="/tipimages2/6552_performance-optimization-power-bi.012.png" />
</div>
<p>Initially, when you get to the Parameter settings as seen on the diagram below,
it would have the default date applied for filtering (i.e. 2014/01/01).</p>
<div class="imageborder">
<img alt="Screenshot showing initial state of parameter settings" src="/tipimages2/6552_performance-optimization-power-bi.013.png" />
</div>
<p>We need to now change this as far back as when the historical data started. In
this case its 2011 May, but I will just start from 2011/01/01 (this was the reason
we used "is after or equal to" earlier"). This is shown in the diagram
below.</p>
<div class="imageborder">
<img alt="Screenshot showing how to change the date values in the parameter settings" src="/tipimages2/6552_performance-optimization-power-bi.014.png" />
</div>
<p>Next, we need to configure the gateway to recognize the data source, if this
is not already done. You can learn more about how to configure a data source with
an On-Premises data gateway
<a href="https://docs.microsoft.com/en-us/power-bi/connect-data/service-gateway-data-sources" target="_blank">
here</a>.. You might also need to configure the schedule refresh to ensure your dataset
refresh without issues later. See one of my tips which
<a href="/sqlservertip/6423/power-bi-paginated-reports-with-excel-source/" target="_blank">
demonstrate how to configure schedule refresh</a>.</p>
<h2>Step 8: Manually refresh the dataset</h2>
<p>After these, the next step is to go back to "Datasets &amp; Dataflows" as
seen below to carry out a one-off manual refresh of the dataset.</p>
<div class="imageborder">
<img alt="Screenshot showing how to navigate to configure initial manual refresh" src="/tipimages2/6552_performance-optimization-power-bi.015.png" />
</div>
<p>After this go back to the report view and verify the number of rows that is now
returned in the visuals. If your visuals are still the same, try to refresh the
Power BI service page, you should be able to now see that the number of rows is
31,465 and that there is now more Years than just 2014 as seen below.
</p>
<div class="imageborder">
<img alt="Screenshot showing total number of rows returned after configuring parameter settings" src="/tipimages2/6552_performance-optimization-power-bi.016.png" />
</div>
<h2>Disabling of Power Query query load for non-required tables</h2>
<p>Every single query loaded into the
data model leads to memory consumption. However, as we have seen in most of the
techniques in this optimization series, the main asset has largely been memory conservation.
The higher the memory consumed, the higher the likelihood of negative performance
impact on the model. Thus, it is
<a href="https://docs.microsoft.com/en-us/power-bi/guidance/import-modeling-data-reduction#disable-power-query-query-load" target="_blank">good practice to disable un-required queries to improve performance</a>.</p>
<p>It is also important to understand
that when a query is disabled to load into the data model, it is only not loaded
into the memory, but the query still refreshes as usual. To demonstrate this, I
have imported two datasets holding Employees details for 2008 and 2009. Both tables
have the same columns but different number of rows. So, we can append the tables.
To ensure this tip is brief enough, I will not go into detail on how I have imported
the tables or how to append datasets. However, I will demonstrate how if both the
appended dataset and the individual (2008 &amp; 2009) datasets can consume memory
if all is loaded to the data model.</p>
<p>The diagram below shows the three
datasets (the 2008, 2009 and the appended dataset known as Employees).</p>
<div class="imageborder">
<img alt="Screenshot showing sample datasets used in demo" src="/tipimages2/6552_performance-optimization-power-bi.017.png" />
</div>
<p>I will now click on "Close &amp; Apply" to load all datasets to the
memory so we can see the memory consumed as seen in the diagram below.</p>
<div class="imageborder">
<img alt="Screenshot showing initial size of model after loading all queries" src="/tipimages2/6552_performance-optimization-power-bi.018.png" />
</div>
<p>As can be seen in the diagram above,
the current memory used up by the data model is about 232KB (but imagine if this
was a very large model). Then let us go back to Power Query Editor and disable the
load of the individual datasets (Emp_2008 &amp; Emp_2009) so we can tell if the
memory usage has increased or decreased. So, as seen in the diagram below, we need
to right click on both datasets individually (Emp_2008 &amp; Emp_2009) and un-check
the checked box at the front. This would ensure the data load is disabled for each
dataset leaving us with only the appended (Employees) dataset to be loaded into
memory. Note you will see the font type of the load disabled datasets change to
italics.</p>
<div class="imageborder">
<img alt="Screenshot showing how to deactivate or disable load for one of the queries" src="/tipimages2/6552_performance-optimization-power-bi.019.png" />
</div>
<p>Then click "Close &amp; Apply"
to load the Employees table only to the data model. After this we can verify
that we have saved memory by disabling the load of two datasets not required in
the model individually as seen in the diagram below. The memory consumption is now
about 196KB from the initial 232KB (a difference of about 36KB). Again, imagine
if this were a massive model, this could have made a difference.</p>
<div class="imageborder">
<img alt="Screenshot showing final size of model after disabling some queries" src="/tipimages2/6552_performance-optimization-power-bi.020.png" />
</div>
<h5>Next Steps</h5>
<ul>
<li>See the
<a href="/sqlservertip/6518/power-bi-performance-optimization-tips--part-1/" target="_blank">first part of this series of improving performance of Power BI model</a></li>
<li>See the
<a href="/sqlservertip/6517/performance-optimization-in-power-bi-part-2/" target="_blank">second part of this series of improving performance of Power BI
model</a></li>
<li>Try this tip out in your own data as needed</li>
</ul>
<br /><br />
Last Updated: 2020-09-09
<br /><br /><br />
<div class="row">
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="_gaq.push(['_trackEvent', 'Scripts', 'Click', 'BotTip']);" target="_blank"><img border="0" src="/images/Free-Download_20190509.png" alt="get scripts" width="300" height="150"></a></div>
<br />
</div>
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/sql-server-tip-category/211/power-bi/" onclick="_gaq.push(['_trackEvent', 'NextTip', 'Click', 'YellowArrow']);"><img border="0" src="/images/nav_nexttip_clickhere_rev1.png" alt="next tip button" width="300" height="150"></a></div>
<br />
</div>
</div>
<br /><br />
<h5>About the author</h5>
<div class="row">
<div class="large-6 columns">
<a href="/sqlserverauthor/376/kenneth-a-omorodion/"><img style="float: left; padding: 0px 3px 0px 0px;" alt="MSSQLTips author Kenneth A. Omorodion" height="90" src="/images/Kenneth-Omorodion.png" width="60" /></a>
Kenneth A. Omorodion is a Data Analytics and BI professional mostly in Microsoft BI stack of tools. He is a BI Consultant with Avanade.
<br /><br /><b><a href="/sqlserverauthor/376/kenneth-a-omorodion/">View all my tips</a></b>
</div>
<div class="large-6 columns">
<b>Related Resources</b><br />
<ul>
<li><a href="/sqlservertip/6518/power-bi-performance-optimization-tips/" title="Power BI Performance Optimization Tips">Power BI Performance Optimization Tips...</a></li><li><a href="/sqlservertip/6517/improve-power-bi-performance-with-auto-datetime-and-dax-variables/" title="Improve Power BI Performance with Auto Date/Time and DAX Variables">Improve Power BI Performance with Auto Date/Time a...</a></li><li><a href="/sqlservertip/6552/improve-power-bi-performance-with-horizontal-filtering/" title="Improve Power BI Performance with Horizontal Filtering">Improve Power BI Performance with Horizontal Filte...</a></li><li><a href="/sql-server-developer-resources/">More Database Developer Tips...</a></li>
</ul>
</div>
</div>
<br /><br />
<a name="comments"></a>
<div class="row hide-for-small hide-for-print">
<div class="large-12 columns">
<a href="/contribute/">Become a paid author</a>
</div>
<hr />
</div>
<br /><br />
</article>
<div class="row">
</div>
<div class="hide-for-print hide-for-small">
<div class="row">
<div class="large-3 medium-3 hide-for-print columns" align="center">

<div id='div-gpt-ad-1481919244109-0' style='height:90px; width:170px;'>
<script>
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1481919244109-0'); });
		</script>
</div>
</div>
<div class="large-3 medium-3 hide-for-print columns" align="center">

<div id='div-gpt-ad-1481919244109-1' style='height:90px; width:170px;'>
<script>
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1481919244109-1'); });
		</script>
</div>
</div>
<div class="large-3 medium-3 hide-for-print columns" align="center">

<div id='div-gpt-ad-1481919244109-2' style='height:90px; width:170px;'>
<script>
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1481919244109-2'); });
		</script>
</div>
</div>
<div class="large-3 medium-3 hide-for-print columns" align="center">

<div id='div-gpt-ad-1481919244109-3' style='height:90px; width:170px;'>
<script>
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1481919244109-3'); });
		</script>
</div>
</div>
</div>
</div>
<div class="hide-for-print">
<hr>
<h2>Comments For This Article</h2>
<button class="button round" data-reveal-id="myModal" data-reveal-ajax="/zurb_comments.asp?id=1x6552">Add Comment</button>
<div id="myModal" class="reveal-modal" data-reveal aria-labelledby="modalTitle" aria-hidden="true" role="dialog">
</div>
<style type="text/css">
.ForumPostBodyArea
{
	width: 100%;
	vertical-align: top;
	overflow: auto;
}
</style>
<br /><br /><br />
</div>
</div>
<div class="large-3 hide-for-print columns">
<br />
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="_gaq.push(['_trackEvent', 'Scripts', 'Click', 'Right']);" target="_blank"><img src="/images/download-index-scripts-1.png" alt="download"></a></div>
<br /><br />

<div align="center">
<div id='div-gpt-ad-1388505177750-0' style='min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-0'); });
	</script>
</div>
</div><br /><br /><br />
<div style="padding:2px; background-color:#FFFFFF; ">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Recommended Reading</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6552', '6517']);" href="/sqlservertip/6517/improve-power-bi-performance-with-auto-datetime-and-dax-variables/">Improve Power BI Performance with Auto Date/Time and DAX Variables</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6552', '6518']);" href="/sqlservertip/6518/power-bi-performance-optimization-tips/">Power BI Performance Optimization Tips</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6552', '4076']);" href="/sqlservertip/4076/power-bi-histogram-example-using-dax/">Power BI Histogram Example using DAX</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6552', '4621']);" href="/sqlservertip/4621/using-power-bi-with-json-data-sources-and-files/">Using Power BI with JSON Data Sources and Files</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="_gaq.push(['_trackEvent', 'Recommended', '6552', '4841']);" href="/sqlservertip/4841/calculating-mtd-qtd-ytd-running-and-cumulative-total-in-power-bi/">Calculating MTD, QTD, YTD, Running and Cumulative Total in Power BI</a><br><br>
</div>
</div>
<br><br><br><br>

<div align="center">
<div id='div-gpt-ad-1388505177750-1' style='min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-1'); });
	</script>
</div>
</div> <br /><br /><br />
<div id="sticky-anchor"></div>
<div align="center">
<script language="Javascript">
	function ValidateEmail(inputText)
	{
	
		if (document.optin.consent.checked == false) {
		     alert("Please agree to terms by ticking check box.");
		     return false;
	            }	
	   
		var mailformat = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
		if(inputText.value.match(mailformat))
		{
			document.optin.ea.focus();
			return true;
		}
		else
		{
			alert("You have entered an invalid email address!");
			document.optin.ea.focus();
			return false;
		}
	}

	</script>
<div id="sticky" align="center">
<div id="search-div" style="height:300px;">
<div id="signup-div">
<div style="text-align: center;"><a href="/get-free-sql-server-tips/?ref=LeftGFSTSlant"><img alt="get free sql tips" border="0" src="/images/GetFreeSQLTips_black_box.png"></a></div>
<form action="/get-free-sql-server-tips/" method="post" name="optin" onsubmit="return ValidateEmail(document.optin.ea)">
<input name="URL" type="hidden" value="leftform" />
<input name="ReferralURL" type="hidden" value="" />
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-10 columns">
<input size="25" type="text" onblur="if (this.value=='') this.value=this.defaultValue" onclick="if (this.defaultValue==this.value) this.value=''" value="enter business email" name="ea">
</div>
<div class="small-2 columns">
<input type="submit" name="Button1" value="Join" />
</div>
</div>
</div>
</div>
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-1 columns">
<input type="checkbox" name="consent" value="1">
</div>
<div class="small-11 columns">
<a href="/privacy/" target="_blank"><img src="/images/mssqltips-agree-terms.png" alt="agree to terms"></a>
</div>
</div>
</div>
</div>
<br /><br />
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="sticky-anchor-2"></div>
<footer class="row hide-for-print">
<hr />
<ul class="small-block-grid-3 large-block-grid-6">
<li>
<h3><span style="color:#3B6D93">Follow</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=GetFooterMenu">Get Free SQL Tips</a></li>
<li><a rel="noopener" href="https://twitter.com/mssqltips" target="_blank">Twitter</a></li>
<li><a rel="noopener" href="https://www.linkedin.com/groups/2320891/" target="_blank">LinkedIn</a></li>
<li><a rel="noopener" href="https://www.facebook.com/mssqltips/" target="_blank">Facebook</a></li>
<li><a rel="noopener" href="https://www.pinterest.com/mssqltips/" target="_blank">Pinterest</a></li>
<li><a rel="noopener" href="https://feeds.feedburner.com/MSSQLTips-LatestSqlServerTips" target="_blank">RSS</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Learning</span></h3>
<ul>
<li><a href="/sql-server-dba-resources/">DBAs</a></li>
<li><a href="/sql-server-developer-resources/">Developers</a></li>
<li><a href="/sql-server-business-intelligence-resources/">BI Professionals</a></li>
<li><a href="/sql-server-professional-development-resources/">Careers</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Resources</span></h3>
<ul>
<li><a href="/sql-server-tutorials/">Tutorials</a></li>
<li><a href="/sql-server-webcasts/">Webcasts</a></li>
<li><a href="/sql-server-whitepapers/">Whitepapers</a></li>
<li><a href="/sql-server-tools/">Tools</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Search</span></h3>
<ul>
<li><a href="/sql-server-categories/">Tip Categories</a></li>
<li><a href="/search-tip-id/">Search By TipID</a></li>
<li><a href="/sql-server-mssqltips-authors/">Authors</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Community</span></h3>
<ul>
<li><a href="/learn-more-about-mssqltips/">First Timer?</a></li>
<li><a href="/mssqltips-community/1/">Pictures</a></li>
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/sql-server-event-list/">Event Calendar</a></li>
<li><a href="/sql-server-user-groups/">User Groups</a></li>
<li><a href="/mssqltips-author-of-year/">Author of the Year</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">More Info</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=JoinFooterMenu">Join</a></li>
<li><a href="/about/">About</a></li>
<li><a href="/copyright/">Copyright</a></li>
<li><a href="/privacy/">Privacy</a></li>
<li><a href="/disclaimer/">Disclaimer</a></li>
<li><a href="/feedback/">Feedback</a></li>
<li><a href="/advertise/">Advertise</a></li>
</ul>
</li>
</ul>
<hr />
<div class="row">
<div class="large-12 columns text-center">
<p>Copyright (c) 2006-2020 <a href="https://www.edgewoodsolutions.com">Edgewood Solutions, LLC</a> All rights reserved<br />
<small>Some names and products listed are the registered trademarks of their respective owners.</small></p>
</div>
</div>
</footer>

<style type="text/css">
#slideboxtop{
    width:100%;
    height:50px;
    padding:10px;
    background-color:#FFFFFF;      
    border-bottom:1px solid #000000;
    position:fixed;
    top: -350px;
	-moz-box-shadow:-2px 0px 5px #aaa;
	-webkit-box-shadow:-2px 0px 5px #aaa;
/* 	box-shadow:-2px 0px 5px #aaa;    */
}
</style>
<div class="hide-for-small hide-for-medium hide-for-print">
<div id="slideboxtop" style="z-index:1;">
<div style="text-align:center">
<div w3-include-html="/Site-Sponsorship/site-sponsorship.html"></div>
</div>
</div>
</div>
<script src="/js/vendor/jquery.min.js"></script>
<script src="/js/foundation/foundation.combined.js"></script>
<script type="text/javascript">
var articleLength = $("article").find("p").length;


if (articleLength > 6) { 
  $("p:eq( 6 )").after( "<div align='center' class='hide-for-print'><div id='div-gpt-ad-1388505177750-2' style='width:300px; height:250px;'></div></div><br>" );
  var x = document.createElement("script");
  var t = document.createTextNode("googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-2'); });");
  x.appendChild(t);
  document.head.appendChild(x);
  }
  
if (articleLength > 10) { 
  $("p:eq( 10 )").after( "<div align='center' class='hide-for-print'><div id='div-gpt-ad-1388505177750-3' style='width:300px; height:250px;'></div></div><br>" );
  var x = document.createElement("script");
  var t = document.createTextNode("googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-3'); });");
  x.appendChild(t);
  document.head.appendChild(x);
  }
  
if (articleLength > 14) { 
  $("p:eq( 14 )").after( "<div align='center' class='hide-for-print'><div id='div-gpt-ad-1442415667485-0' style='width:300px; height:250px;'></div></div><br>" );
  var x = document.createElement("script");
  var t = document.createTextNode("googletag.cmd.push(function() { googletag.display('div-gpt-ad-1442415667485-0'); });");
  x.appendChild(t);
  document.head.appendChild(x);
  }
 

</script>
<script>
    $(document).foundation();
</script>
<script type="text/javascript" src="/css/prettify.combined.js"></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function(){
		if  ($(window).scrollTop() > 250)
			$('#slideboxtop').animate({'top':'40px'});
		else
			$('#slideboxtop').stop(true).animate({'top':'-250px'});
	});
});
</script>

<style type="text/css">
#sticky {
    padding: 0ex;
    width: 300px;
    background-color: #fff;
}

#sticky.stick {
    margin-top: 100px !important;
    position: fixed;
    top: 0;
    z-index: 1;
}
#sticky-outline {
    padding: 0ex;
    width: 100%;
    background-color: #fff;
}

#sticky-outline.stick {
    margin-top: 45px !important;
    position: fixed;
    top: 0;
    z-index: 1;
}

.fullWidth {
    width: 100%;
    margin-left: auto;
    margin-right: auto;
    max-width: 100%;
}
</style>
<script type="text/javascript">
function sticky_relocate() {
    var window_top = $(window).scrollTop();
	
    var div_top = $('#sticky-anchor').offset().top;
	var div_bottom = $('#sticky-anchor-2').offset().top - 600;

	var div_top2 = $('#sticky-anchor-outline').offset().top;
	
    var window_width = $(window).width();
    var window_height = $(window).height();
    
	if (window_top > div_top && window_width > 1100 && window_height > 400 && window_top < div_bottom ) {
        $('#sticky').addClass('stick');
        $('#sticky-anchor').height($('#sticky').outerHeight());
    } else {
        $('#sticky').removeClass('stick');
        $('#sticky-anchor').height(0);
    }
	if (window_top > div_top2 ) {
        $('#sticky-outline').addClass('stick');
    } else {
        $('#sticky-outline').removeClass('stick');
    }	
		
}

$(function() {
    $(window).scroll(sticky_relocate);
    sticky_relocate();
});

</script>
<script>
function includeHTML() {
  var z, i, elmnt, file, xhttp;
  /*loop through a collection of all HTML elements:*/
  z = document.getElementsByTagName("*");
  for (i = 0; i < z.length; i++) {
    elmnt = z[i];
    /*search for elements with a certain atrribute:*/
    file = elmnt.getAttribute("w3-include-html");
    if (file) {
      /*make an HTTP request using the attribute value as the file name:*/
      xhttp = new XMLHttpRequest();
      xhttp.onreadystatechange = function() {
        if (this.readyState == 4) {
          if (this.status == 200) {elmnt.innerHTML = this.responseText;}
          if (this.status == 404) {elmnt.innerHTML = "Page not found.";}
          /*remove the attribute, and call this function once more:*/
          elmnt.removeAttribute("w3-include-html");
          includeHTML();
        }
      }      
      xhttp.open("GET", file, true);
      xhttp.send();
      /*exit the function:*/
      return;
    }
  }
};
</script>
<script>
includeHTML();
</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-910745-2']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
</body>
</html>
