
<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta http-equiv="Content-Language" content="en-us" />
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

<link rel="SHORTCUT ICON" href="/favicon.ico" />
<meta content="width=device-width, initial-scale=1.0" name="viewport" />
<title>Power BI Download, Install and Get Started</title>
<meta name="description" content="In this article learn how to download, install and get started building your first Power BI report using SQL Server data." />
<link rel="canonical" href="https://www.mssqltips.com/sqlservertip/7300/power-bi-download-install-and-get-started/" />
<link rel="stylesheet" href="/css/foundation-app-combined-min.css">
<script>/*! loadCSS. [c]2017 Filament Group, Inc. MIT License */!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mssqltips.com/sqlservertip/7300/power-bi-download-install-and-get-started/"
  },
  "headline": "Power BI Download, Install and Get Started",
  "image": [
  
    "https://www.mssqltips.com/images_newsletter/7300_NewsletterImage.png"
  
   ],  
  "datePublished": "2022-06-29T00:00:00+05:00",
  "dateModified": "2022-06-29T00:00:00+05:00",
  "author": {
    "@type": "Person",
    "name": "Scott Murray"
  },
   "publisher": {
    "@type": "Organization",
    "name": "MSSQLTips",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.mssqltips.com/images/mslogo_113x60.png"
    }
  },
  "description": "In this article learn how to download, install and get started building your first Power BI report using SQL Server data."
}
</script>
<meta property="og:url" content="https://www.mssqltips.com/sqlservertip/7300/power-bi-download-install-and-get-started/" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Power BI Download, Install and Get Started" />
<meta property="og:description" content="In this article learn how to download, install and get started building your first Power BI report using SQL Server data." />
<meta property="og:image" content="https://www.mssqltips.com/images_newsletter/7300_NewsletterImage.png" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mssqltips">
<meta name="twitter:creator" content="@mssqltips">
<meta name="twitter:title" content="Power BI Download, Install and Get Started">
<meta name="twitter:description" content="In this article learn how to download, install and get started building your first Power BI report using SQL Server data.">
<meta name="twitter:image" content="https://www.mssqltips.com/images_newsletter/7300_NewsletterImage.png">
<script>

var head = document.getElementsByTagName('head')[0];
var js = document.createElement("script");

js.type = "text/javascript";

if (screen.width > 749)
{
    js.src = "https://securepubads.g.doubleclick.net/tag/js/gpt.js";
}
head.appendChild(js);

if (screen.width > 749)
{

!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

apstag.init({
  pubID: '434bb5e4-3704-4b75-b36c-785a444462bd',
  adServer: 'googletag',
  simplerGPT: true,
  schain: {
    complete: 1,
    ver: '1.0',
    nodes: [
      {
        asi: 'theadengine.com',
        sid: '01307',
        hp: 1,
      },
    ],
  },
});

window.googletag = window.googletag || {cmd: []};

googletag.cmd.push(function() {

   var mapping = googletag.sizeMapping().
   addSize([100, 100], []).
   addSize([320, 400], []).
   addSize([320, 700], []).
   addSize([750, 200],  [[728, 90],[300,250],[160,300],[300,600],[170,90]]).
   addSize([1050, 200], [[728, 90],[300,250],[160,300],[300,600],[170,90]]).build();

   var mapping728 = googletag.sizeMapping()
     .addSize([750, 200], [728, 90])
     .addSize([0, 0], [])
     .build();
   var mapping300 = googletag.sizeMapping()
     .addSize([640, 400], [300, 250])
     .addSize([0, 0], [])
     .build();
   var mapping600 = googletag.sizeMapping()
     .addSize([640, 600], [[160,600],[300,600]])
     .addSize([0, 0], [])
     .build();
   var mapping170 = googletag.sizeMapping()
     .addSize([640, 400], [170,90])
     .addSize([0, 0], [])
     .build();   
   
   
 
   googletag.defineSlot('/53998264/160x600-Primary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-0').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/160x600-Secondary', [[160,600],[300,600]], 'div-gpt-ad-1388505177750-1').defineSizeMapping(mapping600).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Primary', [300, 250], 'div-gpt-ad-1388505177750-2').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/300x250-Secondary', [300, 250], 'div-gpt-ad-1388505177750-3').defineSizeMapping(mapping300).addService(googletag.pubads());  
   googletag.defineSlot('/53998264/728x90-Primary', [728, 90], 'ad-slot-leader').defineSizeMapping(mapping728).addService(googletag.pubads()); 
   
   googletag.pubads().setTargeting('SyncFusion','Power');

   // googletag.pubads().enableLazyLoad();
   googletag.pubads().disableInitialLoad();
   googletag.pubads().collapseEmptyDivs();
   googletag.enableServices();
});


googletag.cmd.push(function(){ 
  apstag.fetchBids({ 
  timeout: 2000 }, 
    function(bids) {
      apstag.setDisplayBids(); 
      googletag.pubads().refresh();
  }); 
}); 

}

</script>
</head>
<body onload="PR.prettyPrint()" style="background-color:white;">
<a name="top"></a>

<div name="container" id="container">
<div class="sticky-no">
<nav class="top-bar" data-topbar role="navigation">
<ul class="title-area">
<li class="name">
<a href="https://www.mssqltips.com/"><img alt="mssqltips logo" src="/images/mslogo_bw_89x45-2.png" width="89" height="45"></a>
</li>

<li class="toggle-topbar menu-icon"><a href="#"><span>Menu</span></a></li>
</ul>
<section class="top-bar-section">

<ul class="right">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'join'});" href="/get-free-sql-server-tips/?ref=JoinHeaderMenu"><span style="color:red;">Join</span></a></li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="#">Beginner</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/1948/sql-server/">What is SQL Server?</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6422/sql-server-concepts/">SQL Server Concepts</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/6429/sql-server-download-quick-links/">SQL Server Download Links</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertutorial/3700/my-first-sql-server-business-intelligence-project-tutorial/">My First BI Project </a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sqlservertip/2677/sql-server-career-planning/">SQL Server Career Plan</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'beginner'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="#">Tutorials</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9214/sql-server-101-tutorial-outline-and-overview/">SQL Server 101</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedures</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9131/sql-server-index-tutorial-overview/">Indexing</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tutorial'});" href="/sql-server-tutorials/">All Tutorials</a></li>
</ul>
</li>
<li class="has-dropdown"><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="#">DBA</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/60/database-administration/">Database Administration</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/276/sql-server-performance-tuning-and-monitoring-tutorial/">Performance Tuning</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/54/monitoring/">Monitoring</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9194/sql-server-extended-events-tutorial/">Extended Events</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/81/powershell/">PowerShell</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/27/sql-server-agent/">SQL Server Agent</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sqlservertutorial/9268/sql-server-management-studio-overview-ssms/">Management Studio</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/161/backup/">Backup</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/202/restore/">Restore</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-tip-category/143/availability-groups/">Availability Groups</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'dba'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="#">T-SQL</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertutorial/160/sql-server-stored-procedure-tutorial/">Stored Procedure Tutorial</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1667/sql-server-join-example/">SQL Server Join Example</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">CROSS APPLY + OUTER APPLY</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1599/cursor-in-sql-server/">Cursor in SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1160/execute-dynamic-sql-commands-in-sql-server/">Execute Dynamic SQL</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/4054/creating-a-date-dimension-or-calendar-table-in-sql-server/">Calendar Table</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sqlservertip/5993/sql-server-date-and-time-functions-with-examples/">Date and Time Functions</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'tsql'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="#">Analytics</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-tip-category/211/power-bi/">Power BI</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9053/sql-server-integration-services-ssis-2016-tutorial/">Integration Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-business-intelligence-resources/">Azure Data Factory</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9079/sql-server-reporting-services-ssrs-2017-installation-and-configuration-setup/">Reporting Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/4200/sql-server-analysis-services-2016-ssas-tutorial/">Analysis Services</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9073/sql-server-2017-and-python-basics/">Python</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sqlservertutorial/9040/getting-started-with-r-in-sql-server/">R</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-webcasts/">Webinars</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'bi'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="#">Cloud</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/205/amazon-aws/">AWS</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-tip-category/87/azure/">Azure</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'cloud'});" href="/sql-server-categories/">All Categories</a></li>
</ul>
</li>
<li class="has-dropdown hide-for-medium">
<a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="#">Tools</a>
<ul class="dropdown">
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6297/melissa-data-quality-solutions-for-ssis/?ps=melissa">Data Quality Tools</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6310/solarwinds-database-performance-analyzer-for-sql-server/?ps=solarwinds-dpa">Database Performance Analyzer</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6367/quest-foglight-for-databases/?ps=quest-foglight">Foglight for SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/6845/sql-diagnostic-manager-for-sql-server/?ps=sql-dm">SQL Diagnostic Manager for SQL Server</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/7159/solarwinds-sentryone-sql-server-performance-tuning/?ps=solarwinds-s1">SolarWinds SQL Sentry</a></li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'showcase'});" href="/sqlservertip/7224/dbi-performance-suite-for-db2-and-sql-server/?ps=dbi-software">DBI Web Performance Suite</a></li>
</ul>
</li>
<li><a onclick="gtag('event', 'click', {'event_category': 'hmenu', 'event_label': 'search'});" href="/search/"><span style="color:red;">Search</span></a></li>
</ul>
</section>
</nav>
</div>
<div class="row">
<div class="entry-content large-9 columns" role="content"> <h1>Power BI - How to Download and Get Started</h1>
<article>
<p>By: <a href="/sqlserverauthor/81/scott-murray/" rel="author" title="author profile for Scott Murray">Scott Murray</a> &nbsp;&nbsp;|&nbsp;&nbsp; Updated: 2022-06-29 &nbsp;&nbsp;|&nbsp;&nbsp; <a href="#comments" title="read and post comments">Comments</a> &nbsp;&nbsp;|&nbsp;&nbsp; Related: > <a href="/sql-server-tip-category/211/power-bi/">Power BI</a></p>
<br />
<h5>Problem</h5>
<p>How do I download and get started using Microsoft Power BI for my
organization's business intelligence needs?</p>
<div align="center" class="hide-for-print hide-for-small"> <div id="ad-slot-leader" style="width:728px; height:90px; min-width:728px; min-height:90px;"> <script type='text/javascript'> if (screen.width > 749) { googletag.cmd.push(function() {googletag.display('ad-slot-leader'); }); }	</script> </div></div><h5>Solution</h5>
<p>Getting started with Microsoft Power BI Desktop is actually not significantly complicated
at the base level, but thinking about using Power BI in an enterprise context certainly
requires research, analysis, use case reviews, and ultimately at budget evaluation.
Furthermore, Power BI can be used at all levels of organizations along with all
sizes of organizations from a small 1-person organization to a large multi-location,
global organization. However, to get started without answering all the above questions,
is as easy as downloading Power BI, selecting your data source type (on-premises
data, cloud platform, etc.), and then creating
a query against that data source. Thus, the first step is to download the Power
BI application as noted below.</p>
<p>Within this tutorial, we will be showing how to install the Power BI Desktop,
and then use it for several next steps. Thus, to get started
<a href="https://powerbi.microsoft.com/en-us/get-started/">Power BI Desktop must
be downloaded</a>. Additionally, we will be using the WideWorldImportersDW
database as a basis for our data sources. This database can be
<a href="https://github.com/Microsoft/sql-server-samples/releases/tag/wide-world-importers-v1.0">
downloaded from GitHub</a>.
</p>
<h2>Download Power BI Desktop, Install, and GO!</h2>
<p>Downloading any tool can be a challenge on just about any machine. A couple of
quick requirements are required for the machine where you will be installing Power
BI. These requirements include:</p>
<ul>
<li>Use a Windows based machine including Windows 10, Windows 11, Windows Server
2019, Windows Server 2016 among some other Windows machines versions</li>
<li>Use 32 bit or 64-bit machine and compare it to the installation file
</li>
</ul>
<p>Downloads can take place manually from the above-mentioned site. As an
alternative to the manual download, Power BI Desktop can be
<a href="https://www.microsoft.com/store/productId/9NTXR16HNW1T">downloaded from
the Microsoft.com APP Store</a>.</p>
<div class="imageborder">
<img loading="lazy" alt="Microsoft App Store" src="/tipimages2/7300_power-bi-download.001.png" height="651" width="900" />
</div>
<p>One of the advantages of using the Microsoft Store is that updates are often
automatically pushed to your machine. As these updates generally occur monthly,
having an automated push certainly helps to keep you on the latest version of Power
BI Desktop with minimal interaction. Certainly, some organizations block access
to the Microsoft store, which leaves the report designer needing to update the application
manually. Note, you will get a prompt in Power BI Desktop, in the bottom right
corner of your application, which notes that a new update is available.</p>
<p>Installing Power BI Desktop is as easy as most Windows installs; you select a
language, agree to the terms of service (you read them, right?), and selecting the
install file location.</p>
<div class="imageborder">
<img loading="lazy" alt="Install 1" src="/tipimages2/7300_power-bi-download.002.png" height="352" width="450" /><img loading="lazy" alt="Install 2" src="/tipimages2/7300_power-bi-download.003.png" height="352" width="450" /><img loading="lazy" alt="Install 3" src="/tipimages2/7300_power-bi-download.004.png" height="352" width="450" /><img loading="lazy" alt="Install 4" src="/tipimages2/7300_power-bi-download.005.png" height="352" width="450" /><img loading="lazy" alt="Install 6" src="/tipimages2/7300_power-bi-download.006.png" height="352" width="450" /><img loading="lazy" alt="Install 8" src="/tipimages2/7300_power-bi-download.007.png" height="352" width="450" />
<img loading="lazy" alt="Install 9" src="/tipimages2/7300_power-bi-download.008.png" height="352" width="450" /><img loading="lazy" alt="Install 10" src="/tipimages2/7300_power-bi-download.009.png" height="352" width="450" />
</div>
<p>Once you are ready to get started with Power BI Desktop, you must decide where
your data sets will be sourced. Obvious choices would be database systems such as
SQL Server, Oracle, or Teradata, but also some not so obvious choices like html
tables from a website or json files sourced either locally or maybe on a website
or API. Similarly, you could also use content that was published to the Power BI
service by your organization (curated data sets).</p>
<div class="imageborder">
<img loading="lazy" alt="start screen" src="/tipimages2/7300_power-bi-download.010.png" height="475" width="900" />
</div>
<p>If you do not have any readily available datasets, the best option is to use
the sample dataset provided with Power BI. Selecting the <strong>Try a sample dataset</strong>
option provides a tutorial option along with an option to load sample data set.
</p>
<div class="imageborder">
<img loading="lazy" alt="select sample dataset" src="/tipimages2/7300_power-bi-download.011.png" height="291" width="900" />
</div>
<div class="imageborder">
<img loading="lazy" alt="load sample data" src="/tipimages2/7300_power-bi-download.012.png" height="474" width="717" />
</div>
<p>The sample dataset contains a set of basic sales details, but it a useful place
to start designing your first dashboard. To be frank, if you have your own dataset,
especially one that may contain multiple tables, it would be useful to use that
dataset if available for testing and exploration.</p>
<div class="imageborder">
<img loading="lazy" alt="sample data" src="/tipimages2/7300_power-bi-download.013.png" height="547" width="900" />
</div>
<p>Likewise, Microsoft has provided some additional and more
<a href="https://docs.microsoft.com/en-us/power-bi/create-reports/sample-datasets">complex sample datasets
and pbix files</a> (pbix files are the file type used by Power BI). If
you use these samples, it is best to download Excel files or pbix files for your
use.</p>
<p>You will notice in the above screen print that upon selecting the data import,
the load data "Navigator" screen opens, often this is where some of
the confusion with Power BI starts. First you must select the tables / queries
you would like to use as your data source(s) by checking the appropriate boxes next
to each data source name. However, the broader choice that must be made is
whether you select the load option or the transform option. The transform
option brings up the Power Query Editor. This allows for the implementation of steps
to adjust the data in columns in rows by doing such things as filters, adding columns,
modifying data types, parse column data, and just about any other way to transform
data or adjust columns. </p>
<div class="imageborder">
<img loading="lazy" alt="Transform data" src="/tipimages2/7300_power-bi-download.014.png" height="506" width="900" />
</div>
<p>All of these changes are completed in the M language, step by step. The ordering
of those steps can be rearranged while steps can also be deleted / removed completely
as needed.</p>
<div class="imageborder">
<img loading="lazy" alt="M language advanced editor" src="/tipimages2/7300_power-bi-download.015.png" height="590" width="900" />
</div>
<p>As shown above the advanced editor allows for the writing of M code by hand which
is convenient when special coding in M is required, or you need to copy a large
number of steps.</p>
<p>As an alternative, many, but not all of the transformation that can be achieved
in the query editor can also be achieved in the design grid by creating new columns
or measures via DAX or by adding filters or slicers. Like M, DAX is a tool that
can be used to create and add logic to new columns and measures.</p>
<div class="imageborder">
<img loading="lazy" alt="Design Grid" src="/tipimages2/7300_power-bi-download.016.png" height="492" width="808" />
</div>
<p>As you are just starting out, the broader question is whether to do all your
work in the query editor or the design grid. Which is better, more efficient?
Where should I do my database modeling? Of course, the answer to these questions
is&hellip;.. it depends. However, we can certainly provide some guidance.
Generally, if work can be completed in the query layer, I will often recommend completing
transformations in that layer. Especially when dealing with filtering methods, completing
the processes in the query editor can provide performance and storage benefits which
are not available in DAX. Additionally, joins can take place both in query
editor via merge which allows for multiple key joins (and append for unioning));
on the contrary, joins are easy to complete in the design grid using the manage
relationship option (see below). However, using this method, only one field can
be used as the join field.</p>
<div class="imageborder">
<img loading="lazy" alt="joins" src="/tipimages2/7300_power-bi-download.017.png" height="559" width="900" />
</div>
<p>Similar to the relationship options for joins, both query editor and design grid
allow for the creation of new fields, and each offer both manual and GUI.</p>
<div class="imageborder">
<img loading="lazy" alt="add conditional column" src="/tipimages2/7300_power-bi-download.018.png" height="484" width="900" />
</div>
<p>Nevertheless, using the design grid, two options exist for adding a field, and
unlike the previous option about where to work with the data model, the selection
of a particular option here much clearer. Either a column can be added or
a measure. The difference between the two is significant, although both are created
and coded using DAX. A column occurs row by row, so every row is evaluated to determine
the appropriate values. However, a measure evaluates based on the entire data set,
so it is generally used for aggregation type of fields; something like a total of
ALL sales for instance. Since a DAX column evaluates row by row, it can trigger
performance issues when interacting with the design grid within extremely large
data sets.</p>
<p>A couple of other points need to be made at this juncture. Depending on the structure
of your organization, business logic and related code may reside in the data model
in Power BI OR it may be such that business logic resides completely with the database
via ETL/ELT using tools like SSIS or DBT. Either way the data must reside within
the model in query editor which establishes the source for the next steps in the
design process.</p>
<p>A second item that is often recommended is the establishment of a data table.
Depending on the granularity and the level or aggregation need for your date and
time series, it is often advantageous to create a data table as opposed to using
the built-in date hierarchy added to every date field in a data set. This tip shows
the process of creating a data table in M:
<a href="/sqlservertip/6756/power-bi-calendar-table/" target="_blank">
Create Calendar Table Using Power Query M Language</a> while
this tip reviews the process for creating a date table in DAX:
<a href="/sqlservertip/4857/creating-a-date-dimension-table-in-power-bi/" target="_blank">
Creating a Date Dimension Table in Power BI</a>. Furthering this point is this tip which outlines why using a date table can improve
performance and create a much more nimble process:
<a href="/sqlservertip/6517/improve-power-bi-performance-with-auto-datetime-and-dax-variables/" target="_blank">
Improve Power BI Performance with Auto Date/Time and DAX Variables</a>.</p>
<p>At this point, you are probably wondering when we will ever get to the dashboard
creation step; that is the next step in the process, but to get here, the data need
to be well formed and be ready to use which was all the prior steps. Likewise, this
step may seem to be "easy", but the report designer must keep in mind
that the visuals tell a story. That story needs to be:</p>
<ul>
<li>Clear</li>
<li>Easy to follow</li>
<li>Require little additional explanation</li>
<li>In many cases interactive including filtering and drill down</li>
<li>Be properly labeled, both at the visual, sheet, and dashboard levels
</li>
<li>Use appropriate colors and color palettes (<a href="https://www.storytellingwithdata.com/blog/2020/5/6/picking-the-right-colors?utm_source=pocket_mylist" target="_blank">choosing
colors for data visualization &mdash; storytelling with data</a>)</li>
<li>Garner additional questions (but not from lack of clarity)</li>
<li>Follow any organizational standards including coloring, logos, and security
</li>
<li>Not too cluttered (3x3 objects is often a good starting point)</li>
</ul>
<p>The actual process of adding the visual is simple; select the visual and drop
it on the grid. Add appropriate measures, categories, series, legends, etc.
</p>
<p>The tips can help you with the design:</p>
<ul>
<li>
<a href="/sqlservertip/4784/power-bi-visual-interactions/" target="_blank">
Power BI Visual Interactions</a>
</li>
<li>
<a href="/sqlservertip/4121/power-bi-desktop-custom-visualization/" target="_blank">
Power BI Desktop Custom Visualization</a>
</li>
<li>
<a href="/sqlservertip/5863/generate-visualizations-in-power-bi-using-python-scripts/" target="_blank">
Generate visualizations in Power BI using Python Scripts</a>
</li>
<li>
<a href="/sqlservertip/6265/power-bi-conditional-formatting-for-matrix-and-table-visuals/" target="_blank">
Power BI Report Conditional Formatting for Matrix and Table Visuals</a>
</li>
<li>
<a href="/sqlservertip/4785/power-bi-custom-infographics/" target="_blank">
Power BI Custom Infographics</a>
</li>
<li>
<a href="/sqlservertip/6733/power-bi-small-multiples/" target="_blank">
Power BI Small Multiples Visual Example</a>
</li>
<li>
<a href="/sqlservertip/6850/power-bi-slicer-dynamic-visuals/" target="_blank">
Dynamically Show or Hide a Visual in Power BI Based on Slicer Selection</a>
</li>
<li>
<a href="/sqlservertip/5547/anomaly-detection-without-any-coding-using-power-bi/" target="_blank">
Anomaly Detection without any coding using Power BI</a>
</li>
</ul>
<p>Plus, many more tips you can search for at:
<a href="/sql-server-tip-category/211/power-bi/" target="_blank">
SQL Server Power BI Tips</a>.</p>
<div class="imageborder">
<img loading="lazy" alt="New Visual" src="/tipimages2/7300_power-bi-download.019.png" height="444" width="899" />
</div>
<p>Thus, using the example below, we can start to formulate a better dashboard view.
The below visuals have several good points with the table headers being clear as
is the bar chart header. The ordering of the figures in the table and the
bars on the chart are both inline with easy reading. However, we could do
better. First, borders around both visuals would likely be helpful. Also,
the x axis is easy to read (except the label), but y axis is not. Also, it
is normally a good practice to set the headers to an equal height and width if possible.
</p>
<div class="imageborder">
<img loading="lazy" alt="dashboard example" src="/tipimages2/7300_power-bi-download.020.png" height="426" width="718" />
</div>
<p>By adjusting a few of the formatting properties for the visuals on the dashboard,
a more well-balanced dashboard begins to take shape, as illustrated next.</p>
<div class="imageborder">
<img loading="lazy" alt="Well done dashboard start" src="/tipimages2/7300_power-bi-download.021.png" height="378" width="719" />
</div>
<p>The below example actually shows going in the wrong direction for the design.
The color palette is hard to see with the blue background, and then yellow labels
on the axis. The actual visual tiles are not balanced at all. Between just those
two items, the effectiveness of the dashboard diminishes.</p>
<div class="imageborder">
<img loading="lazy" alt="bad dashboard" src="/tipimages2/7300_power-bi-download.022.png" height="485" width="900" />
</div>
<p>Once your dashboard is complete in Power BI desktop, the next step is to publish
to the Power BI Web Service online. By publishing to the web, you are taking the
dashboard that was available only to you (outside of sharing the PBIX file) and
allowing others to view it. You will need a Power BI organization account
in order to complete the publishing process as Microsoft only allows organizational
emails to setup an account (i.e., no gmail.com, yahoo.com, outlook.com, etc). After
logging into the account and clicking the Publish button provides the ability to
select which workspace (which is sort of like a container or folder) to publish
the dashboard to; these tips could be helpful concerning workspaces:
<a href="/sqlservertip/6487/power-bi-workspace-permissions-and-roles/" target="_blank">
Power BI Workspace Permissions and Roles</a>
and
<a href="/sqlservertip/6582/power-bi-workspace-management-with-powershell/" target="_blank">
Managing Power BI Workspaces with PowerShell</a>.
</p>
<div class="imageborder">
<img loading="lazy" alt="Publish" src="/tipimages2/7300_power-bi-download.023.png" height="428" width="900" />
</div>
<p>Finally, once publishing is complete, we can navigate to the Power Bi Service.
</p>
<div class="imageborder">
<img loading="lazy" alt="Publishing" src="/tipimages2/7300_power-bi-download.024.png" height="292" width="488" />
</div>
<div class="imageborder">
<img loading="lazy" alt="final report" src="/tipimages2/7300_power-bi-download.025.png" height="388" width="875" />
</div>
<p>In this tip, we covered the basic steps to getting started with Power BI. The
first step centers around importing the data. Next, the data must be curated to
get the model in a position to be used for the last step which is adding visuals
along with related data fields and measures.</p>
<h5>Next Steps</h5>
<ul>
<li>
<a href="/sql-server-tip-category/211/power-bi/" target="_blank">
SQL Server Power BI Tips</a></li>
<li>
<a href="/sqlservertip/6867/ssrs-vs-power-bi/" target="_blank">SSRS
vs Power BI</a></li>
<li>
<a href="/sqlservertip/6453/power-bi-best-practices/" target="_blank">Power BI Best Practices</a></li>
<li>
<a href="/sqlservertip/6117/publish-power-bi-report-to-power-bi-service/" target="_blank">Publishing from Power BI Desktop</a></li>
</ul>
<br /><br />
<div style="width:95%;">
<script src="https://fast.wistia.com/embed/medias/fbvlltguct.jsonp" async></script><script src="https://fast.wistia.com/assets/external/E-v1.js" async></script><div class="wistia_responsive_padding" style="padding:56.25% 0 0 0;position:relative;"><div class="wistia_responsive_wrapper" style="height:100%;left:0;position:absolute;top:0;width:100%;"><div class="wistia_embed wistia_async_fbvlltguct videoFoam=true" style="height:100%;position:relative;width:100%"><div class="wistia_swatch" style="height:100%;left:0;opacity:0;overflow:hidden;position:absolute;top:0;transition:opacity 200ms;width:100%;"><img src="https://fast.wistia.com/embed/medias/fbvlltguct/swatch" style="filter:blur(5px);height:100%;object-fit:contain;width:100%;" alt="" aria-hidden="true" onload="this.parentNode.style.opacity=1;" /></div></div></div></div>
<br>
<p style="text-align:center;"><a onclick="gtag('event', 'download', {'event_category': 'SolarWinds', 'event_label': 'ProdCommercial'});" href="https://www.solarwinds.com/database-insights-sql-server/registration?CMP=SYN-VID-MSSQL-SW_WW_X_RR_FLT_CQ_EN_DISSQL_SW-DISQL-X_X_X_VID_X-X" target="_blank">Get Started Now - Click here to get your free 14 day trial of SolarWinds Database Insights</a>
<br>
</div>
<div class="row">
<div class="large-6 medium-6 small-12 columns">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Related Articles</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '4475'});" href="/sqlservertip/4475/using-parameters-in-power-bi/">Using Parameters in Power BI</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '4621'});" href="/sqlservertip/4621/using-power-bi-with-json-data-sources-and-files/">Using Power BI with JSON Data Sources and Files</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '4841'});" href="/sqlservertip/4841/calculating-mtd-qtd-ytd-running-and-cumulative-total-in-power-bi/">Calculating MTD, QTD, YTD, Running and Cumulative Total in Power BI</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '5953'});" href="/sqlservertip/5953/create-power-bi-connection-to-azure-sql-database/">Create Power BI Connection to Azure SQL Database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6318'});" href="/sqlservertip/6318/read-api-data-with-power-bi-using-power-query/">Read API Data with Power BI using Power Query</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6362'});" href="/sqlservertip/6362/conditional-column-in-power-bi/">Conditional Column in Power BI</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6424'});" href="/sqlservertip/6424/calculate-percentage-growth-over-time-with-power-bi/">Calculate Percentage Growth Over Time with Power BI</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6487'});" href="/sqlservertip/6487/power-bi-workspace-permissions-and-roles/">Power BI Workspace Permissions and Roles</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6671'});" href="/sqlservertip/6671/dynamic-power-bi-slicer-using-dax-logic/">Dynamic Power BI Slicer Using DAX Logic</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6756'});" href="/sqlservertip/6756/power-bi-calendar-table/">Create Calendar Table Using Power Query M Language</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6860'});" href="/sqlservertip/6860/create-date-dimension-power-bi-text-columns/">How to Create Date Dimension Tables in Power BI from Text Columns</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6917'});" href="/sqlservertip/6917/working-days-calculator-power-bi/">Calculate Working Days in Power BI</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6951'});" href="/sqlservertip/6951/power-bi-desktop-external-tools/">Power BI Desktop External Tools and Why You Should be Using Them</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '6964'});" href="/sqlservertip/6964/schedule-export-email-power-bi-reports-power-automate/">Schedule, Export and Email Power BI Reports using Power Automate</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '7003'});" href="/sqlservertip/7003/text-strings-power-bi-dax/">Combine Text Strings in Power BI Using DAX</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '7033'});" href="/sqlservertip/7033/power-bi-concatenate-function-examples/">Power BI CONCATENATE Function: How and When to Use it</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '7061'});" href="/sqlservertip/7061/calculate-date-difference-power-bi-dax-datediff/">Dynamically Compute Different Time Duration in Power BI Using DAX</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '7086'});" href="/sqlservertip/7086/power-bi-navigation-features-improved-interactivity/">Power BI New Navigation Features</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '7100'});" href="/sqlservertip/7100/power-bi-concatenate-strings-power-query-m-language/">Concatenate Strings in Power BI Using Power Query M Language</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Related', 'event_label': '7133'});" href="/sqlservertip/7133/compute-fiscal-week-calculations-with-power-bi-and-dax/">Calculate Values for the Same Fiscal Week in a Previous Fiscal Year with Power BI and DAX</a><br><br>
</div>
</div>
<div class="large-6 medium-6 small-12 columns">
<div style="width:100%; background-color:#B00000;">
<h2 style="text-align:center; color:white;">Popular Articles</h2>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '1145'});" href="/sqlservertip/1145/date-and-time-conversions-using-sql-server/">Date and Time Conversions Using SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '2655'});" href="/sqlservertip/2655/format-sql-server-dates-with-format-function/">Format SQL Server Dates with FORMAT Function</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '1599'});" href="/sqlservertip/1599/cursor-in-sql-server/">SQL Server Cursor Example</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '1958'});" href="/sqlservertip/1958/sql-server-cross-apply-and-outer-apply/">SQL Server CROSS APPLY and OUTER APPLY</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '2914'});" href="/sqlservertip/2914/rolling-up-multiple-rows-into-a-single-row-and-column-for-sql-server-data/">Rolling up multiple rows into a single row and column for SQL Server data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '6769'});" href="/sqlservertip/6769/sql-server-drop-table-if-exists/">SQL Server DROP TABLE IF EXISTS Examples</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '6904'});" href="/sqlservertip/6904/sql-not-in-operator/">SQL NOT IN Operator</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '1140'});" href="/sqlservertip/1140/how-to-tell-what-sql-server-version-you-are-running/">How to tell what SQL Server versions you are running</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '2509'});" href="/sqlservertip/2509/add-and-subtract-dates-using-dateadd-in-sql-server/">Add and Subtract Dates using DATEADD in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '6452'});" href="/sqlservertip/6452/sql-convert-date-to-yyyymmdd/">SQL Convert Date to YYYYMMDD</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '2340'});" href="/sqlservertip/2340/resolving-could-not-open-a-connection-to-sql-server-errors/">Resolving could not open a connection to SQL Server errors</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '6148'});" href="/sqlservertip/6148/sql-server-loop-through-table-rows-without-cursor/">SQL Server Loop through Table Rows without Cursor</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '6481'});" href="/sqlservertip/6481/install-sql-server-integration-services-in-visual-studio-2019/">Install SQL Server Integration Services in Visual Studio 2019</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '1704'});" href="/sqlservertip/1704/using-merge-in-sql-server-to-insert-update-and-delete-at-the-same-time/">Using MERGE in SQL Server to insert, update and delete at the same time</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '2542'});" href="/sqlservertip/2542/display-line-numbers-in-a-sql-server-management-studio-query-window/">Display Line Numbers in a SQL Server Management Studio Query Window</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '2537'});" href="/sqlservertip/2537/sql-server-row-count-for-all-tables-in-a-database/">SQL Server Row Count for all Tables in a Database</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '6817'});" href="/sqlservertip/6817/sql-current-date/">How to Get Current Date in SQL Server</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '2779'});" href="/sqlservertip/2779/ways-to-compare-and-find-differences-for-sql-server-tables-and-data/">Ways to compare and find differences for SQL Server tables and data</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '2985'});" href="/sqlservertip/2985/concatenate-sql-server-columns-into-a-string-with-concat/">Concatenate SQL Server Columns into a String with CONCAT()</a><br><br>
</div>
<div style="line-height:120%;font-size:85%;padding-left:5px;">
<a onclick="gtag('event', '7300', {'event_category': 'Popular', 'event_label': '1522'});" href="/sqlservertip/1522/searching-and-finding-a-string-value-in-all-columns-in-a-sql-server-table/">Searching and finding a string value in all columns in a SQL Server table</a><br><br>
</div>
</div>
</div>
<br /><br /><br />
<div class="row">
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/download-scripts/" onclick="gtag('event', 'click', {'event_category': 'Scripts', 'event_label': 'BotTip'});" target="_blank"><img loading="lazy" border="0" src="/images/Free-Download_20190509.png" alt="get scripts" width="300" height="150"></a></div>
<br />
</div>
<div class="large-6 columns">
<div align="center" class="hide-for-print"><a href="/sql-server-tip-category/211/power-bi/" onclick="gtag('event', 'click', {'event_category': 'NextTip', 'event_label': 'YellowArrow'});"><img loading="lazy" border="0" src="/images/nav_nexttip_clickhere_rev1.png" alt="next tip button" width="300" height="150"></a></div>
<br />
</div>
</div>
<br /><br />
<h5>About the author</h5>
<div class="row">
<div class="large-12 columns">
<a href="/sqlserverauthor/81/scott-murray/"><img loading="lazy" style="float: left; padding: 0px 10px 0px 0px;" alt="MSSQLTips author Scott Murray" height="150" src="/images/ScottMurray.jpg" width="100" /></a>
Scott Murray has a passion for crafting BI Solutions with SharePoint, SSAS, OLAP and SSRS.
<br /><br /><b><a href="/sqlserverauthor/81/scott-murray/">View all my tips</a></b>
</div>
</div>
<br /><br />
Article Last Updated: 2022-06-29
<a name="comments"></a>
</article>
<div class="row">
</div>
<div class="hide-for-print">
<hr>
<h2>Comments For This Article</h2>
<button class="button round" data-reveal-id="myModal" data-reveal-ajax="/zurb_comments.asp?id=1x7300">Add Comment</button>
<div id="myModal" class="reveal-modal" data-reveal aria-labelledby="modalTitle" aria-hidden="true" role="dialog">
</div>
<style type="text/css">
.ForumPostBodyArea
{
	width: 100%;
	vertical-align: top;
	overflow: auto;
}
</style>
<br /><br /><br />
</div>
</div>
<style>
			div.stickyright {
			  position: -webkit-sticky;
			  position: sticky;
			  padding: 0;
			  background-color: white;
			  width: 300px;
			  z-index: 1;
			}
	</style>
<div class="large-3 hide-for-print columns rightsize">
<br />
<div align="center" class="hide-for-print"><a href="https://s.surveyplanet.com/d7ib5olr " onclick="gtag('event', 'click', {'event_category': 'download-button', 'event_label': 'survey-perf'});" target="_blank"><img loading="lazy" src="/images/Performance_Monitoring_Survey_20220715.png" alt="download" width="300"></a></div>
<br /><br />

<div align="center">
<div id='div-gpt-ad-1388505177750-0' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-0'); });
	}	
	</script>
</div>
</div><br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-3' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-3'); });
	}	
	</script>
</div>
</div> <br /><br /><br />
<div align="center">
<div id='div-gpt-ad-1388505177750-1' style='width:300px; height:600px; min-width: 300px; min-height: 600px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-1'); });
	}
	</script>
</div>
</div> <br /><br /><br />
<div class="stickyright" style="top:55px;">

<div align="center">
<div id='div-gpt-ad-1388505177750-2' style='width:300px; height:250px; min-width:300px; min-height:250px;'>
<script type='text/javascript'>
	if (screen.width > 749)
	{	
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1388505177750-2'); });
	}	
	</script>
</div>
</div> <br /><br /><br /> <script language="Javascript">
	function ValidateEmail(inputText)
	{
	
		if (document.optin.consent.checked == false) {
		     alert("Please agree to terms by ticking check box.");
		     return false;
	            }	
	   
		var mailformat = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
		if(inputText.value.match(mailformat))
		{
			document.optin.ea.focus();
			return true;
		}
		else
		{
			alert("You have entered an invalid email address!");
			document.optin.ea.focus();
			return false;
		}
	}

	</script>
<div id="sticky2">
<div id="search-div" style="height:300px; width:300px">
<div id="signup-div">
<div style="text-align: center;"><a href="/get-free-sql-server-tips/?ref=LeftGFSTSlant"><img loading="lazy" alt="get free sql tips" border="0" src="/images/GetFreeSQLTips_black_box.png" width="300" height="150"></a></div>
<form action="/get-free-sql-server-tips/" method="post" name="optin" onsubmit="return ValidateEmail(document.optin.ea)">
<input name="URL" type="hidden" value="leftform" />
<input name="ReferralURL" type="hidden" value="" />
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-10 columns">
<input size="25" type="text" onblur="if (this.value=='') this.value=this.defaultValue" onclick="if (this.defaultValue==this.value) this.value=''" value="enter business email" name="ea">
</div>
<div class="small-2 columns">
<input type="submit" name="Button1" value="Join" />
</div>
</div>
</div>
</div>
<div class="row">
<div class="large-12 columns">
<div class="row collapse">
<div class="small-1 columns">
<input type="checkbox" name="consent" value="1">
</div>
<div class="small-11 columns">
<a href="/privacy/" target="_blank"><img loading="lazy" src="/images/mssqltips-agree-terms.png" alt="agree to terms" width="276" height="67"></a> 
</div>
</div>
</div>
</div>
<br /><br />
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<footer class="row hide-for-print">
<hr />
<ul class="small-block-grid-2 medium-block-grid-3 large-block-grid-6" style="margin:10px;">
<li>
<h3><span style="color:#3B6D93">Follow</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=GetFooterMenu">Get Free SQL Tips</a></li>
<li><a rel="noopener" href="https://twitter.com/mssqltips" target="_blank">Twitter</a></li>
<li><a rel="noopener" href="https://www.linkedin.com/groups/2320891/" target="_blank">LinkedIn</a></li>
<li><a rel="noopener" href="https://www.facebook.com/mssqltips/" target="_blank">Facebook</a></li>
<li><a rel="noopener" href="https://www.pinterest.com/mssqltips/" target="_blank">Pinterest</a></li>
<li><a rel="noopener" href="https://feeds.feedburner.com/MSSQLTips-LatestSqlServerTips" target="_blank">RSS</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Learning</span></h3>
<ul>
<li><a href="/sql-server-dba-resources/">DBAs</a></li>
<li><a href="/sql-server-developer-resources/">Developers</a></li>
<li><a href="/sql-server-business-intelligence-resources/">BI Professionals</a></li>
<li><a href="/sql-server-professional-development-resources/">Careers</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Resources</span></h3>
<ul>
<li><a href="/sql-server-tutorials/">Tutorials</a></li>
<li><a href="/sql-server-webcasts/">Webcasts</a></li>
<li><a href="/sql-server-whitepapers/">Whitepapers</a></li>
<li><a href="/sql-server-tools/">Tools</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Search</span></h3>
<ul>
<li><a href="/sql-server-categories/">Tip Categories</a></li>
<li><a href="/search-tip-id/">Search By TipID</a></li>
<li><a href="/sql-server-mssqltips-authors/">Authors</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">Community</span></h3>
<ul>
<li><a href="/learn-more-about-mssqltips/">First Timer?</a></li>
<li><a href="/mssqltips-community/1/">Pictures</a></li>
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/sql-server-event-list/">Event Calendar</a></li>
<li><a href="/sql-server-user-groups/">User Groups</a></li>
<li><a href="/mssqltips-author-of-year/">Author of the Year</a></li>
</ul>
</li>
<li>
<h3><span style="color:#3B6D93">More Info</span></h3>
<ul>
<li><a href="/get-free-sql-server-tips/?ref=JoinFooterMenu">Join</a></li>
<li><a href="/about/">About</a></li>
<li><a href="/copyright/">Copyright</a></li>
<li><a href="/privacy/">Privacy</a></li>
<li><a href="/disclaimer/">Disclaimer</a></li>
<li><a href="/feedback/">Feedback</a></li>
<li><a href="/advertise/">Advertise</a></li>
</ul>
</li>
</ul>
<hr />
<div class="row">
<div class="large-12 columns text-center">
<p>Copyright (c) 2006-2022 <a href="https://www.edgewoodsolutions.com">Edgewood Solutions, LLC</a> All rights reserved<br />
<small>Some names and products listed are the registered trademarks of their respective owners.</small></p>
</div>
</div>
</footer>

<style type="text/css">
#slideboxtop{
    width:100%;
    height:50px;
    padding:0px;
    background-color:#FFFFFF;      
    border-bottom:1px solid #000000;
    position:fixed;
    top: -350px;
	-moz-box-shadow:-2px 0px 5px #aaa;
	-webkit-box-shadow:-2px 0px 5px #aaa;
/* 	box-shadow:-2px 0px 5px #aaa;    */
}
</style>
<div class="hide-for-small hide-for-medium hide-for-print">
<div id="slideboxtop" style="z-index:1;">
<div style="text-align:center">
<div w3-include-html="/Site-Sponsorship/site-sponsorship.asp"></div>
</div>
</div>
</div>
<script src="/js/jquery-foundation-combined-min.js"></script>
<script type="text/javascript">
var articleLength = $("article").find("p").length;

 

</script>
<script>
    $(document).foundation();
</script>
<script type="text/javascript" src="/css/prettify.combined.js" defer></script>
<script type="text/javascript">
$(function() {
	$(window).scroll(function(){
		if  ($(window).scrollTop() > 250)
			$('#slideboxtop').animate({'top':'0px'});
		else
			$('#slideboxtop').stop(true).animate({'top':'-250px'});
	});
});
</script>
<script>
function includeHTML() {
  var z, i, elmnt, file, xhttp;
  /*loop through a collection of all HTML elements:*/
  
  z = document.getElementsByTagName("*");
  for (i = 0; i < z.length; i++) {
    elmnt = z[i];
    /*search for elements with a certain atrribute:*/
    file = elmnt.getAttribute("w3-include-html");
	if (file) {
      /*make an HTTP request using the attribute value as the file name:*/
      xhttp = new XMLHttpRequest();
      xhttp.onreadystatechange = function() {
        if (this.readyState == 4) {
          if (this.status == 200) {elmnt.innerHTML = this.responseText;}
          if (this.status == 404) {elmnt.innerHTML = "Page not found.";}
          /*remove the attribute, and call this function once more:*/
          elmnt.removeAttribute("w3-include-html");
          includeHTML();
        }
      }   
      xhttp.open("GET", file, true);
      xhttp.send();
      /*exit the function:*/
      return;
    }
  }
};
</script>
<script>
 if ($(window).width() > 1000) {
	includeHTML();
	$("div.rightsize").height($("#container").height());
    }	
</script>

<script> 
//<![CDATA[ 
if (screen.width > 0)
{
function deferGoogleJS() { 
var d = document.createElement("script"); 
d.src = "https://www.googletagmanager.com/gtag/js?id=UA-910745-2", 
document.body.appendChild(d) 
} 
window.addEventListener ? window.addEventListener("load", deferGoogleJS, !1) : window.attachEvent ? window.attachEvent("onload", deferGoogleJS) : window.onload = deferGoogleJS; 
window.dataLayer = window.dataLayer || [];

function gtag() { 
dataLayer.push(arguments); 
} 
gtag('js', new Date()); 
gtag('config', 'UA-910745-2'); 
}
//]]> 
</script>
</body>
</html>
